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Tutorial 1: 
Open Source Tools for S&T Data Analysis and Visualization

Katy Börner
Victor H. Yngve Professor of Information Science
Director, Cyberinfrastructure for Network Science Center
School of Informatics and Computing, Indiana University, USA

ISSI , Rectorate Conference Hall
Istanbul, Turkey

9:00‐11:00, 11:15‐13:00
June 29, 2015

Please 
‐ download the Sci2 Tool from http://sci2.cns.iu.edu
‐ these slides http://cns.iu.edu/docs/presentations/2015‐borner‐issi‐tutorial.pdf
‐ and complete the Pre‐Tutorial Questionnaire
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Tutorial Overview

9:00  Welcome and Overview of Tutorial and Attendees
9:30  The Sci2 Tool 
• Download and run the Sci2 Tool
• ONE dataset, MANY analyses and visualizations
10:00 Sci2 Tool Workflows
• Temporal Analysis: Horizontal line graph of NSF projects
• Geospatial Analysis: US and world maps
• Geospatial Analysis: Geomap with network overlays
• Topical Analysis: Visualize research profiles
• Network Analysis: Co‐occurrence networks and bimodal networks
• Network Analysis: Evolving collaboration networks
11:00 Networking Break
11:15 Visualization Framework
11:45 IVMOOC – MANY more Workflows
12:15 Plug‐and‐Play Macroscopes
12:30 Outlook and Q&A
13:00 Adjourn
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The Sci2 Tool: 
A Plug‐and‐Play Macroscope that implements 

the Visualization Framework
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Software, Datasets, Plugins, and Documentation
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• These slides 
http://cns.iu.edu/docs/presentations/2015‐borner‐issi‐tutorial.pdf

• Sci2 Tool Manual v0.5.1 Alpha, updated to match v1.0 Alpha tool release 
http://sci2.wiki.cns.iu.edu

• Sci2 Tool v 1.1 beta 
http://sci2.cns.iu.edu

• Additional Datasets 
http://sci2.wiki.cns.iu.edu/2.5+Sample+Datasets

• Additional Plugins
http://sci2.wiki.cns.iu.edu/3.2+Additional+Plugins

Make sure you have Java 1.6 (32‐bit suffices) or higher installed or download from 
http://www.java.com/en/download. To check your Java version, open a terminal 
and run 'java ‐version'.
Some visualizations are saved as Postscript files. A free Postscript to PDF viewer is 
at http://ps2pdf.com and a free PDF Viewer at 
http://www.adobe.com/products/reader.html. 

Install and Run Sci2 

10

Sci2 Tool runs on Windows, Mac, and Linux. 

Unzip.

Run /sci2/sci2.exe
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Sci2 Tool Interface Components
See also http://sci2.wiki.cns.iu.edu/2.2+User+Interface

11

Use
• Menu to read data, run 

algorithms.
• Console to see work log, 

references to seminal works.
• Data Manager to select, view, 

save loaded, simulated, or 
derived datasets.

• Scheduler to see status of 
algorithm execution. 

All workflows are recorded into a log file (see /sci2/logs/…), and can be re‐run for 
easy replication. If errors occur, they are saved in a error log to ease bug reporting.

All algorithms are documented online; workflows are given in Sci2 Manual at 
http://sci2.wiki.cns.iu.edu

Sci2 Tool Interface Components
Download for free at http://sci2.cns.iu.edu
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Load One File and Run Many Analyses and Visualizations

13

Times 
Cited

Publication 
Year

City of 
Publisher

Country Journal Title 
(Full)

Title Subject 
Category

Authors

12 2011 NEW YORK USA COMMUNIC
ATIONS OF 
THE ACM

Plug‐and‐Play 
Macroscopes

Computer 
Science

Borner, K

18 2010 MALDEN USA CTS‐
CLINICAL 
AND 
TRANSLATIO
NAL 
SCIENCE

Advancing the 
Science of Team 
Science

Research & 
Experimental 
Medicine

Falk‐Krzesinski, HJ|Borner, 
K|Contractor, N|Fiore, 
SM|Hall, KL|Keyton, 
J|Spring, B|Stokols, 
D|Trochim, W|Uzzi, B

13 2010 WASHINGTON USA SCIENCE 
TRANSLATIO
NAL 
MEDICINE

A Multi‐Level Systems 
Perspective for the 
Science of Team 
Science

Cell Biology 
|Research & 
Experimental 
Medicine

Borner, K|Contractor, 
N|Falk‐Krzesinski, HJ|Fiore, 
SM|Hall, KL|Keyton, 
J|Spring, B|Stokols, 
D|Trochim, W|Uzzi, B
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many other 
bi‐modal networks.
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Load One File and Run Many Analyses and Visualizations

15

Download  20publications.csv from
http://wiki.cns.iu.edu/download/attachments/12
45848/20publications.csv?version=1&modificatio
nDate=1403450235951

In Sci2, use ‘File > Load’ and load file as ‘Standard 
csv format’. 
Run ‘Data Preparation > Extract Co‐Occurrence 
Network’ with parameters:

Co‐author network will appear in Data Manager.

Load One File and Run Many Analyses and Visualizations

16

Run ‘Analysis > Network Analysis Toolkit (NAT)’ to get basic properties:

Nodes: 65
Isolated nodes: 0
Edges: 404
No self loops were discovered. 
Average degree: 12.4308
The largest connected component consists of 65 nodes.
Density (disregarding weights): 0.1942 

Select ‘Extracted Network on Column Authors’ network in Data Manager and run 
‘Visualization > GUESS’ to open GUESS with file loaded.
Initial layout is random:

In GUESS, apply ‘Layout > GEM’:
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Sci2 Workflows

Light, Robert, David E. Polley, and Katy Börner. 2014. "Open Data and Open 
Code for Big Science of Science Studies". Scientometrics 101 (2): 1535-1551. 
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Tutorial Overview
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13:00 Adjourn
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Horizontal line graph of  NSF projects
See 5.2.1 Funding Profiles of  Three Universities (NSF Data)

19

Download NSF data                                  Visualize as Horizontal Line Graph 

Start date End date

Area size equals numerical 
value, e.g., award amount.

Text

Horizontal line graph of  NSF projects

20

NSF Awards Search via http://www.nsf.gov/awardsearch

Save in CSV format as *institution*.nsf
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Download and load a dataset of  your choice or load one of  the sample data files, e.g., 
‘sampledata/scientometrics/nsf/Indiana.nsf.’ 

Run ‘Visualization > Temporal > Temporal Bar Graph’ using parameters:

Save ‘visualized with Horizontal Line Graph’ as ps or eps file. Convert into pdf and view. 

Zoom to see details in visualizations of  large datasets, e.g., all NSF awards ever made.

Temporal bar graph of  NSF projects

21
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TLS: Towards a Macroscope for Science Policy Decision Making

SciSIP Funding 
for Sci2 Tool

Seven grants by 
the “Indiana 
University of 
Pennsylvania 
Research 
Institute”  should 
be excluded. 
Rerun analysis.
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TLS: Towards a Macroscope for Science Policy Decision Making

Start date End date

Area size equals numerical 
value, e.g., award amount.

Text, e.g., title

Date of  Data Download

Temporal bar graph of  NSF projects

26

More NSF data workflows can be found in wiki tutorial:
5.1.3 Funding Profiles of  Three Researchers at Indiana University (NSF Data)
5.2.1 Funding Profiles of  Three Universities (NSF Data)
5.2.3 Biomedical Funding Profile of  NSF (NSF Data)

Start date End date

Area size equals numerical 
value, e.g., award amount.

Text, e.g., title
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2828

Geocoding and Geospatial Maps
http://wiki.cns.iu.edu/display/CISHELL/Bing+Geocoder

• Data with 
geographic 
identifiers

Geocode

• Geolocated
data

Aggregate (if  
necessary) • Geographic 

identifiers 
with data

Visualize

Geocoordinates + numeric data 
(Proportional Symbol Map)

Region names + numeric data 
(Choropleth Map)
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Load File with Address and Times Cited Fields

Run ‘File > Load…’ and select the sample data table ‘sampledata/geo/usptoInfluenza.csv’

Create a map of influenza patents held by different countries.

3030
http://wiki.cns.iu.edu/display/CISHELL/Bing+Geocoder

Bing Geocoder
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3131

Run ‘Analysis > Geospatial > Bing Geocoder’

Using Bing Geocoder

Enter your Bing app key. 
You can obtain one from here..  

3232

Aggregate by Country

Aggregate Data was selected.
Implementer(s): Chintan Tank
Documentation: http://wiki.cns.iu.edu/display/CISHELL/Aggregate+Data
Input Parameters:
Aggregate on column: Country
Delimiter for Country: | 
Longitude: AVERAGE
Latitude: AVERAGE
Times Cited: SUM
Aggregated by '': All rows of  Latitude column were skipped due to no non-null, non-empty values.
Aggregated by '': All rows of  Longitude column were skipped due to no non-null, non-empty values.
Frequency of  unique "Country" values added to "Count" column.
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3333

Right-click and Save map as 
PostScript file. Use PostScript 
Viewer or convert to pdf to 
view.

Choropleth Map 

34

Legend shows 
how data matches 
up with visual 
representation

Header shows visualization type, 
data description, and creation date

34

Reading the Choropleth Map
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3535

Proportional Symbol Map 

Right-click and Save map as 
PostScript file. Use PostScript 
Viewer or convert to pdf to 
view.

36

Legend shows how data 
matches up with visual 
representation

Header shows visualization type, 
data description, and creation date

36

Reading the Proportional Symbol Map
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37
http://wiki.cns.iu.edu/display/SCI2TUTORIAL/5.2.4+Mapping+Scientometrics+%28ISI+Data%29

Relevant Sci2 Manual entry
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38
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Geomap with Gephi Network Overlay
See 4.7.6 on http://sci2.wiki.cns.iu.edu

39

Use Bing Geocoder to identify Latitude, Longitude for each geolocation
Extract attributes per geolocation, e.g., total times cited (TC)
Extract linkages and their attributes, e.g., number of  co-occurences
See sample /geo/LaszloBarabasiGeo.net with co-occurrence of  “Research 
Addresses” and full counting of  TC per geolocation.

File with 
geolocations and
linkage info, e.g., 
an isi biblio-
graphy file.

Read into Sci2 Tool to generate 
geomap and network file

Layout network in Gephi Combine geomap and 
network in Photoshop

+ =

40

http://sci2.wiki.cns.iu.edu/display/SCI2TUTORIAL/4.7+Geospatial+Analysis+%28Where%29#4.
7GeospatialAnalysis%28Where%29-4.7.6UsingGephitoRenderNetworksOverlaidonGeoMaps

Relevant Sci2 Manual entry
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41

Use Sci2 Tool to Generate Geomap and Network File

Read prepared .net file and run:

Save map file as Postscript file and use Adobe or other view to read. It looks like:

Save .net file as GraphML (Prefuse) and 
rename to .graphml so that Gephi can read it.

42

Use Gephi to Generate Network Layout

Start gephi. Use New Project > Open a graph file to read .graphml file that Sci2 generated.

Follow instructions in online tutorial on Manipulating the Network File in Gephi
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43

Use Gephi to Generate Network Layout

Color or size code the “Near Alaska” and “Near Antarctica” anchor nodes to ease alignment 
of  geomap and network overlay, see instructions in online tutorial on Manipulating the 
Network File in Gephi. Save result using File > Export > SVG/PDF file.

44

Use Photoshop to Overlay Network on Geomap

Load geomap and network files into Photoshop. Select ‘network’ layer an use ‘Right click, 
Duplicate Layer’ to copy network over to ‘geomap’ file as a second layer. 
Use Edit > Transform > Scale’ and align using the “Near Antarctica” anchor nodes, see 
instructions in online tutorial on Creating the Visualization in Photoshop.
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45

Use Photoshop to Overlay Network on Geomap

Delete anchor nodes and save in preferred format.

46



24

Practice these steps using “LaszloBarabasi-collaborations.net” linked from Sci2 wiki: 
4.7.6 Using Gephi to Render Networks Overlaid on GeoMaps

47

Rounded edges might increase legibility of
overlapping lines.

Tutorial Overview

9:00  Welcome and Overview of Tutorial and Attendees
9:30  The Sci2 Tool 
• Download and run the Sci2 Tool
• ONE dataset, MANY analyses and visualizations
10:00 Sci2 Tool Workflows
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• Network Analysis: Evolving collaboration networks
11:00 Networking Break
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13:00 Adjourn
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Topical Analysis: 
Research Profiles

Data: WoS and Scopus paper level data for 
2001–2010, about 25,000 separate journals, 
proceedings, and series.
Similarity Metric: Combination of 
bibliographic coupling and keyword vectors.
Number of Disciplines: 554 journal clusters 
further aggregated into 13 main disciplines.
Börner, Katy, Richard Klavans, et al. (2012) Design 
and Update of  a Classification System: The UCSD 
Map of  Science. PLoS ONE 7(7): e39464. 
doi:10.1371/journal.pone.0039464

50

Research Profiles—Publication Data

Load an ISI (*.isi), Bibtex (*.bib), Endnote Export Format (*.enw), Scopus csv
(*.scopus) file such as /sci2/sampledata/scientometrics/isi/FourNetSciResearchers.isi

Run ‘Visualization > Topical > Science Map via Journals’
using parameters given to the right.

Postscript file will appear in Data Manager. 
Save and open with a Postscript Viewer.



26



27
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Research Profiles—Existing Classifications

In addition to using journal names to
- Map career trajectories
- Identify evolving expertise areas
- Compare expertise profiles
Existing classifications can be aligned and used to generate science map overlays.

Run Visualization > Topical > Science Map via 554 Fields
using parameters given to the right.
Postscript file will appear in Data Manager. 
Save and open with a Postscript Viewer.
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55

Align Science Basemaps using the Sci2 Tool

UCSD Map                           Loet et al science maps ISI categories     http://vosviewer.com

NIH Map
Elsevier’s SciVal Map                       Science-Metrix.com                     (https://app.nihmaps.org) 
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56
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General Network Extraction:
Weighted, Undirected Co-Occurrence Network

Author co-occurrence network

57

*Vertices 6
1 A1 
2 A6 
3 A2 
4 A3 
5 A5 
6 A4 
*Edges 6
2 3 2 
1 4 1 
1 5 1 
5 6 1 
1 6 1 
2 5 1 

58

General Network Extraction:
Unweighted, Directed Bipartite Network

Paper-author bipartite (2-mode) network

*Vertices 12
1 P1 bipartitetype "Paper" 
2 A1 bipartitetype "Authors" 
3 P2 bipartitetype "Paper" 
4 A2 bipartitetype "Authors" 
5 A6 bipartitetype "Authors" 
6 P3 bipartitetype "Paper" 
7 A3 bipartitetype "Authors" 
8 P4 bipartitetype "Paper" 
9 A4 bipartitetype "Authors" 
10 A5 bipartitetype "Authors" 
11 P5 bipartitetype "Paper" 
12 P6 bipartitetype "Paper" 
*Arcs 
1 2 
3 4 
3 5 
6 2 
6 7 
8 2 
8 10 
8 9 
11 5 
11 10 
12 4 
12 5 

Author
Paper
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59

General Network Extraction:
Unweighted, Directed Network

59

*Vertices 12
1 P1 indegree 0 
2 A1 indegree 3 
3 P2 indegree 0 
4 A2 indegree 2 
5 A6 indegree 3 
6 P3 indegree 0 
7 A3 indegree 1 
8 P4 indegree 0 
9 A4 indegree 1 
10 A5 indegree 2 
11 P5 indegree 0 
12 P6 indegree 0 
*Arcs 
1 2 
3 4 
3 5 
6 2 
6 7 
8 10 
8 2 
8 9 
11 10 
11 5 
12 4 
12 5 

Author
Paper

60

General Network Extraction:
Unweighted, Directed Paper-Citation Network

60

*Vertices 6
1 P1 
2 P2 
3 P3 
4 P4 
5 P5 
6 P6 
*Arcs 
2 1 
3 1 
3 2 
4 2 
5 4 
5 3 
5 1 
5 2 
6 5 

1970           1980         1990        1995        2000

Arcs from  papers to references
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General Network Extraction:
Unweighted, Directed Bi-Partite Network

61

*Vertices 11
1 P1 bipartitetype "Paper" 
2 P2 bipartitetype "Paper" 
3 P1 bipartitetype "References" 
4 P3 bipartitetype "Paper" 
5 P2 bipartitetype "References" 
6 P4 bipartitetype "Paper" 
7 P5 bipartitetype "Paper" 
8 P4 bipartitetype "References" 
9 P3 bipartitetype "References" 
10 P6 bipartitetype "Paper" 
11 P5 bipartitetype "References" 
*Arcs 
2 3 
4 3 
4 5 
6 5 
7 3 
7 9 
7 5 
7 8 
10 11 

WRONG!!!

62

ISI Paper-Citation Network Extraction

62
2000            2001            2002

Arcs from  references to papers—
in the direction of  information flow
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• Network Analysis: Co‐occurrence networks and bimodal networks
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11:00 Networking Break
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13:00 Adjourn

63

Evolving collaboration networks

64
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Evolving Collaboration Networks

65

Load isi formatted file

As csv, file looks like:

Visualize each time slide separately: 

66
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Relevant Sci2 Manual entry
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67
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Slice Table by Time

68
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Visualize Each Network, Keep Node Positions

1. To see the evolution of  Vespignani's co-authorship network over time, check ‘cumulative’. 

2. Extract co-authorship networks one at a time for each sliced time table using 'Data 
Preparation > Extract Co-Author Network', making sure to select "ISI" from the pop-up 
window during the extraction.  

3. To view each of  the Co-Authorship Networks over time using the same graph layout, 
begin by clicking on longest slice network (the 'Extracted Co-Authorship Network' under 'slice 
from beginning of  1990 to end of  2006 (101 records)') in the data manager. Visualize it in 
GUESS using 'Visualization > Networks >  GUESS'. 

4. From here, run 'Layout > GEM' followed by 'Layout > Bin Pack'.  Run 'Script > Run Script
…' and select ' yoursci2directory/scripts/GUESS/co-author-nw.py'.

5. In order to save the x, y coordinates of  each node and to apply them to the other time 
slices in GUESS, select 'File > Export Node Positions' and save the result as 
'yoursci2directory/NodePositions.csv'. Load the remaining three networks in GUESS using the 
steps described above and for each network visualization, run 'File > Import Node Positions'
and open 'yoursci2directory/NodePositions.csv'.

6. To match the resulting networks stylistically with the original visualization, run 'Script > 
Run Script …' and select 'yoursci2directory/scripts/GUESS/co-author-nw.py', followed by 'Layout > 
Bin Pack', for each.  
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69
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Visualize Each Network, Keep Node Positions

70

http://cishell.wiki.cns.iu.edu/Slice+Table+by+Time

Relevant CIShell plugin
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Network Visualization with GUESS

Pan:
“grab” the background 
by holding left-click and 
moving your mouse.

Zoom:
Using scroll wheel, press 
the “+” and “-” buttons 
in the upper-left hand 
corner, or right-click and 
move the mouse left or 
right. Center graph by 
selecting ‘View -> 
Center’.

Select        to 
select/move single 
nodes. Hold down ‘Shift’ 
to select multiple.

Right click node/edge to 
modify Color, Shape, etc.

72

Network Visualization 
with GUESS

Graph Modifier:
Select “all nodes” in the Object 
drop-down menu and click ‘Show 
Label’ button. 

Select ‘Resize Linear > Nodes > 
times_cited’ drop-down menu, 
then type “5” and “20” into the 
From” and To” Value box 
separately. Then select ‘Do Resize 
Linear’.

Select ‘Colorize> 
Nodes>totalities’, then select 
white and enter (204,0,51) in the 
pop-up color boxes on in the 
“From” and “To” buttons.

Select “Format Node Labels”, 
replace default text {originallabel} 
with your own label in the pop-up 
box ‘Enter a formatting string for 
node labels.’
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Network Visualization with GUESS

Interpreter uses Jython a combination of  Java and Python.

Try
resizeLinear(times_cited,1,20)
colorize(times_cited, white, red)

BREAK

74
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Tutorial Overview

9:00  Welcome and Overview of Tutorial and Attendees
9:30  The Sci2 Tool 
• Download and run the Sci2 Tool
• ONE dataset, MANY analyses and visualizations
10:00 Sci2 Tool Workflows
• Temporal Analysis: Horizontal line graph of NSF projects
• Geospatial Analysis: US and world maps
• Geospatial Analysis: Geomap with network overlays
• Topical Analysis: Visualize research profiles
• Network Analysis: Co‐occurrence networks and bimodal networks
• Network Analysis: Evolving collaboration networks
11:00 Networking Break
11:15 Visualization Framework
11:45 IVMOOC – MANY more Workflows
12:15 Plug‐and‐Play Macroscopes
12:30 Outlook and Q&A
13:00 Adjourn

75

Visualization Framework

76
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Theoretically Grounded and Practically Useful 
Visualization Framework 

developed to empower the broadest spectrum of users to read 
and make data visualizations that are useful and meaningful to 
them. 

The visualization framework was used to
• design the aforementioned study and 
• develop plug‐and‐play macroscope tools that improve the 

data visualization literacy of researchers, practitioners, 
IVMOOC students, museum visitors, and others. 

Börner, Katy. 2015. Atlas of Knowledge: Anyone Can Map. The MIT Press. 
http://scimaps.org/atlas2

77

Tasks

78See page 5
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Workflow Design

Börner, Katy. 2015. Atlas of Knowledge: Anyone Can Map. The MIT Press. 
http://scimaps.org/atlas2

79

Needs‐Driven Workflow Design

Stakeholders

Data

READ ANALYZE VISUALIZE

DEPLOY

Validation

Interpretation

Visually 
encode 
data

Overlay 
data

Select 
visualiz. 
type

Types and levels of analysis determine
data, algorithms & parameters, and 
deployment
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Needs‐Driven Workflow Design

Stakeholders

Data

READ ANALYZE VISUALIZE

DEPLOY

Validation

Interpretation

Visually 
encode 
data

Overlay 
data

Select 
visualiz. 
type

Types and levels of analysis determine
data, algorithms & parameters, and 
deployment

Types

Börner, Katy. 2015. Atlas of Knowledge: Anyone Can Map. The MIT Press. 
http://scimaps.org/atlas2

82
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Types

83

See page 24
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Visualization Types (Reference Systems)

1. Charts: No reference system—e.g., Wordle.com, pie charts

2. Tables: Categorical axes that can be selected, reordered; cells 
can be color coded and might contain proportional symbols. 
Special kind of graph. 

3. Graphs: Quantitative or qualitative (categorical) axes. 
Timelines, bar graphs, scatter plots. 

4. Geospatial maps: Use latitude and longitude reference 
system. World or city maps.

5. Network layouts: Node position might depends on node 
attributes or node similarity. Trees: hierarchies, taxonomies, 
genealogies. Networks: social networks, migration flows.

Types

Börner, Katy. 2015. Atlas of Knowledge: Anyone Can Map. The MIT Press. 
http://scimaps.org/atlas2

86
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88See page 36
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89See pages 36‐39

Information Visualization MOOC (IVMOOC)
Teaches the 

Visualization Framework and The Sci2 Tool

90
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Register for free at http://ivmooc.cns.iu.edu. Class restarted in January 13, 2015.
91

The Information Visualization MOOC
ivmooc.cns.iu.edu

Students from more than 100 countries
350+ faculty members

#ivmooc

92
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Course Schedule

Part 1: Theory and Hands‐On

• Session 1 – Workflow Design and Visualization Framework

• Session 2 – “When:” Temporal Data

• Session 3 – “Where:” Geospatial Data

• Session 4 – “What:” Topical Data

Mid‐Term

• Session 5 – “With Whom:” Trees

• Session 6 – “With Whom:” Networks

• Session 7 – Dynamic Visualizations and Deployment

Final Exam

Part 2: Students work in teams on client projects.

Final grade is based on Class Participation (10%), Midterm (30%), Final Exam 
(30%), and Client Project(30%). 

93

Teaches timeless knowledge:

Visualization framework—
exemplified using generic 
visualization examples and 
pioneering visualizations. 

Teaches timely 
knowledge:

Advanced algorithms, 
tools, and hands‐on 
workflows.

Books Used in the IVMOOC

94
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Visualization Frameworks

How to Classify Different Visualizations?

By

• User insight needs?

• User task types?

• Data to be visualized? 

• Data transformation?

• Visualization technique?

• Visual mapping transformation?

• Interaction techniques?

• Or ?
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Find your way

Find collaborators, friends

Identify trends

Terabytes of data

Descriptive &
Predictive
Models

97

Different Question Types

Different Levels of Abstraction/Analysis

Macro/Global

Population Level

Meso/Local

Group Level

Micro

Individual Level
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Type of Analysis vs. Level of Analysis

Micro/Individual
(1‐100 records)

Meso/Local
(101–10,000 records)

Macro/Global
(10,000 < records) 

Statistical 
Analysis/Profiling 

Individual person and 
their expertise profiles

Larger labs, centers, 
universities, research 
domains, or states

All of NSF, all of USA, all 
of science.

Temporal Analysis 
(When)

Funding portfolio of 
one individual

Mapping topic bursts 
in 20 years of PNAS

113 years of physics 
research

Geospatial Analysis 
(Where)

Career trajectory of one 
individual  

Mapping a state’s 
intellectual landscape

PNAS publications 

Topical Analysis 
(What)

Base knowledge from 
which one grant draws.

Knowledge flows in 
chemistry research 

VxOrd/Topic maps of 
NIH funding

Network Analysis 
(With Whom?)

NSF Co‐PI network of 
one individual  

Co‐author network  NIH’s core competency 
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Type of Analysis vs. Level of Analysis

Micro/Individual
(1‐100 records)

Meso/Local
(101–10,000 records)

Macro/Global
(10,000 < records) 

Statistical 
Analysis/Profiling 

Individual person and 
their expertise profiles

Larger labs, centers, 
universities, research 
domains, or states

All of NSF, all of USA, all 
of science.

Temporal Analysis 
(When)

Funding portfolio of 
one individual

Mapping topic bursts 
in 20‐years of PNAS

113 years of physics 
research

Geospatial Analysis 
(Where)

Career trajectory of one 
individual  

Mapping a states 
intellectual landscape

PNAS publications 

Topical Analysis 
(What)

Base knowledge from 
which one grant draws.

Knowledge flows in 
chemistry research 

VxOrd/Topic maps of 
NIH funding

Network Analysis 
(With Whom?)

NSF Co‐PI network of 
one individual  

Co‐author network  NIH’s core competency 

100
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Clients

http://ivmooc.cns.iu.edu/clients.html

101

Diogo Carmo

102
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mjstamper_ivmooc

103

Plug‐and‐Play Macroscopes

104
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Börner, Katy. (2011). 

Plug‐and‐Play Macroscopes.
Communications of the 
ACM, 54(3), 60‐69. 

Video and paper are at
http://www.scivee.tv/node/27704

105

Designing “Dream Tools”

Many of the best micro‐, tele‐, and macroscopes are designed by 

scientists keen to observe and comprehend what 
no one has seen or understood before. Galileo Galilei 
(1564–1642) recognized the potential of a spyglass for the study of the 
heavens, ground and polished his own lenses, and used the improved optical 
instruments to make discoveries like the moons of Jupiter, providing 
quantitative evidence for the Copernican theory. 

Today, scientists repurpose, extend, and invent new hardware and 

software to create “macroscopes” that may solve both 

local and global challenges.

CNS Macroscope tools empower me, my students, colleagues, and 
more than 100,000 others that downloaded them. 

106
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Macroscopes
Decision making in science, industry, and politics, as well as in daily life, requires that 
we make sense of data sets representing the structure and dynamics of complex 
systems. Analysis, navigation, and management of these continuously evolving data 
sets require a new kind of data‐analysis and visualization tool we call a macroscope
(from the Greek macros, or “great,” and skopein, or “to observe”) inspired by de 
Rosnay’s futurist science writings. 
Macroscopes provide a “vision of the whole,” helping us “synthesize” the related 
elements and enabling us to detect patterns, trends, and outliers while granting access 
to myriad details. Rather than make things larger or smaller, macroscopes let us 
observe what is at once too great, slow, or complex for the human eye and mind to 
notice and comprehend.

107

Plug‐and‐Play Macroscopes

Inspire computer scientists to implement software frameworks that 

empower domain scientists to assemble their own continuously evolving 
macroscopes, adding and upgrading existing (and removing obsolete) plug‐ins to arrive 
at a set that is truly relevant for their work—with little or no help from computer 
scientists. 

While microscopes and telescopes are physical instruments, macroscopes
resemble continuously changing bundles of software plug‐ins.
Macroscopes make it easy to select and combine algorithm and tool plug‐ins but also 
interface plug‐ins, workflow support, logging, scheduling, and other plug‐ins needed for 
scientifically rigorous yet effective work. 

They make it easy to share plug‐ins via email, flash drives, or online. To use new plugins, 
simply copy the files into the plug‐in directory, and they appear in the tool menu ready 
for use. No restart of the tool is necessary. Sharing algorithm components, 
tools, or novel interfaces becomes as easy as sharing images on 
Flickr or videos on YouTube. Assembling custom tools is as quick 
as compiling your custom music collection.

108
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Changing Scientific Landscape—Personal 
Observations

109

Different datasets/formats.
Diverse algorithms/tools written in 
many programming languages. Physics

SNA

IS

Bio
CS

Related Work 

Google Code and SourceForge.net provide special means for developing and distributing software
 In August 2009, SourceForge.net hosted more than 230,000 software projects by two million 

registered users (285,957 in January 2011); 
 In August 2009 ProgrammableWeb.com hosted 1,366 application programming interfaces 

(APIs) and 4,092 mashups (2,699 APIs and 5,493 mashups in January 2011) 

Cyberinfrastructures serving large biomedical communities
 Cancer Biomedical Informatics Grid (caBIG) (http://cabig.nci.nih.gov) 
 Biomedical Informatics Research Network (BIRN) (http://nbirn.net)
 Informatics for Integrating Biology and the Bedside (i2b2) (https://www.i2b2.org)
 HUBzero (http://hubzero.org) platform for scientific collaboration uses 
 myExperiment (http://myexperiment.org) supports the sharing of scientific workflows and 

other research objects. 

Missing so far is a common standard for 

 the design of modular, compatible algorithm and tool plug‐ins (also called 
“modules” or “components”) 

 that can be easily combined into scientific workflows (“pipeline” or “composition”), 

 and packaged as custom tools.

110
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OSGi & CIShell 

CIShell
Sci2 Tool

NWB Tool

CIShell Wizards

Developers

 CIShell (http://cishell.org) is an open source software specification for the 
integration and utilization of datasets, algorithms, and tools. 

 It extends the Open Services Gateway Initiative (OSGi) (http://osgi.org), a 
standardized, component oriented, computing environment for networked services 
widely used in industry since more than 10 years. 

 Specifically, CIShell provides “sockets” into which existing and new datasets, 

algorithms, and tools can be plugged using a wizard‐driven process.

Users

Alg

Tool

Tool

Alg

Alg

Workflow

Workflow

Workflow

Workflow

112

CIShell Portal and Developer Guide 
(http://cishell.org)
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Changing Scientific Landscape—Personal 
Observations Cont.

113

Common algorithm/tool pool
Easy way to share new algorithms
Workflow design logs
Custom tools TexTrend

NWB

EpiC

Sci2
Converters

IS
CS
Bio
SNA
Phys

OSGi/CIShell Adoption
CIShell/OSGi is at the core of different CIs and a total of 169 unique plugins are used in the 
‐ Information Visualization (http://iv.slis.indiana.edu), 
‐ Network Science (NWB Tool) (http://nwb.slis.indiana.edu), 
‐ Scientometrics and Science Policy (Sci2 Tool) (http://sci.slis.indiana.edu), and 
‐ Epidemics (http://epic.slis.indiana.edu) research communities. 

Most interestingly, a number of other projects recently adopted OSGi and one adopted CIShell:
Cytoscape (http://www.cytoscape.org) lead by Trey Ideker, UCSD is an open source bioinformatics 

software platform for visualizing molecular interaction networks and integrating these interactions 
with gene expression profiles and other state data (Shannon et al., 2002). Bruce visits Mike Smoot 
in 2009

Taverna Workbench (http://taverna.sourceforge.net) lead by Carol Goble, University of Manchester, 
UK is a free software tool for designing and executing workflows (Hull et al., 2006). Taverna allows 
users to integrate many different software tools, including over 30,000 web services. Micah, June 
2010

MAEviz (https://wiki.ncsa.uiuc.edu/display/MAE/Home) managed by Shawn Hampton, NCSA is an 
open‐source, extensible software platform which supports seismic risk assessment based on the 
Mid‐America Earthquake (MAE) Center research.

TEXTrend (http://www.textrend.org) lead by George Kampis, Eötvös University, Hungary develops a 
framework for the easy and flexible integration, configuration, and extension of plugin‐based 
components in support of natural language processing (NLP), classification/mining, and graph 
algorithms for the analysis of business and governmental text corpuses with an inherently 
temporal component.

As the functionality of OSGi‐based software frameworks improves and the number and diversity of 
dataset and algorithm plugins increases, the capabilities of custom tools will expand. 
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CIShell/Sci2 World and Science Visualizations
of NIH RePORTER Data

Re-Run Workflows 

Run ‘File > Read Directory Hierarchy’ using parameters:

‘Visualize > Networks >  Tree Map’:

118

Bonus: Re-Run Workflow
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Re-Run Workflows 

Delete file in Data Manager

In Workflow Manager

Right click Workflow and ‘Run’:

119

Bonus: Re-Run Workflow

Adding a new algorithm to Sci2 is easy. Simply use the Wizard driven process:

120

Bonus: How to create a new Sci2 plugin
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Adding a new algorithm to Sci2 is easy. Simply use the Wizard driven process:

121

Bonus: How to create a new Sci2 plugin
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Adding a new 
algorithm to Sci2 is 
easy. Simply use the 
Wizard driven 
process.

See also

http://wiki.cns.iu.edu
/display/CISHELL/Hell
o+World+Tutorial

http://cishell.wiki.cns
.iu.edu/Home
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Adding a new algorithm to Sci2 is easy. Simply use the Wizard driven process:

123

Bonus: How to create a new Sci2 plugin

Adding a new algorithm to Sci2 is easy. Simply use the Wizard driven process:

124

Bonus: How to create a new Sci2 plugin
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Tutorial Overview

9:00  Welcome and Overview of Tutorial and Attendees
9:30  The Sci2 Tool 
• Download and run the Sci2 Tool
• ONE dataset, MANY analyses and visualizations
10:00 Sci2 Tool Workflows
• Temporal Analysis: Horizontal line graph of NSF projects
• Geospatial Analysis: US and world maps
• Geospatial Analysis: Geomap with network overlays
• Topical Analysis: Visualize research profiles
• Network Analysis: Co‐occurrence networks and bimodal networks
• Network Analysis: Evolving collaboration networks
11:00 Networking Break
11:15 Visualization Framework
11:45 IVMOOC – MANY more Workflows
12:15 Plug‐and‐Play Macroscopes
12:30 Outlook and Q&A
13:00 Adjourn
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All papers, maps, tools, talks, press are linked from http://cns.iu.edu
These slides will soon be at http://cns.iu.edu/docs/presentations

CNS Facebook: http://www.facebook.com/cnscenter
Mapping Science Exhibit Facebook: http://www.facebook.com/mappingscience
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