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 These slides
http://ivl.slis.indiana.edu/km/pres/2013-borner-sci2tutorial-scits.pdf

 Sci2 Tool Manual v0.5.1 Alpha, updated to match v1.0 Alpha tool release
http://sci2.wiki.cns.iu.edu

 Sci2 Tool v1.0 Alpha (June 13, 2012) 
http://sci2.cns.iu.edu

 Additional Datasets 
http://sci2.wiki.cns.iu.edu/2.5+Sample+Datasets

 Additional Plugins
http://sci2.wiki.cns.iu.edu/3.2+Additional+Plugins

 Make sure you have Java 1.6 (32-bit suffices) or higher installed or download 
from http://www.java.com/en/download.  To check your Java version, open a 
terminal and run 'java -version'.

 Some visualizations are saved as Postscript files. A free Postscript to PDF 
viewer is at http://ps2pdf.com and a free PDF Viewer at 
http://www.adobe.com/products/reader.html. 



8:30a  Welcome and Overview of Tutorial and Attendees

8:45a  Sci2 Tool Hands-on
 Download and run the Sci2 Tool
 Temporal Analysis: Horizontal line graph of NSF projects
 Geospatial Analysis: US and world maps
 Geospatial Analysis: Geomap with network overlays

10-10:30a Networking Break

 Topical Analysis: Visualize research profiles
 Network Analysis: Co-occurrence networks and bimodal networks
 Network Analysis: Evolving collaboration networks

12:30p  IVMOOC
12:45p  Outlook and Q&A

1:00p Adjourn

Tutorial Overview
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Using the Sci2 Tool to Visualize Tutorial Registrants

Use ‘File > Read’ to load cleaned SciTS-Workshop-attendee-info.csv with 17 records

6

Using the Sci2 Tool to Visualize Tutorial Registrants

Run ‘Data Preparation > Extract Bipartite Network’

With parameter values:

Visualize resulting ‘Bipartite network from Affiliation to Background’ using ‘Visualization > 

Network > GUESS’ and ‘Layout > GEM’, ‘Layout > Bin Pack’
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Sci2 Tool – Visualize Tutorial Attendees:
Bi-partite Name-Role Network

Role

Name
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Sci2 Tool – Visualize Tutorial Attendees:
Bi-partite Name-Role Network

Role

Name
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Science of Science (Sci2) Tool
http://sci2.cns.iu.edu

 Explicitly designed for SoS research and practice, well documented, easy to use. 

 Empowers many to run common studies while making it easy for exports to 
perform novel research.

 Advanced algorithms, effective visualizations, and many (standard) workflows. 

 Supports micro-level documentation and replication of studies.

 Is open source—anybody can review and extend the code, or use it for 
commercial purposes.

10



Sci2 Tool v0.5.2 Alpha (Dec 19, 2011)
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New Features
 Support new Web of  Science format from ISI
 Support network overlay for geographical map
 Support Prefuse's visualizations on Macs OS 

Improvements
 Improve memory usage and processing time of  Extract top N nodes and 

Extract top N Edges algorithms
 Unify merging algorithms used by database 

Bug fixes
 Fix legend boundary issue in geographical map
 Fix typo error on the output data label
 Fix slice by year algorithm

Sci2 Tool v1.0 Alpha (June 13, 2012)
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Major Release 
featuring a Web services compatible CIShell v2.0 (http://cishell.org)

New Features
 Google Scholar citation reader 
 New visualizations such as 

 geospatial maps
 science maps
 bi-modal network layout

 R statistical tool bridging
 Gephi visualization tool bridging
 Comprehensive online documentation 

Release Note Details
http://wiki.cns.iu.edu/display/SCI2TUTORIAL/4.4+Sci2+Release+Notes+v1.0+alpha



Sci2 Tool v1.1 Alpha (planned for August 2013)
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New Features
 Twitter, Facebook, and Flickr readers
 Bing Geocoder
 Flow map visualization, see below
 Comprehensive online documentation 

Bug fixes
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Micro/Individual
(1-100 records)

Meso/Local
(101–10,000 records)

Macro/Global
(10,000 < records) 

Statistical 
Analysis/Profiling 

Individual person and 
their expertise profiles

Larger labs, centers, 
universities, research 
domains, or states

All of NSF, all of USA, 
all of science.

Temporal Analysis 
(When)

Funding portfolio of 
one individual

Mapping topic bursts 
in 20-years of PNAS

113 Years of Physics 
Research

Geospatial Analysis 
(Where)

Career trajectory of one 
individual  

Mapping a states 
intellectual landscape

PNAS publciations 

Topical Analysis 
(What)

Base knowledge from 
which one grant draws.

Knowledge flows in 
Chemistry research 

VxOrd/Topic maps of 
NIH funding

Network Analysis 
(With Whom?)

NSF Co-PI network of 
one individual  

Co-author network NIH’s core competency 

Type of Analysis vs. Level of Analysis



Needs-Driven Workflow Design using a modular data acquisition/analysis/ 
modeling/ visualization pipeline as well as modular visualization layers.

Börner, Katy (2010) Atlas of  Science. MIT Press. 15

Sci2 Tool – Supported Data Formats

Input:

Network Formats 

 GraphML (*.xml or *.graphml)

 XGMML (*.xml)

 Pajek .NET (*.net)

 NWB (*.nwb)

Scientometric Formats 

 ISI (*.isi)

 Bibtex (*.bib)

 Endnote Export Format (*.enw)

 Scopus csv (*.scopus)

 NSF csv (*.nsf)

Other Formats 

 Pajek Matrix (*.mat)

 TreeML (*.xml)

 Edgelist (*.edge)

 CSV (*.csv)

Formats are documented at http://sci2.wiki.cns.iu.edu/display/SCI2TUTORIAL/2.3+Data+Formats.  
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Output:
Network File Formats
 GraphML (*.xml or *.graphml)
 Pajek .MAT (*.mat)
 Pajek .NET (*.net)
 NWB (*.nwb)
 XGMML (*.xml)
 CSV (*.csv)

Image Formats

 JPEG (*.jpg)

 PDF (*.pdf)

 PostScript (*.ps) 



Sci2 Tool – Supported Tools

Gnuplot

portable command-line driven 
interactive data and function plotting 
utility http://www.gnuplot.info/.

GUESS

exploratory data analysis and visualization tool 
for graphs and networks. 

https://nwb.slis.indiana.edu/community/?n=Vi
sualizeData.GUESS. 
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Sci2 Tool – Supported Tools
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Adding more layout algorithms and network visualization interactivity 

via Cytoscape http://www.cytoscape.org. 

Simply add org.textrend.visualization.cytoscape_0.0.3.jar into your /plugin directory.

Restart Sci2 Tool

Cytoscape now shows in the Visualization Menu

Select a network in Data Manager, run Cytoscape and the tool will start with this 
network loaded.



Sci2 Tool – Bridged Tools

19

R statistical tool bridging

Gephi visualization tool bridging 

20

Sci2 Tool: Download, Install, and Run

Sci2 Tool v1.0 Alpha (June 13, 2012)
Can be freely downloaded for all major 
operating systems from 
http://sci2.cns.iu.edu

Select your operating system from the 
pull down menu and download. 
Unpack into a /sci2 directory.
Run /sci2/sci2.exe

Sci2 Manual is at
http://sci2.wiki.cns.iu.edu

Cite as 
Sci2 Team. (2009). Science of  Science (Sci2) Tool. 
Indiana University and SciTech Strategies, 
http://sci2.cns.iu.edu . 
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Sci2 Tool: Download, Install, and Run

Sci2 Tool v1.0 Alpha (June 13, 2012)
Sci2 Tool runs on Windows, Mac, and Linux.

Unzip.

Run /sci2/sci2.exe

22

Sci2 Tool Interface Components
See also http://sci2.wiki.cns.iu.edu/2.2+User+Interface

Use

 Menu to read data, run 
algorithms.

 Console to see work log, 
references to seminal works.

 Data Manager to select, view, 
save loaded, simulated, or 
derived datasets.

 Scheduler to see status of 
algorithm execution.

All workflows are recorded into a log file (see /sci2/logs/…), and soon can be re-
run for easy replication. If  errors occur, they are saved in a error log to ease bug 
reporting.
All algorithms are documented online; workflows are given in tutorials, see Sci2 
Manual at http://sci2.wiki.cns.iu.edu
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Horizontal line graph of  NSF projects
See 5.2.1 Funding Profiles of  Three Universities (NSF Data)

24

Download NSF data                                  Visualize as Horizontal Line Graph 

Start date End date

Area size equals numerical 
value, e.g., award amount.

Text



Horizontal line graph of  NSF projects
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NSF Awards Search via http://www.nsf.gov/awardsearch

Save in CSV format as *institution*.nsf

Download and load a dataset of  your choice or load one of  the sample data files, e.g., 
‘sampledata/scientometrics/nsf/Indiana.nsf.’ 

Run ‘Visualization > Temporal > Temporal Bar Graph’ using parameters:

Save ‘visualized with Horizontal Line Graph’ as ps or eps file. Convert into pdf and view. 

Zoom to see details in visualizations of  large datasets, e.g., all NSF awards ever made.

Temporal bar graph of  NSF projects
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TLS: Towards a Macroscope for Science Policy Decision Making

SciSIP Funding 
for Sci2 Tool



Seven grants by 
the “Indiana 
University of 
Pennsylvania 
Research 
Institute”  should 
be excluded. 
Rerun analysis.

TLS: Towards a Macroscope for Science Policy Decision Making

Start date End date

Area size equals numerical 
value, e.g., award amount.

Text, e.g., title

Date of  Data Download



Temporal bar graph of  NSF projects
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More NSF data workflows can be found in wiki tutorial:
5.1.3 Funding Profiles of  Three Researchers at Indiana University (NSF Data)
5.2.1 Funding Profiles of  Three Universities (NSF Data)
5.2.3 Biomedical Funding Profile of  NSF (NSF Data)

Start date End date

Area size equals numerical 
value, e.g., award amount.

Text, e.g., title
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Geocoding and Geospatial Maps
http://wiki.cns.iu.edu/display/CISHELL/Yahoo+Geocoder

• Data with 
geographic 
identifiers

Geocode

• Geolocated
data

Aggregate (if  
necessary) • Geographic 

identifiers 
with data

Visualize

Geocoordinates + numeric data 
(Proportional Symbol Map)

Region names + numeric data 
(Choropleth Map)

3434

Load File with Address and Times Cited Fields

Run ‘File > Load…’ and select the sample data table ‘sampledata/geo/usptoInfluenza.csv’

Create a map of influenza patents held by different countries.
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http://wiki.cns.iu.edu/display/CISHELL/Yahoo+Geocoder

Yahoo Geocoder

3636
http://wiki.cns.iu.edu/display/CISHELL/Bing+Geocoder

Yahoo Geocoder
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Run ‘Analysis > Geospatial > Yahoo Geocoder’

Using Yahoo! Geocoder

You can leave Application ID blank for 
trial purposes, but for heavy use, register 
for your own personal Yahoo! 
Application ID, see:
http://developer.yahoo.com/geo/placefinder/

3838

Aggregate by Country

Aggregate Data was selected.
Implementer(s): Chintan Tank
Documentation: http://wiki.cns.iu.edu/display/CISHELL/Aggregate+Data
Input Parameters:
Aggregate on column: Country
Delimiter for Country: | 
Longitude: AVERAGE
Latitude: AVERAGE
Times Cited: SUM
Aggregated by '': All rows of  Latitude column were skipped due to no non-null, non-empty values.
Aggregated by '': All rows of  Longitude column were skipped due to no non-null, non-empty values.
Frequency of  unique "Country" values added to "Count" column.
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Right-click and Save map as 
PostScript file. Use PostScript 
Viewer or convert to pdf to 
view.

Choropleth Map 

40

Legend shows 
how data matches 
up with visual 
representation

Header shows visualization type, 
data description, and creation date

40

Reading the Choropleth Map
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Proportional Symbol Map 

Right-click and Save map as 
PostScript file. Use PostScript 
Viewer or convert to pdf to 
view.

42

Legend shows how data 
matches up with visual 
representation

Header shows visualization type, 
data description, and creation date

42

Reading the Proportional Symbol Map
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http://wiki.cns.iu.edu/display/SCI2TUTORIAL/5.2.4+Mapping+Scientometrics+%28ISI+Data%29

Relevant Sci2 Manual entry
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Geomap with Gephi Network Overlay
See 4.7.6 on http://sci2.wiki.cns.iu.edu
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Use Yahoo! Geocoder to identify Latitude, Longitude for each geolocation
Extract attributes per geolocation, e.g., total times cited (TC)
Extract linkages and their attributes, e.g., number of  co-occurences
See sample /geo/LaszloBarabasiGeo.net with co-occurrence of  “Research 
Addresses” and full counting of  TC per geolocation.

File with 
geolocations and
linkage info, e.g., 
an isi biblio-
graphy file.

Read into Sci2 Tool to generate 
geomap and network file

Layout network in Gephi Combine geomap and 
network in Photoshop

+ =

46

http://sci2.wiki.cns.iu.edu/display/SCI2TUTORIAL/4.7+Geospatial+Analysis+%28Where%29#4.
7GeospatialAnalysis%28Where%29-4.7.6UsingGephitoRenderNetworksOverlaidonGeoMaps

Relevant Sci2 Manual entry
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Use Sci2 Tool to Generate Geomap and Network File

Read prepared .net file and run:

Save map file as Postscript file and use Adobe or other view to read. It looks like:

Save .net file as GraphML (Prefuse) and 
rename to .graphml so that Gephi can read it.

48

Use Gephi to Generate Network Layout

Start gephi. Use New Project > Open a graph file to read .graphml file that Sci2 generated.

Follow instructions in online tutorial on Manipulating the Network File in Gephi
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Use Gephi to Generate Network Layout

Color or size code the “Near Alaska” and “Near Antarctica” anchor nodes to ease alignment 
of  geomap and network overlay, see instructions in online tutorial on Manipulating the 
Network File in Gephi. Save result using File > Export > SVG/PDF file.

50

Use Photoshop to Overlay Network on Geomap

Load geomap and network files into Photoshop. Select ‘network’ layer an use ‘Right click, 
Duplicate Layer’ to copy network over to ‘geomap’ file as a second layer. 
Use Edit > Transform > Scale’ and align using the “Near Antarctica” anchor nodes, see 
instructions in online tutorial on Creating the Visualization in Photoshop.
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Use Photoshop to Overlay Network on Geomap

Delete anchor nodes and save in preferred format.

52



Practice these steps using “LaszloBarabasi-collaborations.net” linked from Sci2 wiki: 
4.7.6 Using Gephi to Render Networks Overlaid on GeoMaps

53

Rounded edges might increase legibility of
overlapping lines.

8:30a  Welcome and Overview of Tutorial and Attendees

8:45a  Sci2 Tool Hands-on
 Download and run the Sci2 Tool
 Temporal Analysis: Horizontal line graph of NSF projects
 Geospatial Analysis: US and world maps
 Geospatial Analysis: Geomap with network overlays

10-10:30a Networking Break

 Topical Analysis: Visualize research profiles
 Network Analysis: Co-occurrence networks and bimodal networks
 Network Analysis: Evolving collaboration networks

12:30p  IVMOOC
12:45p  Outlook and Q&A

1:00p Adjourn

Tutorial Overview

54



55

Topical Analysis: 
Research Profiles

Data: WoS and Scopus paper level data for 
2001–2010, about 25,000 separate journals, 
proceedings, and series.
Similarity Metric: Combination of 
bibliographic coupling and keyword vectors.
Number of Disciplines: 554 journal clusters 
further aggregated into 13 main disciplines.
Börner, Katy, Richard Klavans, et al. (2012) Design 
and Update of  a Classification System: The UCSD 
Map of  Science. PLoS ONE 7(7): e39464. 
doi:10.1371/journal.pone.0039464

56

Research Profiles—Publication Data

Load an ISI (*.isi), Bibtex (*.bib), Endnote Export Format (*.enw), Scopus csv
(*.scopus) file such as /sci2/sampledata/scientometrics/isi/FourNetSciResearchers.isi

Run ‘Visualization > Topical > Science Map via Journals’
using parameters given to the right.

Postscript file will appear in Data Manager. 
Save and open with a Postscript Viewer.
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Research Profiles—Existing Classifications

In addition to using journal names to
- Map career trajectories
- Identify evolving expertise areas
- Compare expertise profiles
Existing classifications can be aligned and used to generate science map overlays.

Run Visualization > Topical > Science Map via 554 Fields
using parameters given to the right.
Postscript file will appear in Data Manager. 
Save and open with a Postscript Viewer.
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Align Science Basemaps using the Sci2 Tool

UCSD Map                           Loet et al science maps ISI categories     http://vosviewer.com

NIH Map
Elsevier’s SciVal Map                       Science-Metrix.com                     (https://app.nihmaps.org) 
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General Network Extraction:
Weighted, Undirected Co-Occurrence Network

Author co-occurrence network

63

*Vertices 6
1 A1 
2 A6 
3 A2 
4 A3 
5 A5 
6 A4 
*Edges 6
2 3 2 
1 4 1 
1 5 1 
5 6 1 
1 6 1 
2 5 1 
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General Network Extraction:
Unweighted, Directed Bipartite Network

Paper-author bipartite (2-mode) network

*Vertices 12
1 P1 bipartitetype "Paper" 
2 A1 bipartitetype "Authors" 
3 P2 bipartitetype "Paper" 
4 A2 bipartitetype "Authors" 
5 A6 bipartitetype "Authors" 
6 P3 bipartitetype "Paper" 
7 A3 bipartitetype "Authors" 
8 P4 bipartitetype "Paper" 
9 A4 bipartitetype "Authors" 
10 A5 bipartitetype "Authors" 
11 P5 bipartitetype "Paper" 
12 P6 bipartitetype "Paper" 
*Arcs 
1 2 
3 4 
3 5 
6 2 
6 7 
8 2 
8 10 
8 9 
11 5 
11 10 
12 4 
12 5 

Author
Paper
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General Network Extraction:
Unweighted, Directed Network
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*Vertices 12
1 P1 indegree 0 
2 A1 indegree 3 
3 P2 indegree 0 
4 A2 indegree 2 
5 A6 indegree 3 
6 P3 indegree 0 
7 A3 indegree 1 
8 P4 indegree 0 
9 A4 indegree 1 
10 A5 indegree 2 
11 P5 indegree 0 
12 P6 indegree 0 
*Arcs 
1 2 
3 4 
3 5 
6 2 
6 7 
8 10 
8 2 
8 9 
11 10 
11 5 
12 4 
12 5 

Author
Paper
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General Network Extraction:
Unweighted, Directed Paper-Citation Network

66

*Vertices 6
1 P1 
2 P2 
3 P3 
4 P4 
5 P5 
6 P6 
*Arcs 
2 1 
3 1 
3 2 
4 2 
5 4 
5 3 
5 1 
5 2 
6 5 

1970           1980         1990        1995        2000

Arcs from  papers to references
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General Network Extraction:
Unweighted, Directed Bi-Partite Network

67

*Vertices 11
1 P1 bipartitetype "Paper" 
2 P2 bipartitetype "Paper" 
3 P1 bipartitetype "References" 
4 P3 bipartitetype "Paper" 
5 P2 bipartitetype "References" 
6 P4 bipartitetype "Paper" 
7 P5 bipartitetype "Paper" 
8 P4 bipartitetype "References" 
9 P3 bipartitetype "References" 
10 P6 bipartitetype "Paper" 
11 P5 bipartitetype "References" 
*Arcs 
2 3 
4 3 
4 5 
6 5 
7 3 
7 9 
7 5 
7 8 
10 11 

WRONG!!!

68

ISI Paper-Citation Network Extraction

68
2000            2001            2002

Arcs from  references to papers—
in the direction of  information flow
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Evolving collaboration networks

70



Evolving Collaboration Networks
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Load isi formatted file

As csv, file looks like:

Visualize each time slide separately: 

72
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Relevant Sci2 Manual entry
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http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Slice Table by Time

74
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Visualize Each Network, Keep Node Positions

1. To see the evolution of  Vespignani's co-authorship network over time, check ‘cumulative’. 

2. Extract co-authorship networks one at a time for each sliced time table using 'Data 
Preparation > Extract Co-Author Network', making sure to select "ISI" from the pop-up 
window during the extraction.  

3. To view each of  the Co-Authorship Networks over time using the same graph layout, 
begin by clicking on longest slice network (the 'Extracted Co-Authorship Network' under 'slice 
from beginning of  1990 to end of  2006 (101 records)') in the data manager. Visualize it in 
GUESS using 'Visualization > Networks >  GUESS'. 

4. From here, run 'Layout > GEM' followed by 'Layout > Bin Pack'.  Run 'Script > Run Script
…' and select ' yoursci2directory/scripts/GUESS/co-author-nw.py'.

5. In order to save the x, y coordinates of  each node and to apply them to the other time 
slices in GUESS, select 'File > Export Node Positions' and save the result as 
'yoursci2directory/NodePositions.csv'. Load the remaining three networks in GUESS using the 
steps described above and for each network visualization, run 'File > Import Node Positions'
and open 'yoursci2directory/NodePositions.csv'.

6. To match the resulting networks stylistically with the original visualization, run 'Script > 
Run Script …' and select 'yoursci2directory/scripts/GUESS/co-author-nw.py', followed by 'Layout > 
Bin Pack', for each.  
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http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Visualize Each Network, Keep Node Positions

76

http://cishell.wiki.cns.iu.edu/Slice+Table+by+Time

Relevant CIShell plugin
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Network Visualization with GUESS

Pan:
“grab” the background 
by holding left-click and 
moving your mouse.

Zoom:
Using scroll wheel, press 
the “+” and “-” buttons 
in the upper-left hand 
corner, or right-click and 
move the mouse left or 
right. Center graph by 
selecting ‘View -> 
Center’.

Select        to 
select/move single 
nodes. Hold down ‘Shift’ 
to select multiple.

Right click node/edge to 
modify Color, Shape, etc.
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Network Visualization 
with GUESS

Graph Modifier:
Select “all nodes” in the Object 
drop-down menu and click ‘Show 
Label’ button. 

Select ‘Resize Linear > Nodes > 
times_cited’ drop-down menu, 
then type “5” and “20” into the 
From” and To” Value box 
separately. Then select ‘Do Resize 
Linear’.

Select ‘Colorize> 
Nodes>totalities’, then select 
white and enter (204,0,51) in the 
pop-up color boxes on in the 
“From” and “To” buttons.

Select “Format Node Labels”, 
replace default text {originallabel} 
with your own label in the pop-up 
box ‘Enter a formatting string for 
node labels.’
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Network Visualization with GUESS

Interpreter uses Jython a combination of  Java and Python.

Try
resizeLinear(times_cited,1,20)
colorize(times_cited, white, red)

8:30a  Welcome and Overview of Tutorial and Attendees

8:45a  Sci2 Tool Hands-on
 Download and run the Sci2 Tool
 Temporal Analysis: Horizontal line graph of NSF projects
 Geospatial Analysis: US and world maps
 Geospatial Analysis: Geomap with network overlays

10-10:30a Networking Break

 Topical Analysis: Visualize research profiles
 Network Analysis: Co-occurrence networks and bimodal networks
 Network Analysis: Evolving collaboration networks

12:30p  IVMOOC
12:45p  Outlook and Q&A

1:00p Adjourn

Tutorial Overview
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MOOCs
In 2012, Google hosted three massive open online courses (MOOCs) 
collectively reaching over 400,000 registrants. 

By the end of 2013 more than 250 courses will be run using the Google, 
Coursera, Udacity, EdX, and other platforms.
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ivmooc.cns.iu.edu
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The Information Visualization MOOC
ivmooc.cns.iu.edu

Students come from 93 countries
300+ faculty members

#ivmooc
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Instructors

Katy Börner – Theory Parts

Instructor, Professor at SLIS

David E. Polley – Hands‐on Parts

CNS Staff, Research Assistant with MIS/MLS

Teaches & Tests Sci2 Tool

Scott B. Weingart – Client Work

Assistant Instructor, SLIS PhD student
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Course Schedule

Course started on January 22, 2013

• Session 1 – Workflow design and visualization framework

• Session 2 – “When:” Temporal Data

• Session 3 – “Where:” Geospatial Data

• Session 4 – “What:” Topical Data

Mid‐Term

Students work in teams with clients.

• Session 5 – “With Whom:” Trees

• Session 6 – “With Whom:” Networks

• Session 7 – Dynamic Visualizations and Deployment

Final Exam
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Unit Structure

The course and each unit has three components:

Theory: Videos and Slides

Self‐Assessment (not graded)

Hands‐on: Videos and Slides & Wiki pages with workflows

Homework (not graded)

Client Work: Using Drupal Forum (graded)
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Grading

All students are asked to create a 
personal profile to support working 
in teams.

Final grade is based on Midterm (30%), Final (40%), Client Project (30%).

• Weekly self‐assessments are not graded.

• Homework is graded automatically.

• Midterm and Final test materials from theory and hands‐on sessions 
are graded automatically.

• Client work is peer‐reviewed via online forum. 

All students that receive more than 80% of all available points get 
an official certificate/badge.
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Scholarly Database at Indiana University
http://sdb.wiki.cns.iu.edu

Supports federated search of 26 million publication, patent, clinical trials, and grant records.
Results can be downloaded as data dump and (evolving) co-author, paper-citation networks.

Register for free access at http://sdb.cns.iu.edu



Plug‐and‐Play Macroscopes
cishell.org

Börner, Katy. (March 2011).  Plug‐and‐Play Macroscopes. Communications of the ACM,  
54(3), 60‐69.  http://www.scivee.tv/node/27704  
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Clients

http://ivmooc.cns.iu.edu/ivmooc_clientprojects.html
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Diogo Carmo
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mjstamper_ivmooc
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Diogo Carmo
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JonoPatterson
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Visualizing IVMOOC Data

Empowering Teachers: How to make sense of the activities of 
thousands of students? How to guide them?

Empowering Students: How to navigate learning materials and 
develop successful learning collaborations across disciplines and 
time zones?

Empowering MOOC Platform Designers: What technology helps 
and what hurts?

Research: What teaching and learning works in a MOOC?

8:30a  Welcome and Overview of Tutorial and Attendees

8:45a  Sci2 Tool Hands-on
 Download and run the Sci2 Tool
 Temporal Analysis: Horizontal line graph of NSF projects
 Geospatial Analysis: US and world maps
 Geospatial Analysis: Geomap with network overlays

10-10:30a Networking Break

 Topical Analysis: Visualize research profiles
 Network Analysis: Co-occurrence networks and bimodal networks
 Network Analysis: Evolving collaboration networks

12:30p  IVMOOC
12:45p  Outlook and Q&A

1:00p Adjourn

Tutorial Overview
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Börner, Katy. (March 2011). 

Plug-and-Play Macroscopes. 
Communications of the ACM, 
54(3), 60-69. 

Video and paper are at
http://www.scivee.tv/node/27704
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OSGi/CIShell Adoption

A number of other projects recently adopted OSGi and/or CIShell:
 Cytoscape (http://cytoscape.org) Led by Trey Ideker at the University of California, San Diego is 

an open source bioinformatics software platform for visualizing molecular interaction 
networks and integrating these interactions with gene expression profiles and other state data 
(Shannon et al., 2002). 

 MAEviz (https://wiki.ncsa.uiuc.edu/display/MAE/Home) Managed by Jong Lee at NCSA is an 
open-source, extensible software platform which supports seismic risk assessment based on 
the Mid-America Earthquake (MAE) Center research.

 Taverna Workbench (http://taverna.org.uk) Developed by the myGrid team 
(http://mygrid.org.uk) led by Carol Goble at the University of Manchester, U.K. is a free 
software tool for designing and executing workflows (Hull et al., 2006). Taverna allows users 
to integrate many different software tools, including over 30,000 web services.

 TEXTrend (http://textrend.org) Led by George Kampis at Eötvös Loránd University, Budapest, 
Hungary supports natural language processing (NLP), classification/mining, and graph 
algorithms for the analysis of business and governmental text corpuses with an inherently 
temporal component.

 DynaNets (http://www.dynanets.org) Coordinated by Peter M.A. Sloot at the University of 
Amsterdam, The Netherlands develops algorithms to study evolving networks.

 SISOB (http://sisob.lcc.uma.es) An Observatory for Science in Society Based in Social Models.
As the functionality of OSGi-based software frameworks improves and the number and 
diversity of dataset and algorithm plugins increases, the capabilities of custom tools will expand. 
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Network Workbench Tool
http://nwb.slis.indiana.edu

The Network Workbench (NWB) tool 
supports researchers, educators, and 
practitioners interested in the study of  
biomedical, social and behavioral science, 
physics, and other networks. 

In February 2009, the tool provides more 169 
plugins that support the preprocessing, 
analysis, modeling, and visualization of  
networks. 

More than 50 of  these plugins can be 
applied or were specifically designed for 
S&T studies. 

It has been downloaded more than 125,000 
times since December 2006.

Herr II, Bruce W., Huang, Weixia (Bonnie), Penumarthy, Shashikant & Börner, Katy. (2007). Designing Highly Flexible and Usable 
Cyberinfrastructures for Convergence. In Bainbridge, William S. & Roco, Mihail C. (Eds.), Progress in Convergence - Technologies for Human 
Wellbeing (Vol. 1093, pp. 161-179), Annals of  the New York Academy of  Sciences, Boston, MA. 
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TEXTrend adds R bridge, WEKA, Wordij, CFinder, and more.

See the latest versions of TEXTrend Toolkit modules at  
http://textrend.org/index.php?option=com_content&view=article&id=47&Itemid=53
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OSGi/CIShell-Powered Tools Support Algorithm Sharing
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TexTrend

NWB

EpiC

Sci2

Common algorithm/tool pool
Easy way to share new algorithms
Workflow design logs
Custom tools

Converters

IS
CS
Bio
SNA
Phys



CIShell – Integrate New Algorithms
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CIShell Developer Guide is at http://cishell.wiki.cns.iu.edu

Additional Sci2 Plugins are at http://sci2.wiki.cns.iu.edu/3.2+Additional+Plugins

CIShell – Customize Menu

 The file ‘yourtooldirectory/configuration/default_menu.xml’ encodes the structure of 
the menu system.

 In NWB Tool, the Modeling menu (left) is encoded by the following piece of 
xml code: 
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https://sci2.cns.iu.edu/user/ask.php

Need Help?  Ask an Expert! 

Q & A

Please complete the Post-Tutorial Questionnaire 
so that we can further improve these tutorials.

* * *
Bug reports and all comments are welcome.

If  you enjoyed the tutorial, please thank Noshir Contractor, 
Brian Uzzi, and Latonia Trimuel



All papers, maps, tools, talks, press are linked from http://cns.iu.edu

CNS Facebook: http://www.facebook.com/cnscenter
Mapping Science Exhibit Facebook: http://www.facebook.com/mappingscience


