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 These slides
http://ivl.slis.indiana.edu/km/pres/2012-borner-sci2tutorial-tokyo.pdf

 Sci2 Tool Manual v0.5.1 Alpha, updated to match v1.0 Alpha 
http://sci2.wiki.cns.iu.edu

 Sci2 Tool v1.0 Alpha (June 13, 2012)
http://sci2.cns.iu.edu

 Additional Datasets 
http://sci2.wiki.cns.iu.edu/2.5+Sample+Datasets

 Additional Plugins
http://sci2.wiki.cns.iu.edu/3.2+Additional+Plugins

Or copy them from the DVD or memory stick. 

Postscript Viewer: Please try opening ‘chessboard.ps.’ You should see



Sci2 Tool v0.5.2 Alpha (Dec 19, 2011)
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New Features
 Support new Web of  Science format from ISI
 Support network overlay for geographical map
 Support Prefuse's visualizations on Macs OS 

Improvements
 Improve memory usage and processing time of  Extract top N nodes and 

Extract top N Edges algorithms
 Unify merging algorithms used by database 

Bug fixes
 Fix legend boundary issue in geographical map
 Fix typo error on the output data label
 Fix slice by year algorithm

Sci2 Tool v1.0 Alpha (June 13, 2012)
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Major Release 
featuring a Web services compatible CIShell v2.0 (http://cishell.org)

New Features
 Google Scholar citation reader 
 New visualizations such as 

 geospatial maps
 science maps
 bi-modal network layout

 R statistical tool bridging
 Gephi visualization tool bridging
 Comprehensive online documentation 

Release Note Details
http://wiki.cns.iu.edu/display/SCI2TUTORIAL/4.4+Sci2+Release+Notes+v1.0+alpha



9:00am Welcome and Overview of Tutorial and Attendees
9:15am Sci2 Tool Usage and Adoption
10:00am Sci2 Tool Basics 
Download and run the Sci2 Tool
Load, analyze, and visualize family and business networks 
Horizontal line graph of NSF projects
Studying four major network science researchers
• Load and clean a dataset; process raw data into networks
• Find basic statistics and run various algorithms over the network
• Visualize the network using different layouts
11:00am Break
11:15am Sci2 Tool Novel Functionality
• Yahoo! Geocoder
• Geomap with Gephi network overlay
• Evolving collaboration networks
• R-Bridge
• New Visualizations
12:15pm Outlook and Q&A
12:30pm Adjourn

Tutorial Overview
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Interested to Learn:
• The basics

• Topical analysis and maps
• Visualization of a large-scale network
• Understanding innovation dynamics
• S&E collaborations between nations

• Patent analysis -> SDB

• Comparison with UCINet, GIS

• Capabilities and limitations of the tool
• Whether a similar tool can be 

implemented in Japan

Tutorial Participants
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Science of Science (Sci2) Tool
http://sci2.cns.iu.edu

 Explicitly designed for SoS research and practice, well documented, easy to use. 

 Empowers many to run common studies while making it easy for exports to 
perform novel research.

 Advanced algorithms, effective visualizations, and many (standard) workflows. 

 Supports micro-level documentation and replication of studies.

 Is open source—anybody can review and extend the code, or use it for 
commercial purposes.
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Sci2 Tool – “Open Code for S&T Assessment”

OSGi/CIShell powered tool with NWB plugins and 
many new scientometrics and visualizations plugins.

Börner, Katy, Huang, Weixia (Bonnie), Linnemeier, Micah, Duhon, Russell Jackson, Phillips, Patrick, Ma, Nianli, Zoss, 
Angela,  Guo, Hanning & Price, Mark. (2009). Rete-Netzwerk-Red: Analyzing and Visualizing Scholarly Networks 
Using the Scholarly Database and the Network Workbench Tool. Proceedings of ISSI 2009: 12th International Conference 
on Scientometrics and Informetrics, Rio de Janeiro, Brazil, July 14-17 . Vol. 2, pp. 619-630. 

Horizontal Time Graphs

Sci Maps GUESS Network Vis
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Sci2 Tool Visualizations

Geo Maps

Circular Hierarchy

10



Sci2 Tool Usage at National Science Foundation

Topic co-occurrence network of  the 2885 cognitive and 
neuroscience NSF projects funded between 2007 and 2011.
Statistical text mining (Topic model) was used to identify topics 
from NSF awards and proposals from 2000-2011.

Each award is tagged with up to 4 topics. Lines represent the co-occurrence of  the 
connected topics within an award(s). The nodes are scaled by number of  awards 
(max = 355) and the lines are scaled on number of  co-occurrences (max =91). The 
node colors differentiate the nodes via the level-0 Blondel communities.

This is … an entirely new way of  characterizing and understanding the NSF 
portfolio. This is in part because this enables analysis of  the content of  the 
awards/proposals independent of  the institutional structure. One can quickly 
identify ALL of  the Cog/Neuro awards throughout the entire NSF portfolio – so it 
captures research in all of  the unexpected institutional places. This method also 
allows one to easily identify areas of  parallel or potentially collaborative 
research being funded by different institutional structures and  … to identify 
potential areas for advancing science by facilitating collaborations.
Leah G. Nichols, NSF
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Sci2 Tool Usage at National Institutes of Health

Mapping Transdisciplinary Tobacco Use Research 
Centers Publications: Compare  R01 investigator 
based funding with TTURC Center awards in terms of 
number of publications and evolving co-author 
networks. Zoss & Börner, forthcoming. 
Supported by NIH/NCI Contract HHSN261200800812
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Sci2 Tool Usage at National Institutes of Health

Sci2 Tool now supports Web services and serves as a visual interface to publically 
available NIH RePORT Expenditure and Results RePORTER)/ RePORTER data 
provided by NIH.

14



Sci2 Tool Usage at the National Oceanic and 
Atmospheric Administration (NOAA)

Co-author network generated from publications supported by NOAA’s Office of 
Ocean Exploration and Research (OER). Nodes are sized based on the number of 
publications produced and colored to highlight clustering. Edges are sized and 
colored based on the number of collaborations between authors.

For details, see “Visualizing 
Networks of Scientific 
Research”
by Chris Belter 
http://www.infotoday.com/
online/may12/Belter-
Visualizing-Networks-of-
Scientific-Research.shtml
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Sci2 Tool Usage at the National Oceanic and 
Atmospheric Administration (NOAA)

Central section of a word co-occurrence 

network of words drawn from 

the titles of OER-supported 

journal articles. Some words 

have been truncated. 

Nodes are sized by the number 

of times the word is 

used and edges 

are sized and colored 

based on the number 

of publications in which they co-occur. 

Weaker edges have been removed 

for clarity. Nodes colored blue are 

those that have been used 10 or 

more times in the publication set. 16



Sci2 Tool Usage at US Department of Agriculture 
(USDA)

First time portrait of  intramural research conducted by the U.S. Department of  
Agriculture (USDA) presented at the VIVO Conference 2012.
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Sci2 Tool Usage at US Department of Agriculture
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Sci2 Tool Usage at US Department of Agriculture
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Sci2 Tool Usage at James S. McDonnell Foundation

How did cognitive neuroscience of  attention emerge from neurobiology and 
psychology, 1980–2005? Author co-citation analysis and Pfnet is used to trace 
prospectively the development of  the field from its precursor disciplines: 
cognitive psychology, single cell neurophysiology, neuropsychology, and evoked 
potential research. 
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Sci2 Tool Usage at James S. McDonnell Foundation

By 1990 a distinct cognitive neuroscience specialty cluster emerges, dominated
by authors engaged in brain imaging research.

Bruer, John T. (2010). Can we talk? How the cognitive neuroscience of  attention emerged from neurobiology and psychology, 
1980.2005. Scientometrics, 83(3), 751-764. http://ivl.cns.iu.edu/km/tools/2010-bruer-scientometrics.pdf
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Type of Analysis vs. Level of Analysis

Micro/Individual
(1-100 records)

Meso/Local
(101–10,000 records)

Macro/Global
(10,000 < records) 

Statistical 
Analysis/Profiling 

Individual person and 
their expertise profiles

Larger labs, centers, 
universities, research 
domains, or states

All of NSF, all of USA, 
all of science.

Temporal Analysis 
(When)

Funding portfolio of 
one individual

Mapping topic bursts 
in 20-years of PNAS

113 Years of Physics 
Research

Geospatial Analysis 
(Where)

Career trajectory of one 
individual  

Mapping a states 
intellectual landscape

PNAS publciations 

Topical Analysis 
(What)

Base knowledge from 
which one grant draws.

Knowledge flows in 
Chemistry research 

VxOrd/Topic maps of 
NIH funding

Network Analysis 
(With Whom?)

NSF Co-PI network of 
one individual  

Co-author network NIH’s core competency 
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Sci2 Tool – Supported Data Formats

Input:

Network Formats 

 GraphML (*.xml or *.graphml)

 XGMML (*.xml)

 Pajek .NET (*.net)

 NWB (*.nwb)

Scientometric Formats 

 ISI (*.isi)

 Bibtex (*.bib)

 Endnote Export Format (*.enw)

 Scopus csv (*.scopus)

 NSF csv (*.nsf)

Other Formats 

 Pajek Matrix (*.mat)

 TreeML (*.xml)

 Edgelist (*.edge)

 CSV (*.csv)

Formats are documented at http://sci2.wiki.cns.iu.edu/display/SCI2TUTORIAL/2.3+Data+Formats.  
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Output:
Network File Formats
 GraphML (*.xml or *.graphml)
 Pajek .MAT (*.mat)
 Pajek .NET (*.net)
 NWB (*.nwb)
 XGMML (*.xml)
 CSV (*.csv)

Image Formats

 JPEG (*.jpg)

 PDF (*.pdf)

 PostScript (*.ps) 

Sci2 Tool – Supported Tools

Gnuplot

portable command-line driven 
interactive data and function plotting 
utility http://www.gnuplot.info/.

GUESS

exploratory data analysis and visualization tool 
for graphs and networks. 

https://nwb.slis.indiana.edu/community/?n=Vi
sualizeData.GUESS. 

26



Sci2 Tool – Supported Tools
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Adding more layout algorithms and network visualization interactivity 

via Cytoscape http://www.cytoscape.org. 

Simply add org.textrend.visualization.cytoscape_0.0.3.jar into your /plugin directory.

Restart Sci2 Tool

Cytoscape now shows in the Visualization Menu

Select a network in Data Manager, run Cytoscape and the tool will start with this 
network loaded.

Sci2 Tool – Bridged Tools

28

R statistical tool bridging

Gephi visualization tool bridging 
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Sci2 Tool: Download, Install, and Run

Sci2 Tool v1.0 Alpha (June 13, 2012)
Can be freely downloaded for all major 
operating systems from 
http://sci2.cns.iu.edu

Select your operating system from the 
pull down menu and download. 
Unpack into a /sci2 directory.
Run /sci2/sci2.exe

Sci2 Manual is at
http://sci2.wiki.cns.iu.edu

Cite as 
Sci2 Team. (2009). Science of  Science (Sci2) Tool. 
Indiana University and SciTech Strategies, 
http://sci2.cns.iu.edu . 
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Sci2 Tool: Download, Install, and Run

Sci2 Tool v1.0 Alpha (June 13, 2012)
Sci2 Tool runs on Windows, Mac, and Linux.

Unzip.

Run /sci2/sci2.exe
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Sci2 Tool Interface Components
See also http://sci2.wiki.cns.iu.edu/2.2+User+Interface

Use

 Menu to read data, run 
algorithms.

 Console to see work log, 
references to seminal works.

 Data Manager to select, view, 
save loaded, simulated, or 
derived datasets.

 Scheduler to see status of 
algorithm execution.

All workflows are recorded into a log file (see /sci2/logs/…), and soon can be re-
run for easy replication. If  errors occur, they are saved in a error log to ease bug 
reporting.
All algorithms are documented online; workflows are given in tutorials, see Sci2 
Manual at http://sci2.wiki.cns.iu.edu

9:00am Welcome and Overview of Tutorial and Attendees
9:15am Sci2 Tool Usage and Adoption
10:00am Sci2 Tool Basics 
Download and run the Sci2 Tool
Load, analyze, and visualize family and business networks 
Horizontal line graph of NSF projects
Studying four major network science researchers
• Load and clean a dataset; process raw data into networks
• Find basic statistics and run various algorithms over the network
• Visualize the network using different layouts
11:00amBreak
11:15am Sci2 Tool Novel Functionality
• Yahoo! Geocoder
• Geomap with Gephi network overlay
• Evolving collaboration networks
• R-Bridge
• New Visualizations
12:15pm Outlook and Q&A
12:30pm Adjourn

Tutorial Overview
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Padgett's Florentine Families – Load, analyze, and 
visualize family and business networks 

Florentine families related through business ties (specifically, recorded financial ties such 
as loans, credits and joint partnerships) and marriage alliances.

Node attributes

 Wealth: Each family's net wealth in 1427 (in thousands of lira).

 Priorates: The number of seats on the civic council held between 1282-1344.

 Totalities: Number of business/marriage ties in complete dataset of 116 families.

Edge attributes:

 Marriage  T/F

 Business  T/F

“Substantively, the data include families who were locked in a struggle for political 
control of the city of Florence around 1430. Two factions were dominant in this 
struggle: one revolved around the infamous Medicis, the other around the powerful 
Strozzis.”

More info is at http://svitsrv25.epfl.ch/R-doc/library/ergm/html/florentine.html
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Padgett's Florentine Families – Load, analyze, and 
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*Nodes
id*int label*string wealth*int totalities*int
priorates*int
1 "Acciaiuoli" 10 2 53
2 "Albizzi" 36 3 65
3 "Barbadori" 55 14 0
4 "Bischeri" 44 9 12
5 "Castellani" 20 18 22
6 "Ginori" 32 9 0
7 "Guadagni" 8 14 21
8 "Lamberteschi" 42 14 0
9 "Medici" 103 54 53
10 "Pazzi" 48 7 0
11 "Peruzzi" 49 32 42
12 "Pucci" 3 1 0
13 "Ridolfi" 27 4 38
14 "Salviati" 10 5 35
15 "Strozzi" 146 29 74
16 "Tornabuoni" 48 7 0
*UndirectedEdges
source*int target*int marriage*string business*string
9 1 "T" "F"
6 2 "T" "F"
7 2 "T" "F"
9 2 "T" "F"
5 3 "T" "T"



Padgett's Florentine Families – Load, compute 
basic network properties & view in GUESS

 Load *yoursci2directory*/sampledata/socialscience/florentine.nwb
 Run ‘Analysis > Network Analysis Toolkit (NAT)’ to get basic properties.
This graph claims to be undirected.
Nodes: 16
Isolated nodes: 1
Node attributes present: label, wealth, totalities, priorates
Edges: 27
No self loops were discovered.
No parallel edges were discovered.
Edge attributes:
Nonnumeric attributes:
Example value
marriag...T
busines...F
Average degree: 3.375
There are 2 weakly connected components. (1 isolates)
The largest connected component consists of 15 nodes.
Did not calculate strong connectedness because this graph was not directed.
Density (disregarding weights): 0.225

 Select network and run ‘Visualization > GUESS’ to open GUESS with file loaded.
 Apply ‘Layout > GEM’.
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Pan:
“grab” the background 
by holding left-click 
and moving your 
mouse.

Zoom:
Using scroll wheel, 
press the “+” and “-” 
buttons in the upper-
left hand corner, or 
right-click and move 
the mouse left or right. 
Center graph by 
selecting ‘View -> 
Center’.

Select        to 
select/move single 
nodes. Hold down 
‘Shift’ to select 
multiple.

Right click to modify 
Color, etc.
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Graph Modifier:
Select “all nodes” in the Object 
drop-down menu and click ‘Show 
Label’ button. 

Select ‘Resize Linear > Nodes > 
totalities’ drop-down menu, then 
type “5” and “20” into the From” 
and To” Value box separately. 
Then select ‘Do Resize Linear’.

Select ‘Colorize> 
Nodes>totalities’, then select 
white and enter (204,0,51) in the 
pop-up color boxes on in the 
“From” and “To” buttons.

Select “Format Node Labels”, 
replace default text {originallabel} 
with your own label in the pop-up 
box ‘Enter a formatting string for 
node labels.’

38



Interpreter:
Uses Jython a combination of  Java 
and Python.

Try
colorize(wealth, white, red)
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• Load and clean a dataset; process raw data into networks
• Find basic statistics and run various algorithms over the network
• Visualize the network using different layouts
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11:15am Sci2 Tool Novel Functionality
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• Geomap with Gephi network overlay
• Evolving collaboration networks
• R-Bridge
• New Visualizations
12:15pm Outlook and Q&A
12:30pm Adjourn

Tutorial Overview
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Horizontal line graph of  NSF projects
See 5.2.1 Funding Profiles of  Three Universities (NSF Data)

41

Download NSF data                                  Visualize as Horizontal Line Graph 

Start date End date

Area size equals numerical 
value, e.g., award amount.

Text

Horizontal line graph of  NSF projects
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NSF Awards Search via http://www.nsf.gov/awardsearch

Save in CSV format as *institution*.nsf



Download and load a dataset of  your choice or load one of  the sample data files, e.g., 
‘sampledata/scientometrics/nsf/Michigan.nsf.’ 

Run ‘Visualization > Temporal > Horizontal Line Graph’ using parameters:

Save ‘visualized with Hotizontal Line Graph’ as ps or eps file. Convert into pdf and view. 

Zoom to see details in visualizations of  large datasets, e.g., all NSF awards ever made.

Horizontal line graph of  NSF projects

43

Horizontal line graph of  NSF projects
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Start date End date

Area size equals numerical 
value, e.g., award amount.

Text, e.g., title

More NSF data workflows can be found in wiki tutorial:
5.1.3 Funding Profiles of  Three Researchers at Indiana University (NSF Data)
5.2.1 Funding Profiles of  Three Universities (NSF Data)
5.2.3 Biomedical Funding Profile of  NSF (NSF Data)



9:00am Welcome and Overview of Tutorial and Attendees
9:15am Sci2 Tool Usage and Adoption
10:00am Sci2 Tool Basics 
Download and run the Sci2 Tool
Load, analyze, and visualize family and business networks 
Horizontal line graph of NSF projects
Studying four major network science researchers
• Load and clean a dataset; process raw data into networks
• Find basic statistics and run various algorithms over the network
• Visualize the network using different layouts
11:00amBreak
11:15am Sci2 Tool Novel Functionality
• Yahoo! Geocoder
• Geomap with Gephi network overlay
• Evolving collaboration networks
• R-Bridge
• New Visualizations
12:15pm Outlook and Q&A
12:30pm Adjourn

Tutorial Overview

45

Studying Four Major NetSci Researchers (ISI Data) 
using Database (section 5.1.4)

Thomson Reuter’s Web of  Knowledge (WoS) is a leading citation database.  Access it 
via the “Web of  Science” tab at http://www.isiknowledge.com (note: access to this 
database requires a paid subscription).  Along with Scopus, WoS provides some of  
the most comprehensive datasets for scientometric analysis.  

To find all publications by an author, search for the last name and the first initial 
followed by an asterisk in the author field. 

http://sci2.wiki.cns.iu.edu/5.1.4+Studying+Four+Major+NetSci+Researchers+(ISI+Data)
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Data Acquisition from Web of Science

In Dec 2007, we downloaded 

all papers by

 Eugene Garfield

 Stanley Wasserman

 Alessandro Vespignani

 Albert-László Barabási

from

 Science Citation Index 

Expanded (SCI-EXPANDED)

--1955-present 

 Social Sciences Citation Index 
(SSCI)--1956-present 

 Arts & Humanities Citation 
Index (A&HCI)--1975-present 
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Comparison of Counts
No books and other non-WoS publications are covered.

Age Total # Cites Total # Papers H-Index

Eugene Garfield 82 1,525 672 31

Stanley Wasserman 122 35 17

Alessandro Vespignani 42 451 101 33

Albert-László Barabási 40 2,218 126 47    (Dec 2007)

41 16,920 159 52    (Dec 2008)

44 30,102 201 68    (April 2011)
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Extract Co-Author Network

Load*yoursci2directory*/sampledata/scientometrics/isi/FourNetSciResearchers.isi’ 

using 'File > Load …‘

And file with 361 records appears in the Data Manager. 

Duplicates were removed, author names normalized. Log file exists.
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Extract Co-Author Network
(see section 5.1.4.2 on correcting duplicate/misspelled author names)

To extract the co-author network, select the ‘361 Unique ISI Records’ table and run
‘Data Preparation > Extract Co-Author Network’ using isi file format:

The result is an undirected but weighted network of co-authors in the Data Manager. 
Run ‘Analysis > Network > Network Analysis Toolkit (NAT)’ to calculate basic 

properties: the network has 247 nodes and 891 edges. 
Use ‘Analysis > Network > Unweighted and Undirected > Node Degree’ to calculate the number 

of neighbors for each node independent of co-authorship weight.
To view the complete network, select the ‘Extracted Co-Authorship Network’ and run 

‘Visualization > Networks > GUESS’. 
Network is loaded with random layout. In GUESS, run ‘Layout > GEM’ and ‘Layout 

> Bin Pack’ to improve layout. Run 'Script > Run Script …' and select ' 
yoursci2directory/scripts/GUESS/co-author-nw.py'.

50



Co-Author Network of all Four NetsSci Researchers
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Co-Author Network of all Four NetsSci Researchers
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Use the GUESS Graph Modifier to change 
color and size coding.

Calculate node degrees in Sci2 Tool.

Use a graphic program to add legend.



Individual Co-Author Networks 
(Read/map 4 files separately)

Eugene Garfield Stanley Wasserman

Alessandro Vespignani Albert-László Barabási
53

Network Visualization: 
Node Layout
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Load and Clean ISI File was selected.
Loaded 361 records.
Removed 0 duplicate records.
Author names have been normalized.
361 records with unique ISI IDs are available 
via Data Manager.
..........
Extract Co-Author Network was selected.
Input Parameters:
File Format: isi
..........
Network Analysis Toolkit (NAT) was selected.
Nodes: 247
Edges: 891
..........
GUESS was selected.



Network Visualization: 
Color/Size Coding by Data Attribute Values
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Network Visualization: 
Giant Component
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..........
Weak Component Clustering was selected.
Implementer(s): Russell Duhon
Integrator(s): Russell Duhon

Input Parameters:
Number of  top clusters: 10
3 clusters found, generating graphs for the top 3 clusters.
..........



Network Visualization: 
Color/Size Coding by Degree
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..........
Node Degree was selected.
Documentation: 
https://nwb.slis.indiana.edu/community/?n=AnalyzeData.No
deDegree
..........

Network Visualization: 
Color/Size Coding by Betweeness Centrality
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..........
Node Betweenness Centrality was selected.
Author(s): L. C. Freeman
Implementer(s): Santo Fortunato
Integrator(s): Santo Fortunato, Weixia Huang
Reference: Freeman, L. C. (1977). A set of  measuring centrality 
based on betweenness. Sociometry. 40:35-41.

Input Parameters:
Number of  bins: 10

umber of  bins: 10
..........



Network Visualization: 
Reduced Network After Pathfinder Network Scaling
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..........
MST-Pathfinder Network Scaling was selected.
Input Parameters:
Weight Attribute measures: SIMILARITY
Edge Weight Attribute: weight
..........

Network Visualization: 
Circular Hierarchy Visualization
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Select Co-Author Network and run Blondel Community detection:

With parameter values



Network Visualization: 
Circular Hierarchy Visualization
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Visualize resulting file using ‘Visualization > Networks > Circular Hierarchy’
with parameter values     

Network Visualization: 
Circular Hierarchy Visualization
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Node labels, e.g., 
author names.

Network structure 
using edge bundling.

Color coded cluster 
hierarchy according to 
Blondel community 
detection algorithm.

Note:
Header/footer info, legend, and more meaningful color coding are under development.

Nodes that are interlinked/clustered 
are spatially close to minimize the 
number of  edge crossings.



Paper-Citation Network Layout

To extract the paper-citation network, select the ‘361 Unique ISI Records’ table and run 
‘Data Preparation > Extract Paper Citation Network.‘

The result is a unweighted, directed network of papers linked by citations, named 
Extracted paper-citation network in the Data Manager.

Run NAT to calculate that the network has 5,342 nodes and 9,612 edges. There are 
15 weakly connected components. (0 isolates)

Run ‘Analysis > Networks > Unweighted and Directed > Weak Component Clustering’ with 
parameters 

to identify top-10 largest components. The largest (giant) component has 5,151 nodes.

To view the complete network, select the network and run ‘Visualization > GUESS’.
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General Network Extraction:
Weighted, Undirected Co-Occurrence Network

Author co-occurrence network

65

*Vertices 6
1 A1 
2 A6 
3 A2 
4 A3 
5 A5 
6 A4 
*Edges 6
2 3 2 
1 4 1 
1 5 1 
5 6 1 
1 6 1 
2 5 1 
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General Network Extraction:
Unweighted, Directed Bipartite Network

Paper-author bipartite (2-mode) network

*Vertices 12
1 P1 bipartitetype "Paper" 
2 A1 bipartitetype "Authors" 
3 P2 bipartitetype "Paper" 
4 A2 bipartitetype "Authors" 
5 A6 bipartitetype "Authors" 
6 P3 bipartitetype "Paper" 
7 A3 bipartitetype "Authors" 
8 P4 bipartitetype "Paper" 
9 A4 bipartitetype "Authors" 
10 A5 bipartitetype "Authors" 
11 P5 bipartitetype "Paper" 
12 P6 bipartitetype "Paper" 
*Arcs 
1 2 
3 4 
3 5 
6 2 
6 7 
8 2 
8 10 
8 9 
11 5 
11 10 
12 4 
12 5 

Author
Paper
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General Network Extraction:
Unweighted, Directed Network
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*Vertices 12
1 P1 indegree 0 
2 A1 indegree 3 
3 P2 indegree 0 
4 A2 indegree 2 
5 A6 indegree 3 
6 P3 indegree 0 
7 A3 indegree 1 
8 P4 indegree 0 
9 A4 indegree 1 
10 A5 indegree 2 
11 P5 indegree 0 
12 P6 indegree 0 
*Arcs 
1 2 
3 4 
3 5 
6 2 
6 7 
8 10 
8 2 
8 9 
11 10 
11 5 
12 4 
12 5 

Author
Paper
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General Network Extraction:
Unweighted, Directed Paper-Citation Network

68

*Vertices 6
1 P1 
2 P2 
3 P3 
4 P4 
5 P5 
6 P6 
*Arcs 
2 1 
3 1 
3 2 
4 2 
5 4 
5 3 
5 1 
5 2 
6 5 

1970           1980         1990        1995        2000

Arcs from  papers to references
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General Network Extraction:
Unweighted, Directed Bi-Partite Network
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*Vertices 11
1 P1 bipartitetype "Paper" 
2 P2 bipartitetype "Paper" 
3 P1 bipartitetype "References" 
4 P3 bipartitetype "Paper" 
5 P2 bipartitetype "References" 
6 P4 bipartitetype "Paper" 
7 P5 bipartitetype "Paper" 
8 P4 bipartitetype "References" 
9 P3 bipartitetype "References" 
10 P6 bipartitetype "Paper" 
11 P5 bipartitetype "References" 
*Arcs 
2 3 
4 3 
4 5 
6 5 
7 3 
7 9 
7 5 
7 8 
10 11 

WRONG!!!
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ISI Paper-Citation Network Extraction

70
2000            2001            2002

Arcs from  references to papers—
in the direction of  information flow
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Q&A

9:00am Welcome and Overview of Tutorial and Attendees
9:15am Sci2 Tool Usage and Adoption
10:00am Sci2 Tool Basics 
Download and run the Sci2 Tool
Load, analyze, and visualize family and business networks 
Horizontal line graph of NSF projects
Studying four major network science researchers
• Load and clean a dataset; process raw data into networks
• Find basic statistics and run various algorithms over the network
• Visualize the network using different layouts
11:00amBreak
11:15am Sci2 Tool Novel Functionality
• Yahoo! Geocoder
• Geomap with Gephi network overlay
• Evolving collaboration networks
• R-Bridge
• New Visualizations
12:15pm Outlook and Q&A
12:30pm Adjourn

Tutorial Overview

72



7373

Geocoding and Geospatial Maps
http://wiki.cns.iu.edu/display/CISHELL/Yahoo+Geocoder

• Data with 
geographic 
identifiers

Geocode

• Geolocated
data

Aggregate (if  
necessary) • Geographic 

identifiers 
with data

Visualize

Geocoordinates + numeric data 
(Proportional Symbol Map)

Region names + numeric data 
(Choropleth Map)

7474

Load File with Address and Times Cited Fields

Run File > Load…

Load the sample data table sampledata/geo/usptoInfluenza.csv

Let’s create a map showing influenza-related patent activity in the following 

countries.
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http://wiki.cns.iu.edu/display/CISHELL/Yahoo+Geocoder

Yahoo Geocoder

7676

Run Analysis > Geospatial > Yahoo Geocoder

Using Yahoo! Geocoder

You can leave Application ID blank for 
trial purposes, but before heavy use, register 
later for your own personal Yahoo! 
Application ID, see:
http://developer.yahoo.com/geo/placefinder/
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Aggregate by Country

Aggregate Data was selected.
Implementer(s): Chintan Tank
Documentation: http://wiki.cns.iu.edu/display/CISHELL/Aggregate+Data
Input Parameters:
Aggregate on column: Country
Delimiter for Country: | 
Longitude: AVERAGE
Latitude: AVERAGE
Times Cited: SUM
Aggregated by '': All rows of  Latitude column were skipped due to no non-null, non-empty values.
Aggregated by '': All rows of  Longitude column were skipped due to no non-null, non-empty values.
Frequency of  unique "Country" values added to "Count" column.

7878

Right-click and Save map 

Open this PostScript file to 
visualize

Choropleth Map 
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Legend shows 
how data matches 
up with visual 
representation

Header shows visualization type, 
data description, and creation date

79

Interpreting the Choropleth Map

8080

Right-click and Save map 

Open this PostScript file to 
visualize

Proportional Symbol Map 
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Legend shows how data 
matches up with visual 
representation

Header shows visualization type, 
data description, and creation date

81

Interpreting the Proportional Symbol Map

82
http://wiki.cns.iu.edu/display/SCI2TUTORIAL/5.2.4+Mapping+Scientometrics+%28ISI+Data%29

Relevant Sci2 Manual entry



9:00am Welcome and Overview of Tutorial and Attendees
9:15am Sci2 Tool Usage and Adoption
10:00am Sci2 Tool Basics 
Download and run the Sci2 Tool
Load, analyze, and visualize family and business networks 
Horizontal line graph of NSF projects
Studying four major network science researchers
• Load and clean a dataset; process raw data into networks
• Find basic statistics and run various algorithms over the network
• Visualize the network using different layouts
11:00amBreak
11:15am Sci2 Tool Novel Functionality
• Yahoo! Geocoder
• Geomap with Gephi network overlay
• Evolving collaboration networks
• R-Bridge
• New Visualizations
12:15pm Outlook and Q&A
12:30pm Adjourn

Tutorial Overview
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Geomap with Gephi Network Overlay
See 4.7.6 on http://sci2.wiki.cns.iu.edu

84

Use Yahoo! Geocoder to identify Latitude, Longitude for each geolocation
Extract attributes per geolocation, e.g., total times cited (TC)
Extract linkages and their attributes, e.g., number of  co-occurences
See sample /geo/LaszloBarabasiGeo.net with co-occurrence of  “Research 
Addresses” and full counting of  TC per geolocation.

File with 
geolocations and
linkage info, e.g., 
an isi biblio-
graphy file.

Read into Sci2 Tool to generate 
geomap and network file

Layout network in Gephi Combine geomap and 
network in Photoshop

+ =
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http://sci2.wiki.cns.iu.edu/display/SCI2TUTORIAL/4.7+Geospatial+Analysis+%28Where%29#4.
7GeospatialAnalysis%28Where%29-4.7.6UsingGephitoRenderNetworksOverlaidonGeoMaps

Relevant Sci2 Manual entry

86

Use Sci2 Tool to Generate Geomap and Network File

Read prepared .net file and run:

Save map file as Postscript file and use Adobe or other view to read. It looks like:

Save .net file as GraphML (Prefuse) and 
rename to .graphml so that Gephi can read it.



87

Use Gephi to Generate Network Layout

Start gephi. Use New Project > Open a graph file to read .graphml file that Sci2 generated.

Follow instructions in online tutorial on Manipulating the Network File in Gephi

88

Use Gephi to Generate Network Layout

Color or size code the “Near Alaska” and “Near Antarctica” anchor nodes to ease alignment 
of  geomap and network overlay, see instructions in online tutorial on Manipulating the 
Network File in Gephi. Save result using File > Export > SVG/PDF file.
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Use Photoshop to Overlay Network on Geomap

Load geomap and network files into Photoshop. Select ‘network’ layer an use ‘Right click, 
Duplicate Layer’ to copy network over to ‘geomap’ file as a second layer. 
Use Edit > Transform > Scale’ and align using the “Near Antarctica” anchor nodes, see 
instructions in online tutorial on Creating the Visualization in Photoshop.

90

Use Photoshop to Overlay Network on Geomap



Delete anchor nodes and save in preferred format.

91

Practice these steps using “LaszloBarabasi-collaborations.net” linked from Sci2 wiki: 
4.7.6 Using Gephi to Render Networks Overlaid on GeoMaps

92

Rounded edges might increase legibility of
overlapping lines.



9:00am Welcome and Overview of Tutorial and Attendees
9:15am Sci2 Tool Usage and Adoption
10:00am Sci2 Tool Basics 
Download and run the Sci2 Tool
Load, analyze, and visualize family and business networks 
Horizontal line graph of NSF projects
Studying four major network science researchers
• Load and clean a dataset; process raw data into networks
• Find basic statistics and run various algorithms over the network
• Visualize the network using different layouts
11:00amBreak
11:15am Sci2 Tool Novel Functionality
• Yahoo! Geocoder
• Geomap with Gephi network overlay
• Evolving collaboration networks
• R-Bridge
• New Visualizations
12:15pm Outlook and Q&A
12:30pm Adjourn

Tutorial Overview
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Sci2 Demo II: 
Evolving collaboration networks

94



Evolving Collaboration Networks
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Load isi formatted file

As csv, file looks like:

Visualize each time slide separately: 

96
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Relevant Sci2 Manual entry



97
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Slice Table by Time

98
http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Visualize Each Network, Keep Node Positions

1. To see the evolution of  Vespignani's co-authorship network over time, check ‘cumulative’. 

2. Extract co-authorship networks one at a time for each sliced time table using 'Data 
Preparation > Extract Co-Author Network', making sure to select "ISI" from the pop-up 
window during the extraction.  

3. To view each of  the Co-Authorship Networks over time using the same graph layout, 
begin by clicking on longest slice network (the 'Extracted Co-Authorship Network' under 'slice 
from beginning of  1990 to end of  2006 (101 records)') in the data manager. Visualize it in 
GUESS using 'Visualization > Networks >  GUESS'. 

4. From here, run 'Layout > GEM' followed by 'Layout > Bin Pack'.  Run 'Script > Run Script
…' and select ' yoursci2directory/scripts/GUESS/co-author-nw.py'.

5. In order to save the x, y coordinates of  each node and to apply them to the other time 
slices in GUESS, select 'File > Export Node Positions' and save the result as 
'yoursci2directory/NodePositions.csv'. Load the remaining three networks in GUESS using the 
steps described above and for each network visualization, run 'File > Import Node Positions'
and open 'yoursci2directory/NodePositions.csv'.

6. To match the resulting networks stylistically with the original visualization, run 'Script > 
Run Script …' and select 'yoursci2directory/scripts/GUESS/co-author-nw.py', followed by 'Layout > 
Bin Pack', for each.  
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http://sci2.wiki.cns.iu.edu/5.1.2+Time+Slicing+of+Co-Authorship+Networks+(ISI+Data)

Visualize Each Network, Keep Node Positions

100

http://cishell.wiki.cns.iu.edu/Slice+Table+by+Time

Relevant CIShell plugin



14:15 Welcome and Overview of Tutorial and Attendees
14:30 Sci2 Tool Usage and Adoption
15:00 Sci2 Tool Hands-on
 Download and run the Sci2 Tool
 Load, analyze, and visualize family and business networks 
 Horizontal line graph of NSF projects
 Studying four major network science researchers
- Load and clean a dataset; process raw data into networks
- Find basic statistics and run various algorithms over the network
- Visualize as either a circular hierarchy or network

16:00 Sci2 Tool Novel Functionality
 Yahoo! Geocoder
 Geomap with Gephi network overlay
 Evolving collaboration networks
 R-Bridge
 New Visualizations
16:30 Outlook and Q&A
16:45 Adjourn

Tutorial Overview
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R-Bridge

Download edu.iu.cns.r_0.0.1.jar from Additional Plugins wiki page at
http://sci2.wiki.cns.iu.edu/3.2+Additional+Plugins
Or copy them from the DVD or memory stick.
Available by default starting v1.0.

Run ‘R > Create an R Instance’ parameter should be the path to the directory on your 
computer that contains Rgui.exe.  Results in an ‘R Instance’ object in the Data 
Manager.

To send a table from the data manager to an R Instance object, select the table and 
the R Instance object together then run ‘R > Import Table Into R’.  Select ‘R > Run 
Rgui’ and the table is available in the R environment using the variable name you 
specified as a parameter to the Import algorithm.

To pull back data from an R Instance object to the Data Manager, select the R 
Instance object and run ‘R > Export Table From R’.  Choose the name of  the 
variable from the dropdown list.



9:00am Welcome and Overview of Tutorial and Attendees
9:15am Sci2 Tool Usage and Adoption
10:00am Sci2 Tool Basics 
Download and run the Sci2 Tool
Load, analyze, and visualize family and business networks 
Horizontal line graph of NSF projects
Studying four major network science researchers
• Load and clean a dataset; process raw data into networks
• Find basic statistics and run various algorithms over the network
• Visualize the network using different layouts
11:00amBreak
11:15am Sci2 Tool Novel Functionality
• Yahoo! Geocoder
• Geomap with Gephi network overlay
• Evolving collaboration networks
• R-Bridge
• New Visualizations
12:15pm Outlook and Q&A
12:30pm Adjourn

Tutorial Overview
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New Visualizations 

Types
• Geospatial maps:  Choropleth Map and Proportional Symbol Map
• Science Map: Based on 25,000 journals or 554 subdisciplines.
• Bi-Modal Network Layout

Shared Features
• Uniform layout
• Scalable to extremely large datasets as rendered into PS, PDF files.
• Header information on file mapped and footer information
• Automatic legend generation
• ‘How To Read This Map” information
• Additional pages for details
• Color coding suitable for black and white printout and color blind users
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New Visualizations 

106

New Visualizations 
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New Visualizations 

108

New Visualizations 

Data: WoS and Scopus paper level data for 
2001–2010, about 25,000 separate journals, 
proceedings, and series.
Similarity Metric: Combination of 
bibliographic coupling and keyword vectors.
Number of Disciplines: 554 journal clusters 
further aggregated into 13 main scientific 
disciplines that are labeled and color coded in 
a metaphorical way, e.g., Medicine is blood 
red and Earth Sciences are brown as soil.
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12:30pm Adjourn

Tutorial Overview
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Scholarly Database at Indiana University
http://sdb.wiki.cns.iu.edu

Supports federated search of 25 million publication, patent, grant records.
Results can be downloaded as data dump and (evolving) co-author, paper-citation networks.

Register for free access at http://sdb.cns.iu.edu
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Since March 2009:
Users can download networks:
- Co-author
- Co-investigator  
- Co-inventor
- Patent citation
and tables for 
burst analysis in NWB.
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Börner, Katy. (March 2011). 

Plug-and-Play Macroscopes. 
Communications of the ACM, 
54(3), 60-69. 

Video and paper are at
http://www.scivee.tv/node/27704
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OSGi/CIShell Adoption

A number of other projects recently adopted OSGi and/or CIShell:
 Cytoscape (http://cytoscape.org) Led by Trey Ideker at the University of California, San Diego is 

an open source bioinformatics software platform for visualizing molecular interaction 
networks and integrating these interactions with gene expression profiles and other state data 
(Shannon et al., 2002). 

 MAEviz (https://wiki.ncsa.uiuc.edu/display/MAE/Home) Managed by Jong Lee at NCSA is an 
open-source, extensible software platform which supports seismic risk assessment based on 
the Mid-America Earthquake (MAE) Center research.

 Taverna Workbench (http://taverna.org.uk) Developed by the myGrid team 
(http://mygrid.org.uk) led by Carol Goble at the University of Manchester, U.K. is a free 
software tool for designing and executing workflows (Hull et al., 2006). Taverna allows users 
to integrate many different software tools, including over 30,000 web services.

 TEXTrend (http://textrend.org) Led by George Kampis at Eötvös Loránd University, Budapest, 
Hungary supports natural language processing (NLP), classification/mining, and graph 
algorithms for the analysis of business and governmental text corpuses with an inherently 
temporal component.

 DynaNets (http://www.dynanets.org) Coordinated by Peter M.A. Sloot at the University of 
Amsterdam, The Netherlands develops algorithms to study evolving networks.

 SISOB (http://sisob.lcc.uma.es) An Observatory for Science in Society Based in Social Models.
As the functionality of OSGi-based software frameworks improves and the number and 
diversity of dataset and algorithm plugins increases, the capabilities of custom tools will expand. 
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Network Workbench Tool
http://nwb.slis.indiana.edu

The Network Workbench (NWB) tool 
supports researchers, educators, and 
practitioners interested in the study of  
biomedical, social and behavioral science, 
physics, and other networks. 

In February 2009, the tool provides more 169 
plugins that support the preprocessing, 
analysis, modeling, and visualization of  
networks. 

More than 50 of  these plugins can be 
applied or were specifically designed for 
S&T studies. 

It has been downloaded more than 125,000 
times since December 2006.

Herr II, Bruce W., Huang, Weixia (Bonnie), Penumarthy, Shashikant & Börner, Katy. (2007). Designing Highly Flexible and Usable 
Cyberinfrastructures for Convergence. In Bainbridge, William S. & Roco, Mihail C. (Eds.), Progress in Convergence - Technologies for Human 
Wellbeing (Vol. 1093, pp. 161-179), Annals of  the New York Academy of  Sciences, Boston, MA. 
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TEXTrend adds R bridge, WEKA, Wordij, CFinder, and more.

See the latest versions of TEXTrend Toolkit modules at  
http://textrend.org/index.php?option=com_content&view=article&id=47&Itemid=53
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OSGi/CIShell-Powered Tools Support Algorithm Sharing

118

TexTrend

NWB

EpiC

Sci2

Common algorithm/tool pool
Easy way to share new algorithms
Workflow design logs
Custom tools

Converters

IS
CS
Bio
SNA
Phys



CIShell – Integrate New Algorithms
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CIShell Developer Guide is at http://cishell.wiki.cns.iu.edu

Additional Sci2 Plugins are at http://sci2.wiki.cns.iu.edu/3.2+Additional+Plugins

CIShell – Customize Menu

 The file ‘yourtooldirectory/configuration/default_menu.xml’ encodes the structure of 
the menu system.

 In NWB Tool, the Modeling menu (left) is encoded by the following piece of 
xml code: 
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https://sci2.cns.iu.edu/user/ask.php

Need Help?  Ask an Expert! 
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Interested to Learn More? Take the IVMOOC 
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Q & A

Please complete the Post-Tutorial Questionnaire 
so that we can further improve these tutorials.

* * *
Bug reports and all comments are welcome.

If  you enjoyed the tutorial, please thank Stefan Hornbostel, Jasmin
Schmitz, and Sibylle Glaab at the Institut für Forschungsinformation 

und Qualitätssicherung in Berlin, Germany

All papers, maps, tools, talks, press are linked from http://cns.iu.edu

CNS Facebook: http://www.facebook.com/cnscenter
Mapping Science Exhibit Facebook: http://www.facebook.com/mappingscience


