Before starting...

A .copy of these slides and all other materials you will need during this
tutorial can be obtained from any of the DVDs or USB memoty sticks
being passed around right now

* DPlease register, download, and decompress Sci? from
http://sci2.cns.iu.edu f

* If you have any problems, ask |

David Joseph
* Please try opening PostScript test - chessboard.ps'
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Sci? Manual: http://sci2.wiki.cns.iu.edu

» Additional Datasets http://sci2.wiki.cns.iv.edu/2.5+Sample+Datasets

» Additional Plugins http://sci2.wiki.cns.iv.edu/3.2+Additional+Plugins

NWB/Sci%: A Tool for
Science of Science Research
and Practice

David M. Coe and Joseph Biberstine
Cyberinfrastructure for Network Science Center
School of Library and Information Science
Indiana University, Bloomington, IN

With special thanks to Kevin W. Boyack, Micah Linnemeier,
ssell J. Duhon, Patrick Phillips, Chintan Tank, Chin Hua Kong,

Thomas Smith, Nianli Ma, Scott Weingart, Hanning Guo,

Mark A. Price, Angela M. Zoss, Ted Polley, and Sean Lind

Tuesday, June 19, 2011 * 09:00 — 12:00




Y

\ A4

Tutorial Overview

Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools

Sci? Tool Basics
» Download and run the Sci? Tool
» Walkthrough: Load, analyze, and visualize a network
» Walkthrough: Analyzing the publications of four prominent network science researchers
» Load and clean a dataset; extract networks from raw data
» Calculate basic statistics and analyses of the network
> Visualize the results
Sci? Tool — Advanced Topics
Walkthrough: Visualizing temporal data for NSF projects
Walkthrough: Locating data on a geographic map
Walkthrough: Examining an evolving network
Interacting with the statistical toolkit R and the network visualization package Gephi
Sci? tool visualizations
» Bipartite networks
» Map of Science

Outlook and Q&A
Adjourn
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
» Sci? Tool Basics

» Sci? Tool — Advanced Topics

» Outlook and Q&A

» Adjourn




Take terabytes of data

Plug-and-Play

Macroscopes

Identity trends

Macroscopes

Decision making in science, industry, and politics, as well as in daily life, requires
that we make sense of datasets representing the structure and dynamics of complex

systems

Macroscopes provide a vision of the whole, helping us synthesize the related
elements and enabling us to detect patterns, trends, and outliers while granting

access to myriad details

Rather than making things larger or smaller, macroscopes let us observe what is
too great, slow, or complex for the human eye and mind to notice and

comprehend

Microscopes

Telescopes

Macroscopes




Plug-and-Play Macroscopes

While microscopes and telescopes are physical instruments, macroscopes
are continuously changing bundles of software plugins

Macroscopes make it easy to

» Select and combine not only domain-specific algorithms and bridges to
existing tools but also to meet the cross-cutting infrastructural
requirements needed for a scientifically rigorous cyberinfrastructure

» Put together plugins to create customized tools
» Share plugins via email, flash drives, or online

» Simply drop plugins into the tool they appear in the menu, ready to use

» Sharing algorithm components, tools, ot novel interfaces becomes as easy as
sharing images on Flickr or videos on YouTube

L G s
’%33 C I 1 1211 OSGi & Cyberinfrastructure Shell (CIShell)

» CIShell (http://cishell.org) is an open source software specification for the integration
and utilization of datasets, algorithms, and tools

» It extends the Open Setvices Gateway Initiative (OSGi) (http://osgi.org), a
standardized, modularized service platform

» Widely used in industry for over 10 years

» CIShell provides “sockets” into which algorithms, tools, and datasets can be plugged
using a wizard-driven process

Developers . Users
4 e Ui VI
Alg ) ‘ . ' | Workflow
CIShell Wizards Sei” Tool
Alg | | S || Workflow
—
= Workflow
Tool i
Tool 2| Workflow




%g’ C I S }ﬁE e I I CIShell — Integrate New Algorithms

About the Cyberinfrastructure Shell Learn More...
ClIShell Papers

The Cyberinfrastructure Shell (CIShell) is an open source, community-driven platform for the

integration and utilization of datasets, algorithms, tools, and computing resources. Algorithm I1Sh % 1l Powered Tool
integration support is built in for Java and most other programming languages. Being Java based, %@M&
In min n

it will run on almost all platforms. The software and specification is released under an Apache 2.0
License.

CIShell is the basis of Network Warkbench, TexTrend, Sci® and the upcoming EpiC tool.

CIShell supports remote execution of algorithms. A standard web service definition is in
development that will allow pools of algorithms to transparently be used in a peer-to-peer, client- Getting Started
server, or web front-end fashion.

Misc. Tool Documentation
CIShell Web Services {coming soon)

Screenshots

. ocumentation eveloper R urce:
+ Download
ClIShell Features

Getting Involved...
A framework for easy integration of new and existing algorithms written

in any programming language » Contact Us

Using CIShell, an algorithm writer can fully concentrate on creating their own algorithm in whatever
language they are comfortable with. Simple tools are provided to then take their algorithm and

CIShell Developer Guide is at http://cishell.wiki.cns.iu.edu

Additional Sci? Plugins are at http://sci2.wiki.cns.iuv.edu/3.2+Additional+Plugins

‘%g’ C IS Eﬁﬁ (_:‘I I OSGi/CIShell Adoption

USA

» A number of other projects recently adopted OSGi and/or CIShell:

»  Cytoscape (http://cytoscape.org) Led by Trey Ideker at the University of California, San Diego is an
open source bioinformatics software platform for visualizing molecular interaction networks and
integrating these interactions with gene expression profiles and other state data (Shannon et al., 2002).

» MAEviz (https://wiki.ncsa.uiuc.edu/display/MAE /Home) Managed by Jong Lee at NCSA is an open-
source, extensible software platform which supports seismic risk assessment based on the Mid-America
Earthquake (MAE) Center research.

Europe

A\

Taverna Workbench (http://taverna.org.uk) Developed by the myGrid team (http://mygrid.org.uk) led
by Carol Goble at the University of Manchester, U.K. is a free software tool for designing and executing
workflows (Hull et al., 2006). Taverna allows users to integrate many different software tools, including
over 30,000 web services.

» TEXTrend (http://textrend.org) Led by George Kampis at E6tvos Lorand University, Budapest,
Hungaty supports natural language processing (NLP), classification/mining, and graph algorithms for
the analysis of business and governmental text corpuses with an inherently temporal component.

»  DynaNets (http://www.dynanets.org) Coordinated by Peter M.A. Sloot at the University of
Amsterdam, The Netherlands develops algorithms to study evolving networks.

> SISOB (http://sisob.lcc.uma.cs) An Observatory for Science in Society Based in Social Models.

»  As the functionality of OSGi-based software frameworks improves and the number and

> diversity of dataset and algorithm plugins increases, the capabilities of custom tools will expand.

10




‘géc I S h el l SO};Q:: r{ gCIShell-Powered Tools Support Algorithm

Common algorithm/tool pool
Easy way to share new algorithms
Workflow design logs
Custom tools
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
> Sci? Tool Basics

» Download and run the Sci? Tool
» Walkthrough: Load, analyze, and visualize a network

» Walkthrough: Analyzing the publications of four prominent
network science researchers
» Load and clean a dataset; extract networks from raw data
» Calculate basic statistics and analyses of the network

» Visualize the results

» Sci? Tool — Advanced Topics
» Outlook and Q&A
» Adjourn
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fexiic Science of Science (Sci?) Tool

t}cc of Science

el http://sci2.cns.iu.edu

Effective visualizations
Carefully designed and documented
common workflows

Full logging and data history for perfect
replication of studies

Empowers average users to run common Free and open source software

studies and expert users to perform novel »  Anyone can review and extend the code, or use
research it for commercial purposes

> Advanced algorithms

Built on CIShell/OSGi

Explicitly designed for science of science
research and practice

>
>
»  Well-documented
>
>

Easy to use

Y YV VYV

SUMMARY

o Existing metrics have known flaws

e Areliable, open, joined-up data
infrastructure is needed

o Data should be collected on the full

O P | N | O N range of scientists’ work
e Social scientists and economists

should be involved

nature Vol 464|25 March 2010

Let's make science metrics more scientific

To capture the essence of good science, stakeholders must combine forces to create an open, sound and

consistent system for measuring all the activities that make up academic productivity, says Julia Lane. i,

teol for
L

ce of soience SCiZ Tool

Joint Co-Authorship Network

An OSGi/CIShell-powered tool with NWB plugins and
many new scientometric and visualization plugins

Tesles Viseaiitation

- Map of Science

Barner, Katy, Huang, Weixia (Bonnie), Linnemeier, Micah, Dubon, Russell Jackson, Phillips, Patrick, Ma, Nianli,
Zoss, Angela, Guo, Hanning & Price, Mark. (2009). Rete-Netzwerk-Red: Analyzing and Visualizing Scholarly
Networks Using the Scholarly Database and the Network Workbench Tool. Proceedings of 1SST 2009: 121th

International Conference on Scientometrics and Informetrics, Rio de Janeiro, Brazil, July 14-17 . Vol. 2, pp. 619-630. ”
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Sci” Tool Visualizations S
| % s e
P b
T General " T e e
Welcome to the Science of Science Toel [Seil). Temporal L [l —
The develcpment of this tool is supported in part by the Cyberin Geospatial »  Jence center and the School of Libeary and Information e
| Science at Indiana University, the Maticnal Science Foundation | T and I5-0715303, and the James 5. McDonnell
Foundation, See the Science of Science homepage (httpa/fsci2.y opical ¥ latation and scrsanchats Pleace visit
hittpsy/fscil.cniuedu/userfaskphp if you need help with you| Networks . GUESS
and new festures.
Gephi
Prirnary i gy are Katy Barner, Indi versity and Kevin W, Boyack, SciTech Stri ; oy
Kong, Joseph Biberstine, Thomas G. Smth, David M. Coe, Micah W, Linnemeier, Patrick o] "0l Tree/Gaph (prefusse sipha)
Cyberi Shell (hitp g9 at the Cyber for Nety Fadisl Tree/Geaph with Annotation (prefuse bets)
University. Many algorithm plugins the Network Toal (http Tree View (prefuse bets) .
Please cite as follows: Tree Map (prefuse beta) =

Sci2 Tearn. (2009). Science of Science (Scid) Tool. Indiana University and SciTech Strategies Fodce Directed with Annotation (prefuse beta)

= =V Z, \
@ . — Cllr(.ul:!fH.lel;rthy \ : ,I-Iol
|1 Algorithm Name Date Time % Complete ~- p Al
\\H"‘f—:—:—:—i—
Circular Hierarchy
15
Cognitive and Neuroscience at the NSF: 2007-2011
Cognitive & > ... Hormones/ Social Behavior
Behavioral 17T
Science
Cognitive Science /
ComplexReasoning @ . muwe
: _ ¢ Genetics, Cell Growth,
Language _ @ 7 le\,... and Signaling

Frad: Ses Animain

Neuroscience/ Electrophysiology

.mmm

) . . ) DRAFT - 3/28/12
Human and Machine Perception / Manipulation Leah G. Nichols

lenichol@nsf.gov
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5| Sci® Tool Usage at National Institutes of Health

arch & practice
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‘20 Sci” Tool Usage at National Institutes of Health

Sci? Tool now supports Web setvices and setves as a visual interface to publically
available NIH RePORT Expenditure and Results. RePORTER/ RePORTER data
provided by NIH.

Rerecav

TEMPORAL ANALYRE GEORPATIAL ANALYSIS TORMCAL ANALYBIS

GEOSPATIAL
AMNALYSIS

When™ questions are comm sddressed via temporal anak WHEN
Wihere™ quest o

WHER
What

WHAT
“With whom™ quest

WHOM

18




Sci? Tool Usage at US Department of Agriculture

First time portrait of intramural research conducted by the U.S. Department of
Agriculture (USDA) presented at the VIVO Conference 2012.

Sci? Tool Usage at US Department of Agriculture

20




Sci? Tool Usage at US Department of Agriculture

21

Sci? Tool Usage at James S. McDonnell Foundation
How did conitie neuroscience of attention emerge from neurobiology and
psychology, 198020057 Author co-citation analysis and Pfnet is used to trace
prospectively the development of the field from its precursor disciplines:
cognitive psychology, single cell neurophysiology, neuropsychology, and evoked

potential research. -

e Sctirmicher

Fig. 1 In the 1980 net, neuroscience (black nodes and black-white nodes) and cognitive psychology (whire

nodes) develop as clusters with high internal co-citation rates. ERP (grev nodes) develops later in net

construction. These clusters are connected by secondary edges at very low levels of co-citation 20




By 1990 a

ol for ']
Epce of Science

h & practice

Sci? Tool Usage at James S. McDonnell Foundation

di

stinct cognitive neuroscience specialty cluster emerges, dominated

by authors engaged in brain imaging research.

Bruer, John T.
1980.2005. Scientometrics, 83(3), 751-764. bttp:

Watson
Fig. 5 The strongest link in the 1995 net is a primary edge linking Posner and Petersen. ERP and single cell

neurophysiology are linked to cognitive neuroscience cluster by secondary edges

(2010). Can we talk? How the cognitive neuroscience of attention emerged from neurobiology and psychology,
wl.cns.iu.edu/ km/ tools/ 2010-bruer-scientometrics.pdf
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: ?‘?Lh’f;n Type of Analysis vs. Level of Analysis
Micro/Individual Meso/Local Macro/Global
(2-100 records) (101-10,000 records) | (10,000 < records)
Statistical \ B
Analysis/Profiling \
"nnili
Temporal Analysis _
(When) |
Geospatial Analysis —1
(Where) w
: : % -H Kyre ik
Topical Analysis |~ : S LA
(What) N 4 = HEN L
Network Analysis o iz ;
(With Whom?) ="’ ,a-"nn ¢ o9
. ‘o ‘ﬁ‘ St
e
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Type of Analysis vs. Level of Analysis
Covered Today

Micro/Individual Meso/Local Macro/Global
(2-100 records) (101-10,000 records) | (10,000 < records)

Statistical
Analysis/Profiling

Temporal Analysis

(When) : ‘. o) o@

Geospatial Analysis —— 2
(Where) _indivi ! |

Topical Analysis T N
(What) o i o

Network Analysis e WA
(With Whom?) gy Y O

Sci? Tool — Supported Data Formats

Output:
Network Formats Network File Formats
> GraphML (*.xml or *.graphml) > GraphML (*.xml or *.graphml)
>  XGMML (%.xml) > Pa?ek MAT (*.mat)
> Pajek NET (-.net i ;ﬁ;'ﬁig'neg
> NWB (*.nwb) >  XGMML (*.xml)
Scientometric Formats » CSV (*.csv)
> ISI (*.isi)
> Bibtex (*.bib) Image Formats
» Endnote Export Format (*.enw) > JPEG (~ipg)
> Scopus csv (*.scopus) > PDF (*pdf)
> NSF csv (*.nsf) > PostScript (*.ps)

Other Formats

»  Pajek Matrix (*.mat)
»  TreeML (*.xml)

> Edgelist (*.edge)

» CSV (*.csv)

Formats are documented at http://sci2.wiki.cns.iu.edu/display/SCI2TUTORIAIL/2.3+Data+Formats.

26
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Gnuplot GUESS
portable command-line driven exploratory data analysis and visualization tool
interactive data and function plotting for graphs and networks.
utility http://www.gnuplot.info/. https://nwb.slis.indiana.edu/community/Pn=Vi

sualizeData. GUESS.
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Cytoscape

col for

esotlencs ) Sci? Tool — Supported Tools

Adding more layout algorithms and network visualization
interactivity

via Cytoscape http://www.cvtoscape.org.

Simply add org.texctrend.visnalization.cytoscape_0.0.3.jar into your
/plugin directory.

Restart Sci? Tool

Cytoscape now shows in the Visualization Menu

[S2 Sci2 Tool
File Data Preparation Preprocessing Analysis Modeling RUETESELGY] Heh

B console| st ] = 0| it pata Manager

Cytoscape was selected. Geospatial > A || = 7] 151 Data: C:\Documents and Settings\borner
Integrator(s): TexTrend Consortium (http://www.textrend  Networks  » wis (TexTrend, = r‘ 361 Unique 151 Records

Universitas Press) £, Extracted Co-Authorship Network
\Reference: Cytoscape Consortium {http:ﬁwww.cytns:api ”’L i - =00

F Author information
C:\DOCUME11bornerkiLOCALS~1|Temp\CIShell-Session-6888247 785800266 799\St aticExecut able
Runner-2068718271488870377\algorithm >echo off

cytoscape. Cytoscapelnit[INFO]: Cytoscapelnit static initiakization

| cytoscape.Cytoscapelnit{INFO]: Parent_Dir: C:iDocuments and Settingsibornerk).cytoscape
[created,

Select a network in Data Manager, run Cytoscape and the tool will start with this
network loaded.

28
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Control Panel

Data Panel (]
H04 =2
o |

Prt -

| | Node Attribute Browser | Edge Attrit Browser | 1 k Attribute Browser

Welcome to Cytoscape 2.6.2 Right-cick + drag to ZOOM  Middle-chck + drag to PAN

20.

Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
> Sci? Tool Basics

» Download and run the Sci? Tool
» Walkthrough: Load, analyze, and visualize a network

» Walkthrough: Analyzing the publications of four prominent
network science researchers

» Load and clean a dataset; extract networks from raw data
» Calculate basic statistics and analyses of the network

» Visualize the results

» Sci? Tool — Advanced Topics
» Outlook and Q&A
» Adjourn

30
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Sci? v1.0 Alpha
Can be freely downloaded for all major
operating systems from

http://sci2.cns.iv.edu

Select your operating system from the
pull down menu and download.
Unpack into a /sci2 directory.

Run /sci2/sci2.exe

Sci? Manual is at
http://sci2.wiki.cns.iu.edu

Cite as

Sei? Team. (2009). Science of Science (Sci) Tool.

Indiana University and Scilech Strategies,
hitp:/ [ sci2.cns.in.edu

Sci%: Download, Install, and Run

B4 A [ Hoiouting 31 cnpus map
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Sci? v1.0 alpha

» Supports ASCII UTF-8 characters
>
>
Geographical, and Bipartite data
Customizable stop word lists

New home page, wiki-based tutorial
Reader for Google Scholar

Gephi and R support

YV V VY

Bug fixes, streamlined workflows

Sci? runs on Windows, Mac, and Linux.

Decompress the archive and run SCi12.exe

Sci?: Download, Install, and Run

Web-based Yahoo! and offline geocoders

New visualizations for Temporal, Topical,

1, 5€i2-N-1.0.0.201008130505NGT-macosx.carbon.ppc.zip
1, 5¢i2-N-1.0.0.201008130505NGT-macosxc.carbon.x86.zip

| i, sci2-N-1.0.0.201008130505NGT-macosxccocoaxBb_64.np
£ 5¢i2-N-1.0.0.201008130505NGT-win32.win32.x86.zip

P

) seiz-N-14 91374 KB
'] z::! Browse with Corel Paint Shop Pro Photo X2 L
Open Command Prompt Here
Extract All...
Scan for Viruses... x
1-Z4ip a Open archive
Open With,.. | Extract files...
@ Magiclso =1 Extract Here
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Sci? Tool Interface Components
See also bttp:/ [ sci2.wiki.cns.iu.edn/ 2.2+ User+Interface

G Seid Teal L L
Use ‘v&mmmmmmlm B :
w R
10 the Science of Science Tool [Seid) = ¥ Dowctory Tree - Pre
» Menu to read data, run D et et e
algorithms. g e s -
s e e nt,
» Console to see work log, et ek e s e it o ek s
references to seminal works. P o
» Data Manager to select, view, 8 st — b
save loaded, simulated, or o
. | Algorithen Nasme Date. Teve % Complete
derlved datasets_ i Rusd Disvctory Hiersechy  0B10012  0RS550PM e

» Scheduler to see status of
algorithm execution.

All wotkflows are recorded into a log file (see /sci2/logs/...), and soon can be re-
run for easy replication. If errors occur, they are saved in a error log to ease bug
reporting,

All algorithms are documented online; workflows are given in tutorials, see Sci?
Manual at http://sci2.wiki.cns.iu.edu
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
» Sci? Tool Basics

» Download and run the Sci? Tool
» Walkthrough: Load, analyze, and visualize a network

» Walkthrough: Analyzing the publications of four prominent
network science researchers
» Load and clean a dataset; extract networks from raw data
» Calculate basic statistics and analyses of the network

» Visualize the results

> Sci? Tool — Advanced Topics
» Outlook and Q&A
» Adjourn
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Padgett's Florer
visualize family

Florentine families related through busi
ties such as loans, credits and joint part

Node attributes
» Wealth: Each family's net wealth in
» Priorates: The number of seats on t

» Totalities: Number of business/mas
families.

Edge attributes:
» Marriage T/F
» Business T/F

“Substantively, the data include families
political control of the city of Florence
dominant in this struggle: one revolved
around the powerful Strozzis.”

More info is at http://svitsrv25.epfl.ch

doc/librarv/erom/html/florentine.htm

*N
id
to
1

2
3
4
5
6
7
8

9

10
11
12
13
14
15
16
*U

source*int target*int marriage*string

bu
9
6

g1 o~

odes
*int label*string wealth*int
talities*int priorates*int
"Acciaiuoli™ 10 2 53
“"Albizzi" 36 3 65
"Barbadori'™ 55 14 0
"Bischeri' 44 9 12
"Castellani™ 20 18 22
“Ginori™ 32 9 0
“"Guadagni® 8 14 21
"Lamberteschi™ 42 14 0O
“"Medici' 103 54 53
“"Pazzi™ 48 7 0
"“"Peruzzi' 49 32 42
“"Pucci™ 310
"Ridolfi" 27 4 38
"Salviati™ 10 5 35
“"Strozzi'" 146 29 74

"Tornabuoni™ 48 7 0
ndirectedEdges

siness*string
1 w7 "ET
A B S
A B S
A B S
3 T orT

Padgett's Florentine Families — Load, compute basic
network properties & view in GUESS

» Load yoursci2directory/sampledata/socialscience/florentine.nwb
» RunAnalysis > Networks > Network Analysis Toolkit (NAT) to get basic

properties.
This graph claims to be undirected.
Nodes: 16
Isolated nodes: 1
Node attributes present: label, wealth, totalities, priorates
Edges: 27
No self loops were discovered.
No parallel edges were discovered.
Edge attributes:
Nonnumeric attributes:
Example value
marriag...T
busines...F
Did not detect any numeric attributes.
This network does not seem to be a valued network.
Average degree: 3.375
This graph is not weakly connected.
There are 2 weakly connected components. (1 isolates)
The largest connected component consists of 15 nodes.

Did not calculate strong connectedness because this graph was not directed.

Density (disregarding weights): 0.225

> Select network and run Visualization > Networks > GUESS to open GUESS with file

loade

> Apply Layout > GEM
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UESS was selected

puthor(s): Eytan Adar

rnplementer(s): Eytan Adar (GUESS), Russell Duhon (resizelinear, colorize fix)

ntegrator(s): Russell Dubon

Reference: Adar, Eytan, "GUESS: A Language and Interface for Graph Exploration,” CHI 2006 (http://graphesploration.cond.org/)
Document stion: https://nwb.slis.indiana.edu/community, ?n =VisualizeDat 2. GUESS

ECHO is off.

prarting GLESS...

ECHO is off.

[The irstial layout For your visuskzation is random. For a clearer visuakzation, please run & Layout from the Layout menu. (We recommend GEM, )
ECHO is off.

GUESS log file For this session can be found in

« NWE file: C:\Documents and Settings|katy\C

« List of edges of network crested through the

“ NWB file: C:\Documents and Settingsikaty\l

™' Distribution of degree for network at sty

P Dustribution of degree for network at sty
™" Distribution of degree for network. at sty

= Sequence of site betweennesses for no
" Distribution of site betweenness for nety
"' Distribution of site betweenness for ety

Graph and Network Anahysis Log

I \DOCUME ~ 1 sty \LOCALS~1 | Temp| C15hed- SEAZIStaticExeut, SSA04LALGOR] guessiog.txt ‘s + NWE File with site betweenness attribute
s 101 x
puthor(s): EvtanAdsr | Fle Edk  layot Soph View Heb
{s): Eytan Adi
Inbegraton(s): Russell Dubs k- |
B e araas A, Evtan - Medici-Acciaiuoli |
Documentation: https://1 Field Value |
ECHO is off. __edgesd o
Etarting GLESS. .. Business F
ECHO is off.
e il layout for your 1| 2 (€0 dandelon
ECHO is off. 5 [drected False
SUESS log File For this sess| .5 label
:\DOCLUME ~ 1 Yraty\LOCR Iabedcolor 0,0,0,255
Labedsize 12
) Scheduer :"f"*“;e“"* o
Remove From List | ™ F ﬁl "T
L 2 n
visibie true
.ﬂl wesght 1.0
1 dhmp | D 4
GUESS
GLESS
|| Node Betw
| Network Az
¥ Load...
. GraPlot
R 2 o Object: = property: | Operator: ahua:
| Degres Dis .
J ] BarablshA Colour Show Hide Size Show Label Hide Label Change Label
| Gralot ;
b Desgres Dis Node Shape Center Change History
v GUESS
| Load...
Interpreter | Graph Modifier
| K1 | 37
visualization - GUESS -lo|x| Pan:
Ble Edt Layot Script Yiew Help “grab” the background
Medici ¢ by holding left-click
Field || Value | . and moving your
g color cornfio... J g y
fixed  fakse mouse.
g height 10,0 J
& mage
E label Medici /.oom:
Iabelcolor 0,0,0,... .
labelsize 12 Using scroll wheel,
labetvi... False & 000 press the “+” and “-”
name  n9 _k] 0 g :
.. SMCECEEEEN  buttons in the upper-
priorates 53 O ! Color... left hand corner, or
stroke... cadetb... . .
ave 2 X pemore right-click and move
totalities 54 Add the mouse left or right.
visible  true -@ Modify Feld. ..
.
wealth 103 lkj e e Cente; gr‘ap'h by
width 10,0 selecting “View ->
i ol - Center’.

y 44.312... :k‘j

Interpreter . Graph Modifier

aw
Object: = Property: Operator; * | Yalye:
Colour Show Hide || Size Show Label Hide Label Change Label
Format Node Labels Format Edge Labels
Node Shape Center Change History
Resize Linear Colorize
Nodes w| |labelsize = From: To: Do Resize Linear

Select Q‘ to

select/move single
nodes. Hold down
‘Shift’ to select
multiple.

Right click to modify
Color, etc.
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o Jrow

Graph Modifier:

Select al I nodes in the Object
drop-down menu and click Show
Label button.

Select Resize Linear >
Nodes > totalities drop-
down menu, then type 5 and 20
into the From and To value box
separately. Then select Do
Resize Linear.

Select Colorize>
Nodes>totalities, then select
white and enter (204,0,51) in the
pop-up color boxes on in the
From and To buttons.

Select “Format Node Labels”,
replace default text
{originallabel} with your

| own label in the pop-up box

Enter a formatting string
for node labels.
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r -
# 5 NWB file: C:\Users\jrbibers\nightlies\sci2-259\

nwb - GUESS.

Hle Edt Layout Saipt View Hep

Medici &
Fed | Value £
color 76,255,7... o
fixed  faise
g beght 20,0 —)
Medici

wealth 103
width 20.0
X 80.6520...
L 43.9161...

|
bl i
B 2R RS

Oco=
QL.

O' ‘Pazzi
O Salviati

O Ginori

O Mdo Tomabuoni

Guadagni

Strozzi

Medici

- O Acciaiudli

o Lambert
O Bischeri
s s

Interpreter:

Uses Jython, a combination of Java and Python

>>> resizelinear(totalities,5,20)
>>> colorize(wealth,white,green)
>35>

Try:

colorize(wealth, white, green)

|/ Graph Modifier |
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools

» Sci? Tool Basics
» Download and run the Sci? Tool
» Walkthrough: Load, analyze, and visualize a network

» Walkthrough: Analyzing the publications of four prominent
network science researchers
» Load and clean a dataset; extract networks from raw data
» Calculate basic statistics and analyses of the network
» Visualize the results

» Sci? Tool — Advanced Topics
» Outlook and Q&A
» Adjourn

41

Studying Four Major NetSci Researchers (ISI Data)
using Database (section 5.1.4)

Time frame: 1955-2007

Region(s): Miscellaneous

Topical Area(s): | Network Science

Analysis Type(s): Paper Citation Network, Co-Author Network, Bibliographic

Coupling Network, Document Co-Citation Network, Word Co-
Occurrence Network

Thomson Reuter’s Web of Knowledge (WoS) is a leading citation database

Access it via the “Web of Science” tab at http://wwwisiknowledge.com

(note: access to this database requires a paid subscription)
Along with Scopus, WoS provides some of the most comprehensive datasets for
scientometric analysis
To find all publications by an author, search for the last name and the first initial
followed by an asterisk in the author field

bttp:/ [ sei2.wiki.cns.in.edu/ 5. 1.4+ Studying+ Four+Major+NetS ci+Researchers+(1S1+ Data)
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Data Acquisition from Web of Science

In December 2007, we downloaded

all papers by
» BEugene Garfield
» Stanley Wasserman P e —.
» Alessandro Vespignani B S . p——
> Albert-14s216 Barabisi e €t [ o e, 2
ert- aSz10 arapasi : :$;27:|WJW£;E:m:'“mml :;::“ I% 0 [T ] (ot s o yours)
from 1) Arts & Humanities Craton Indes (ASHCT)-~1975-present To remember these settings, first ign i or regater.
. . . mﬂ;m;ﬁmﬂﬁﬂuﬁhuvﬂmw OR, NOT, or SAME, “"‘”‘I“m Wi our Gensral Sesech tutonal
» Science Citation Index kel s
Expanded (SCI-EXPANDED) 1 A L LT R e
--1955-present | sy v o e
. . . . Author Frder: Weed help findng papers by an suthor? Use Author Finder.
» Social Sciences Citation Index o i o e e o B D
(SSCI)--1956-present
fel : : w’"‘i&"&"mm mhnch-:uo-mw
» Arts & Humanities Citation [
Index (A&HCI)--1975-present = ki
ADDRESS: ;izu;wmum tarms from an suthor's affation (use gbreviatons heip).
Restnct search by languages and document types:

Comparison of Counts
No books and other non-WoS publications are covered.

Researcher Total # Cites | Total # Papers
Eugene Garfield 32 1525 672 31
Stanley Wasserman 122 35 17
Alessandro Vespignani 42 451 101 33
Albert-Laszl6 Barabasi  (Dec 2007) 40 2918 126 47
Dec2008) 44 16920 159 52
(April 2011) 4y 30102 201 68
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Extract Co-Author Network

YourSci2Directory/sampledata/scientometrics/isi/FourNetSciR
esearchers.isi

using File > Load..
A table of 361 unique records will be loaded into the Data Manager
Duplicates are removed and a log file is created

¥ Sci2 Tool [ESRECY X |
| File  Dats Preparation Preprocessing Analysis Modeling ation R Help
) Consale = O || itil Data Manager =i0
Found old-style IS'Web Of Knowledge file. A | D 151 Data: C:\Users\, \Dﬁhop\sc.

The original 361 records have been processed to remove duplicate unique ISIIDs leaving 361

| [“ 361 Unique ISI Records
records.

Wrote log to

C:\U;_e_rs_\ \A_ppDau'_\l.ucaii\Temp '_ duplicateremove ""i““m? et
|| B Scheduter =h
!_ Remove From I.in.! Remove completed ically Remm all completed |
! Algorithm Name Date Time % Complete
| ¥ Load.. 06/12/2012 04:17:43PM

455

L‘:;,;m i| Extract Co-Author Network
(see section 5.1.4.2 on correcting duplicate/ misspelled author names)

To extract the co-author network, select the 361 Unique ISI Records
table and run Data Preparatlon > Extract Co-Author Network
l.lSlIlg the ISI ﬁle format B Extract Co-Author Network x|

Exbutsamm#ﬁ:mtwukﬁm“ofmdﬂpportedﬂa
types.

File Format |isi i
|
» The result is an undirected but weighted network of co-authors in the Data

Manager.

Run Analysis > Networks > Network Analysis Toolkit (NAT)to
calculate basic properties: the network has 247 nodes and 891 edges.

Use Analysis > Networks > Unweighted and Undirected > Node
Degree to calculate the number of neighbors for each node independent
of co-authorship weight

» To view the complete network, select the Extracted Co-Authorship
Network and run Visualization > Networks > GUESS

» Network is loaded with random layout. In GUESS, run Layout > GEM
and Layout > Bin Pack to im dprove layout. Run Scrlpt > Run
Script.. and select yoursci2directory/scripts/GUESS/co-author-
nw.py
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Co-Author Network of all Four NetSci Researchers

Stanley Wasscrman

R R ‘-.‘ " Node Size & Color Edge Shre & Color
“‘H.ﬂ-"_'-- gk . A isthuowr ..| o
- = 27
Eugene Garfield 3
i 9

477

1.3 teol for. §

it Co-Author Network of all Four NetSci Researchers

larch & practice

&,

Use the GUESS Graph Modifier to
change color and size coding.

Stanley Wasscrman

Calculate node degrees in Sci?

An image editor can be used to add
legends

e s ¥ Node Size & Color Edge She {kIL'nlnr
T " Co-Authored
> 127
Eugene Garficld 2
s ?
5 1
| |
1 127 1 33
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Network Visualization:
Node Layout

Load... was selected.
Found old-style ISI/Web Of Knowledge
file.

The original 361 records have been
processed to remove duplicate unique ISI
IDs leaving 361 records.

Extract Co-Author Network was selected.
Input Parameters:
File Format: isi

Network Analysis Toolkit (NAT) was v .
selected. @ K. [
Nodes: 247 }

Edges: 891

GUESS was selected.
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ik Network Visualization:

e of Science

8l  Color/Size Coding by Data Attribute Values
icolor 125,12,17,255
fixed false

g height 10.0 "
image
label Vespignani, A .
~— labelcolor 0,0,0,255
b iz \ -
labetvisible false ® Node Size & Color Edge Size & Color
name nlél ™ Number of Papers Number of Times
numberofworks 101 ) : Co-Authored
A

oo e —={ Gt 3
= 5 ° = 9
timescited 3811 N\ ]
visible true = —_—
— e
X 586.75
ly 107.25 L 1 127 1 33




Network Visualization:
Giant Component

8
ce of Science

larch & practice

Weak Component Clustering was selected.
Implementer(s): Russell Duhon
Integrator(s): Russell Duhon

Input Parameters:
Number of top clusters: 10
3 clusters found, generating graphs for the top 3 clusters.
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Xt o Network Visualization:

ce of Science

Color/Size Coding by Degree

Node Degree was selected.

Documentation:

https://nwb.slis.indiana.edu/community/?n=AnalyzeData.NodeDegree
L]

- * . .
. . » .
.
o .
L] 2 - . - .
.- | 7 . )
P e ",
Garield E ®
. 4 - mman, §
@ ® o
.. Py L ] ® .
-] °® * e
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Node Betweenness Centrality was selected.

Network Visualization:
Color/Size Coding by Betweenness Centrality

Ateol for

c(!i!cicnrl:
arch & practice

Author(s): L. C. Freeman
Implementer(s): Santo Fortunato
Integrator(s): Santo Fortunato, Weixia Huang

Reference: Freeman,

L. C. (1977). A set of measuring centrality

based on betweenness. Sociometry. 40:35-41. *

& : I P . A
. r
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& Atool for

Sscifpce (!i!cicnrl:

Network Visualization:
Reduced Network After Pathfinder Network Scaling

ST eMakeev, MA ol [fe %
MF" T 5 Aﬁ HE .,
A\ ®mong H .
sHmil s | ., ofaia B
a1
2% y '.u;.“’““"L .f (
B LA R OPasoesabmasRe alorsto,V
®0tva, 2N .:m}‘":::“
.I\'id'.:,‘! “.‘. . : o
SRR @Phoneo, L
. V4 L] wBarthelemy, M
‘ ®Barat A
MST-Pathfinder Network Scaling was selected. . - .
Input Parameters: T vm——
Weight Attribute measures: SIMILARITY [ )

Edge Weight Attribute: weight
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Network Visualization:

ST Circular Hierarchy Visualization

Select Co-Author Network and run Blondel Community detection:

File DataPreparation Preprocessing | Analysis | Modeling  Visualizati Help
B Console i Temporal » S0 .
= : Geospatial » il = "NEH-AZ&H-Worksh : N
R T — 2 , JElData, C._\Users\User\Dzsitop\l.ll NEH-A&H-Workshop\DVD\sciZ\sample
Author(s): Micah Linnemeier P | 4 |} 361 Unique IS Records
Implementer(s): Micah Linnemeier Networks 4 | Network Analysis Toolkit (NAT) bn
Integrator(s): Micah Li i NetSciResearchers.isi
Documentation: | Urweighted & Undirected PEN. 4
:.oarde; bslis.indi duf ity/tn=LoadData.ISRoadAq Weighted & Undirected » Clustering Coefficient
|CAUsers\User\Desktop\10-NEH-A&H-Workshop\DVD\sciZ\sample Unweighted & Directed » Nearest Neighbor Degree
(ometrics\isi\FourNetSciResearchers.isi Weighted & Directed » Strength s Degree
;“-’““’ ﬁ:“]f‘”- P ||+ 1 1st0ate: C\Usersiuse)  Degree & Strength
emoved §/dupkcate records, i : Average Weight vs End-point Degree
Author names have been normalized. g 361 e : : g. : g ’
o« Extracted Co-£ Strength Distribution
361 records with unique ISTIDs are available via Data Manager. £ Author inform| Weight Distribution
Wrote log to Randomize Weights
CAU ] DatatL Temphisidupli rlogd773522398971021
3-;\&;;"\ e Lot g iow 7 Blondel Community Detection
) % Blondel Community Detection X
With parameter values oo o= Comemmity detection
algorithm.
Weight |number_of_coauthored_works -
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Network Visualization:

= Circular Hierarchy Visualization

Visualize resulting file using ‘V7sualization > Networks > Circular Hierarchy’

with parameter values

& Circular Hierarchy

Provides Circular Hierarchy Visualization on the

Degree of Edge Bundling 0.75

Node Strength Column [times cited

*| (@)

-] (@]

’) (@)

-)(®)

Level blondel_community_level.0
Level1 | blondel_community _level 1
Level 2 [ blondel_community_level_2
Level3 [No Level

") (@)

Edge Weight Column {number_ﬂf_mmhond_mrks

-)(®)

Node Color Column {nurldnf_of_wlhmed_wutb

-)[®]

Node Color Range [Gl‘tﬁ\ to red

) (@)
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Network Visualization:
Circular Hierarchy Visualization

Nodes that are interlinked/clustered e,
are spatially close to minimize the
number of edge crossings.

Node labels, e.g., . & Y. \\

author names. / S
/ S
/l
/l : \\
/| 1\
Network structute f—= > |
. . | —-= 1\
using edge bundling. o = =.

Color coded cluster ———»
hierarchy according to

Blondel community 5.
detection algorithm. N
Note: ~ _—

Header/footer info, legend, and more meaningful color coding are under development. .

Paper-Citation Network Layout

»To extract the paper-citation network, select the 361 Unique IS1 Records
table and run Data Preparation > Extract Paper Citation Network

»The result is a unweighted, directed network of papers linked by citations,
named Extracted paper-citation network in the Data Manager.
»Run NAT to calculate that the network has 5,342 nodes and 9,612 edges.

There are 15 weakly connected components. (0 isolates)

»Run Analysis > Networks > Unweighted and Directed > Weak
Component Clustering with parameters

@ —
& | Weak Component Clustering %, Weak Component Cluster of 5151 nodes
Creates new graphs containing the top connected components. 5, Weak Component Cluster of 38 nodes
%, Weak Component Cluster of 35 nodes
LS
Number of top clusters 10| 73 = Weak Component Cluster of 27 nodes
»+ Weak Component Cluster of 27 nodes.2
. %7, Weak Component Cluster of 15 nodes
(Lo ] [Cencel

to identify top-10 largest components. The largest (giant) component has
5,151 nodes.
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General Network Extraction:

Weighted, Undirected Co-Occurrence Network

A B C D
1 Paper Authors References Year
2 P1 Al 1570
3 P2 A2;AB P1 1980
4 |P3 Al;A3 P1;P2 1990
5 P4 ALA4;AS P2 1995
6 PS5 AS5;AB P1;P2;P3;P4 1995
7 P6 A2;A6 P5 2000
Author co-occurrence network ®x
L™
[N Extract Network from Table _ % ®
Extracts a network from a delimited table
Column Name I;u_-':v.:rﬁ
.1\3
Text Delimiter F]

® .

.Nj

*Vertices 6
Al
A6
A2
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larch & practice

A B c D

1 Paper Authors References Year
2 P Al 1970
3 |P2 A2;A6 P1 1980
4 P3 ALA3 P1;P2 1990
5 P4 ALA4;AS P2 1995
6 P5 AS;AB P1;P2;P3;P4 1995
7 P AZ;A6 P5 2000

L 05

4 . P2
[
\

!
Y

%
® Author

B Paper H.

General Network Extraction:
Unweighted, Directed Bipartite Network

*Vertices 12
P1 bipartitetype
Al bipartitetype
P2 bipartitetype
A2 bipartitetype
bipartitetype
P3 bipartitetype
A3 bipartitetype
P4 bipartitetype
A4 bipartitetype

©O~NOUIDWNE
>
o

"Paper™
"Authors"
"Paper"’
"Authors"
"Authors"
"Paper"
"Authors"
"Paper"’
"Authors"

10 A5 bipartitetype "Authors"
11 P5 bipartitetype "Paper”

. . ™ 12 P6 bipartitetype "Paper”
Paper-author bipartite (2-mode) network *Arcs
12
\ 34
Extract a bipartite network from two columns in the table. If the cobmn E' WO s 5
values may list multiple entries, enter the spedal text which delimits J
them. / 6 7
column |P / 8 2
£ e ; 8 10
Second column |Authors -'."-“ 8 9
Text Delimiter 13l | . 11 10
7 P1 12 4
0. 12 5
Object: [nodes based on -> | =| Property: |bipartitetype = Operators | == w| Value: [Poper] || o

General Network Extraction:
Unweighted, Directed Paper-Citation Network

SEarch & practice
- .

A B c D

*Vertices 6
1 Paper Authors References Year
2 P1 Al 1970 1Pl
3 P2 AZA6 Pl 1980 2 P2
4 P3  ALAI  PLP2 1990 3 P3
5 P4 ALA4A5 P2 1995
6 PS  AS5;A6  P1;P2;P3;P4 1995 4 P4
7 P6  AZA6 PS5 2000 5 P5
6 P6
*Arcs
21
31
avena b, thsaoorit  ALCS from  papers to references 32
drected edge that starts a 4 2
column node.
. 54
Source Column |Paﬂef P3., 5 3
Target Gokum References . III&% 'IIIIM 51
Text Delimiter [; III:M 52
6 5

H.

1995

I

1970 1980 1990 2000
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General Network Extraction:

Unweighted, Directed Bi-Partite Network
*Vertices 11

1 Paper Authors References Year 1prl bipart!tetype "Paper™
2lp1 AL 1970 2 P2 b!part!tetype "Paper"
3 P2 AZA6 Pl 1980 ° 3 P1 bipartitetype “References™
4 P3  ALA3  PLP2 1990 M]_Stake' 4 P3 bipartitetype “Paper™
S Pa  ALA%AS P2 1995 ° 5 P2 bipartitetype 'References"
6 PS  ASA6  PL;P2;P3;P4 1995 6 P4 bipartitetype "Paper”
7 P6  AZA6 PS5 2000 7 P5 bipartitetype "Paper"
8 P4 bipartitetype "References"
- 9 P3 bipartitetype "References"
= B 10 P6 bipartitetype "Paper"
' s 11 P5 bipartitetype "References™
. & v *
e M NS
Extract a bipartite network P3 ;_..93 43
mmvmmm -P2 45
6 5
First column ]Pape! ) .P4 7 3
Second column References 79
75
Text Dedmiter [ P 78
10 11
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Ateol for 4
iepce of Science

ISI Paper-Citation Network Extraction

e resfarch & practice
0 3

A B C D E
1 Authors Cited References Publication Year Title Cite Me As
2 A1|A2  BENSMAN SJ, 1998, LIBR RESOUR TECH SER, V42, P147|BROI 2000 T1 A1, 2000, INT MICROBIOL, V10, P65
3 Al BENSMAN SJ, 1999, LIBR RESOUR TECH SER, V42, P147|BROI 2000 T2 A1, 2000, P ASIST ANNU MEET, V40, P486
4 A2|A3 GARFIELD E, 1985, ESSAYS INFORMATION S, V8, P403| GILBE 2001 T3 A2, 2001, SCIENTOMETRICS, V60, P295
5 Al ASIMOV A, 1963, GENETIC CODE | LEDERBERG J, 1972, NATUI 2001 T4 A1, 2001, J INFORM SCI, V30, P119
6 A1|A2  AVERY OT, 1944, ) EXP MED, V79, P137|SMALL H, 1985, J INF 2002 TS A1, 2002, INFORM TECHNOL LIBR, V22, P183

Arcs from references to papers—
In the direction of information flow

| N
Ny ) “MA1, 2001, J Inform Sci, V30, P119
= IAT2000, Int Microbiol, V10, PSS g

A, M A1, 2002, Inform Technd Libr, V22, P183
-
. . =l A2, 2001, Scienlomelrics, V60, P295
———AT,2000, P AsistAnnu Meet, V40, P486
5]

2000 2001 2002
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
» Sci? Tool Basics

> Sci? Tool — Advanced Topics
» Walkthrough: Visualizing temporal data for NSF projects
» Walkthrough: Locating data on a geographic map
» Walkthrough: Examining an evolving network

» Interacting with the statistical toolkit R and the network visualization
package Gephi
» Sci? tool visualizations
» Bipartite networks
» Map of Science

» Outlook and Q&A
» Adjourn
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
> Sci? Tool Basics

» Sci? Tool — Advanced Topics
» Walkthrough: Visualizing temporal data for NSF projects
» Walkthrough: Locating data on a geographic map
» Walkthrough: Examining an evolving network

» Interacting with the statistical toolkit R and the network visualization
package Gephi
» Sci? tool visualizations
» Bipartite networks
» Map of Science

» Outlook and Q&A
» Adjourn
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Temporal bar graph for NSF projects
See 5.2.1 Funding Profiles of Three Universities (NSE Data)

Download NSF data Visualize as Temporal Bar Graph

x

Subttle | exw e ] el -;d
[P =
StatDate [t Cate ;]ll

EndDate  [Last Amendmens Date ﬂ_{d

Ii SceBy  [Aworded Aot o Date ;Iil

o] | St B o | ] Gote Formet [Morkh-Diry-Year Dste Format (U.5., £.9. 10/15/2010) = il
Category  [Mo Categuny Colorr =3

¥ Scoe Cutput? =

Area size equals numerical
value, e.g., award amount.

Text

Start date End date

: el x e e
N N R R
6 o] o st o SRR | 30 - o e

NSF Wb Ste =l
-

WOME | FUNDING | AWARDS | O

Award Search

s Lt et e T Saarch All Fiakds L —

Mint: Tha tast fald balom ‘Tanrch dmard or' shatrace nd wmard

Saarh Ak Forn

Beatiit n Totke Sk [

) Amaien Intermation

BLGL200H  Basy Wymgs

-.m.u--,. | PI Lockug |

QLOLTION  Mawl Jpaaihe
Wimts [nciufing CO-B1 will rmalt i shomer naarchas.
dxeaon | Ak
Incledy CO-F11
Srsamsetio _Organization Lookup |
Al
besimacar 0L/0L200% i lw
reteyd ']




Temporal Bar Graph of NSF projects

Download and load a dataset of your choice or load one of the sample data files, e.g,,
sampledata/scientometrics/nst/Indiana.nsf

Run Visualization > Temporal > Temporal Bar Graph using

parameters:
;.:;Lnbulu data and generates PostScript for & temporal bar
Subtitle Generated from NSF v fie: g 2 (@ “"DI&IHMIIQI!
Label Title ~| @) ! ¥ Directory Tree -_Preluse (Beta) Graph
g - J@ O ottt e
EndDute  [Expuation Dute @ B i wives
| Sueby  [Awerded Amountio Dute -[@
Date F [Month-Day-Year Date F 5. e 10/15/2010) - 9
|| Category | No Categery Colaring = | @
7Sl Gutpu 3
l Simplified Layout? @
() (ens
i J

Save visualized with Temporal Bar Graph asPS or EPS file
Convert into PDF and view

Zoom to see details in visualizations of large datasets, e.g;, all NSIF awards ever made
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Temporal Bar Graph of NSF projects

Area size equals numerical

value, e.g., award amount.

S *

Start date End date

Collaborative Res
Sk

Second You

More NSF data wotkflows can be found in wiki tutorial:
5.1.3 Funding Profiles of Three Researchers at Indiana University (NSE Data)
5.2.1 Funding Profiles of Three Universities (NSF Data)

5.2.3 Biomedical Funding Profile of NSF (NSF Data)
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
» Sci? Tool Basics

> Sci? Tool — Advanced Topics
» Walkthrough: Visualizing temporal data for NSF projects
» Walkthrough: Locating data on a geographic map
» Walkthrough: Examining an evolving network

> Interacting with the statistical toolkit R and the network visualization
package Gephi
» Sci? tool visualizations
» Bipartite networks
» Map of Science

» Outlook and Q&A
» Adjourn
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Geocoding and Geospatial Maps
bttp:/ [ wiki.cns.in.edn/ display/ CIS HEILL/ Yahoo+Geocoder

!
-

Aggregate (if
necessary)

e Data with
geographic
identifiers

* Geographic
e Geolocated identifiers

data with data (Choropleth Map)

Region names + numeric data

Visualize i

(- I

Geocoordinates + numeric data
(Proportional Symbol Map)
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s Load File with Address and Times Cited Fields
.4 R
Run File > Load..

Load the sample data table sampledata/geo/usptolnfluenza.csv

Let’s create a map showing influenza-related patent activity in the following

countries
A B C D E
1 Country Latitude  Longitude Patents Times Cited
2 Hungary 47.16116  19.504959 0.083333333 4 ——
3 Belgium 50.500992 4.47677 3.017857143 11 e A =)
4 Germany 51.090839 10.45424 4.783333333 4 CS\"ﬁIEC:\SCiZ‘ pledata\geo\usptolnfl 5V
5 Canada 62.35873 -96.582092 5.539285714 21
6 Russia 59.461479 108.831779 0.266666667 2
7 Austria 47.69651 13.34577 4.2 17
8 Netherlands 52.108089 5.33033 1 2
9 Switzerland 46.813091 8.22414 0.507575758 6
10 Taiwan 23.599751 121.023811 2 3
11 Australia -24.916201 133.393112 1.617857143 23
12 United States 39.83 -98.58 73.9983889 220
13 France 46.712448 1.71832 2.201165501 9
14 'South Africa -28.483219 24.676991 0.333333333 1
15 Japan 37.487598 139.838287 15.99166667 39
16 Israel 31.389299  35.36124 3.5 3
17 United Kingdom  54.313919 -2.23218 3.85 12
73
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54| Yahoo Geocoder
g:’C |She|| Yahoo Geocoder £ Edt b Add - £ Tools -
. L - -

Added by Aretha Alencar. last edited by Kavin Kumar Palanisamy on Feb 08, 2012 (view change)

Description

This algorithm converts place names or addresses into Latitude, Longitude co-ordinates. It accepts international addresses,
countries, States of United States of America and ZIP codes of United States of America. All co-ordinates are obtained by querying
Yahoo! PlaceFinder service. Internet access must be available during geocoding.

Pros & Cons

1. The performance is slower than the Geocoder and may vary due to the network latency since the queries are requested
through internet service. The benchmark test geocoded 470 unique locations per minute

2. Yahoo! Geocoder supports address geocoding with international coverage which is not supported by Geocoder.

3. To use Yahoo! Geocoder, user has to obtain an application id through Yahoo! registration. Save your application id and
provide it when requested by the Yahoo! Geocoder. Since each application id is allowed to geocode 50,000 locations per
24 hours, the user is encouraged to test on a small set of data first.

Applications

The plugin is useful for scientists who would like to visualize their data on a geographical map (geomap). User can obtain the
geographical coordinates (Latitude and Longitude values) and feed them to the visualization plugin.

bhttp:/ [ wikt.cns.in.edu/ display/ CLS HEIL L./ Yahoo+Geocoder
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Run Analysis > Geospatial > Yahoo Geocoder

| Analysis Modeling Visuslization R Help

Temporal l|

Waty

Records

— S — _ :
1 Yahoo! Geocoder e S cany g
Geccodes place names to geographic coordinates (latitudes and
longitudes) using Yahoo. Ensure your machine is connected to
the Internet. [f you need to geocode more than a few entities, you
may wish to obtain a Yahoo Place Finder application ID from
http://developer.yahoo.com/geo/placefinder/ . You may
otherwise leave this field blank. Each ID is limited to 50,000

f q per day. Perfi & may vary due to network latency;
expect about 500 unique requests per minute.
|
Yahoo Application ID
Place Type [Mm ,] http:

Application 1D, see:

developer.yahoo.com/geo/placefinder

You can leave Application 1D blank for
trial purposes, but before heavy use, register
later for your own personal Yahoo!

- l
[V Include address details

U
Place Name Column Eep«nt Address
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- rne Aggregate by Country

Aggregate Data was selected.

Implementer(s): Chintan Tank

Documentation: http:/ /wiki.cns.iu.edu/display/ CISHELL/Aggregate+Data
Input Parameters:

Aggregate on column: Country

Delimiter for Country: |

Longitude: AVERAGE

Latitude: AVERAGE

Times Cited: SUM

Aggregated by ": All rows of Latitude column were skipped due to no non-null, non-empty values.
Aggregated by ": All rows of Longitude column were skipped due to no non-null, non-empty values.

Frequency of unique "Country" values added to "Count" column.

Temporal »

[N Aggregate Data

Times Cited
Latitude

Longitude

_ A B c D A B

1 Times Cited Latitude Longitude  Country 1| Times Cited JLatitude

2 7 42.02946091 -87.68838501 United States 2 14680 [[41.10645f]
3 0 3 1802

4 0 4 398 [[47.506226f]
5 2 42.34999466 -71.08765411 United States 5 101 [[37.25198f]
6 14 41.70074844 -86.23918915 United States 6 18 |[32.08439f]
7 15 41.70074844 -86.23918915 United States 7 57 [[46.768517f]
8 29 41.89422607 -87.61901855 United States 8 55 [47.06615f]
9 32 41.70074844 -86.23918915 United States _+ e 455 [[47.9771841)
10 7 41.70074844 -86.23918915 United States 1 92 [(52.15457f]
11 5 41.70074844 -86.23918915 United States 1 21 [(49.944717f]
12 2 41.11500168 -85.73377991 United States 1 1112 [[41.545982f]
13 10 47.50622177 19.06481934 Hungary 1 1381 [[43.352654f]
14 44 4170074844 -86.23918915 United States 1 188 [[-22.494667f]
15 0 47.50622559 19.06481934 Hungary 56 [[51.24459f]
16 19 41.70074844 -86.23918915 United States 1 0

[-16.49301f]

C
Longitude  Country
[-82.45309f] United States

[19.06482f] Hungary
[127.08451f] South Korea
[34.81297f] Israel
[23.585135f] Romania
[7.2015657f] Switzerland
[2.2232702f] France
[4.49463f] Netherlands
[84.528114f] Russia
[1.7138832f] Spain
[12.727126f] Italy
[-45.4818f] Brazil
[10.360385f] Germany
[-68.14626f] Bolivia

Aggregate data in the table based on a column,
fogegateoncoumn [Conry =] @
Cra—
e —
)
m&mh—i'

£ =

x|

Count
194
57
14

gl—b |l
= Now WU R NN B
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5 Choropleth Map =8 =

Choropleth Map Color-codes the name
proportion to associati
Subtitle Generated from CSV
Geospatial » Proportional Symbol Map Map [WOﬂd
Topical » Choropleth Map
Networks » Geospatial Network Layout with Base Map Region Name [Country

Right-click and Save map

Open this PostScript file to
visualize

ColorBy |Times Cited

Color Scaling [Logarithmic

Color Range [[Yellow to Blue

- CSV file: C:\sci2\sampledata\geo\usptolnfluenza.csv

|19 Geospatial Visualization (Choropleth Map) |
Save

LT

77

Atool for o

e Interpreting the Choropleth Map

Sfarch & practice

Geospatial Visualization (Choropleth Map)

from CSV file. C:

Header shows visualization type,
« data description, and creation date

Jun 14, 2012 | 05:33:37 PM EDT

Legend shows
how data matches
up with visual
representation

Legend

c:aumy Color (Logarithmic)

How to Read this Map

This choropleth map shows 209 countries of the workd usi meequm

proportion o a numerical value. Minamum and maximum ﬂata values
are given in the legend.
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== Proportional Symbol Map

Earch & practice

% | Proportional Symbol Map )

Maps geospatial coordinates as circ
color-coded in proportion to associ

Subtitle Generated from CSV file: C:\s
Map IWorld
R Help
i General i Latitude ILal.llude
: Tempoeal 2 Longitude [Longitude
Geospatial k| Proportional Symbol Map e -
Topical y Choropleth Map SuECRcle: By [T'm Sl
Networks » Geospatial Network Layout with Base Map Size Scaling |Logaﬁﬂ|mic

Right-click and Save map

Open this PostScript file to

Color Circle Exteriors By [None {uniform colering)

Exterior Color Scaling | Linear

Exterior ColorRange | White to Green

Color Circle Interiors By [None (no coloring)

Interior Color Scaling | Linear

Interior Color Range [\Nhite to Green

Data Man

4 CsVfile: C:\sci2\sampledata\geo\usptolnfluenza.csv

I Geospatial Visualization (Pro; rtional Symbol Map) |

visualize Save
View
79
2= Interpreting the Propottional Symbol Map
Geospatial Visualization (Proportional Symbol Map) Header shows visualization type,
Generated from CSV file: CsciZisampledatalgeciusp " T g
st brbopr - data description, and creation date
s
1 k
B £
< -
Legend shows how data How to Read this Map
. . Area (Loganthmic)  This mgm‘bwﬂmmeﬁ mmo;?;rld
matches up with visual TG Ol g:aqda cantsred ot its geolbocaon. The area, imeror calor, and
0 axternor color of each may represent numeric attribute values
representation @,“ Minimum and maamum data values are given in the legend
: 80
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Sci? Manual — Geospatial Workflows for
Scientometrics

For more information on creating geospatial visualizations, see Sci? Manual Section 5.2.4.1.
bttp:/ [ wiks.cns.an.edu/ display/ SCIZTUTORIAL/ 5. 2.4+ Mapping+Scientometries+% 28181+ Data% 29

@ & Edit 9P Add ~ £ Tools ~
5.2.4 Mapping Scientometrics (S| Data)

&9 Added by Ted Polley, 1ast edited by Ted Polley on Nov 11 (view change

5.2.4.1 Document Co-Citation

Scientometrics.isi

Time frame 1978-2008
Region(s) Miscellaneous
Topical Area(s) Scientometrics

Analysis Type(s): Document Co-Citation Network

Scientometrics is a discipline which uses statistical and computatiq
science. Here we use IS| data from the journal "Scientometrics” an
Awards Search

Download Scientometrics.isi. Load the file using 'File > Load and lgf =0 (Curk Austaicasile B o Ao
document co-citation analysis, as the scale is large enough that thq s =i eecau [ o —
similarity within the domain of scientometrics. el s

New 15l File Format a1

Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
> Sci? Tool Basics

> Sci? Tool — Advanced Topics

» Walkthrough: Visualizing temporal data for NSF projects
» Walkthrough: Locating data on a geographic map
» Walkthrough: Examining an evolving network

» Interacting with the statistical toolkit R and the network visualization
package Gephi

» Sci? tool visualizations
» Bipartite networks
» Map of Science

» Outlook and Q&A
> Adjourn
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Sci2 Demo II:

Evolving collaboration networks

Tendor Su Stonebraker Dantzich Thiel Dalel Heath
Chen
Adkan Larson Labow Fox
Paxson Wisnowvsky Landay Robbing Averboch
Spalding cy,, Munzner Wek
Hallerstein Crerwinski Hex
. France
Konstan ‘Woodnff Guimbretiers
Baldonado Ercegovec
Bamy Olston = Daline i Schulman
Kuchinsky s
Carkn Chi Gossweiler Foberson Ghayme Nowedl
Riedl - Hearst e
Mackinlsy Dish! Msintes - Tenasse
Shoop mnk
Ratzel Hahorsen Hatzler
Pedersen Tanev Whitney
Lewis Chang Palli Hawvre
Badro sl o Pithow Fiao
ing garas:
e Zelvmger Stefik i L
AT
Price Stasko Kraamar s O.‘ank.lns ¢ Senn
| Callshan
N Burks
tiukhenea o
" Jones Lucas
Brown  Harrold Waisar - Kalojachick
Botelogo Jonnsch Card Dunmie
iy Gomben
Enagan 4 Gershon Goldstein 9
‘Weiland
Ridin Shneiderman ek Chush Mafts Sofioling
° Bederson  'VaRenberg Jain -~ Hao e
Herrmann
Furnas Fose Wiliamson " Ketpadijiev
North o
Derthick
Zhani Plaisant Keim
9 Milash Ahlberg Seid! Schneidewind Hamison
Kriegel
Doan
Zacks Tanin Nodh  panse
Cam Beigel Wistrand Berchiold Moore
Ankerst
Legend Nede Color Code Edge Color Code
0.9 g " -
Nodes ~ Authors g o — Mapping the Evolution of
Nods cou = Raumbar of crabons .20 p— velo0 — Co-Authorship Networks
30-3% I 01 - Weimao Ke. Lalitha Visvanath & Katy Bomer
Edges ~ Co-authorship relations 4040 InfoVis Lab @ Indiana University
I
Edge color ~ Year of first co-authorship to. mmmmmmmm Displayed Year: 1988 2004

83
| Evolving Collaboration Networks
trics » isi - 6,

Name Date modified Type Size

[Il"m droVespig Fre ].l[s wHisld.isi

|| FourNetSciResearchers.isi | LaszloBarabasiisi

] StanleyWasserman.isi 4| TestSPapers.isi
As CSYV, file looks like:

A | B | c | b | E F G

_1 |Abstract Authors Authors (Full Names) 'Beginning Book Seri¢ Book Serie Cited Pate (
_2 |The systematic study of Colizza, V]Barrat, AlBarthelemy, M[Vespignani, A 2015
3 |Uncovering the hidden r¢Colizza, VIFlammini, AlSerrano, MA[Vespignani, A 110
_4 |Computer viruses can s|Vespignani, A 135
_5 |Mapping the Intemet geiDall'’Asta, L|Alvarez-Hamelin, l[Barrat, AlVazquez, AlVespignani, A 140 LECTURE NOTES IN

Visualize each time slice separately:

[ -

R e

19901991
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Relevant Sci? Manual Entry

Home £ Tools ~
1 iodicion @ 5.1.2 Time Slicing of Co-Authorship Networks (ISI Data)
# 2 Gefling Started @6 Added by Ted Polley, last adited by Scolt Weingart on Mar 18, 2011 (ew change
& 3 Agorithms, Toals,
and Pluging AlessandroVespgnan isi
@ 4 Workflow Desi
°" Time fame: 1990-200
= 5 Sample Woriflows
5 5.1 Indivickal Level Region(s) Indiana University, University of Rome. Yale University. Leiden University. Intemational Center for Thearetical Physics,
Studies - Micro University of Paris-Sud
8:1.1 Mapping Topical Areals) Informatics, Complex Network Science and System Research, Physics, Statistics, Epidemics
Collaboration,
Putlicaon. st Analysis Type(s Co-Authorship Network
Funding Profiles y b it
of One =
Researcher The Sci® Tool supports the analysis of evahing networks. For this study, load Alessandro Vespignani's publication history from IS1, which can be
(EndNate and downloaded from Thomson's Web of Science or loaded using ‘File > Load" and following thes path- ' o
NSF Data) AsiAlessandroVespgnant isfusing ' Slice the data into five year intenvals from 1990-2006 using Preprocessing > Temporal > Shee Table by Time' and the

5.1.2 Tim Shicing following parameters:
of C
Networks (51 |©

(S5 Sice Tabe by T [ESE=)
Data) 22 o

5.1.3 Funding | Slice a table into groups of rows by time.
Profiles of Three
Reseanchers al
Indiana University
(NSF Data)
5.1.4 Studying
Four Major NetSci )
Researchers 05! Stce Into Years.
Diata)
& 52 instution Leval How Many? s
Studies - Meso
# 53 Global Level
Studies - Matro
# 6 Sample Sclence
Studies & Online
Senices

@ 7 Edending the Sc2 ] s
Tool 1] Atign With Calendar

i :ﬂaTools Sbick< On Mlﬂ

EEEEEY

Date/Time Cohumn | Publcation Year -

Date/Time Format — yyyy

From Time 1990
To Time 2006

7] Cumulative?

=

Ll

9 References =

bitp:/ [ sci2.wiki.cns.in.edn/5.1.2+ Tz';ﬁe; S licing+of+Co-Authorship+Networks+ (IS1+Data)

]
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Slice Table by Time

"
% Slice Table by Time

Slice a table into groups of rows by time.

Date/Time Column | Publication Year v

Date/Time Format .ww

Slice Into Years "Slice Into” allows the user to slice the table by days, weeks, months, quarters, years, decades, and
centuries. There are two additional parameters for time slicing: cumulative and align with calendar. The

How Many? 5 former produces tables containing all data from the beginning to the end of each table's time interval, which
can be seen in the Data Manager and below:

Eoniine 150 =] g 101 Urnique ecords

| slice from beginning of 1990 to end of 2006 (101 records)
| slice from beginning of 1990 to end of 2001 (65 records)
| slice from beginning of 1990 to end of 1996 (26 records)
| slice from beginning of 1990 to end of 1991 (4 records)

To Time 2006
[¥] Cumulative?
[Z] Align With Calendar

The latter option aligns the output tables according to calendar intervals:
Week Starts On Sunday
=] 3
| slice from beginning of 2002 to end of 2006 (36 records)
+| slice from beginning of 1997 to end of 2001 (39 records)
|
S5

shice from beginning of 1992 to end of 1996 (22 records)
slice from beginning of 1990 to end of 1991 (4 records)

Choosing "Years™ under “Slice Into” creates multiple tables beginning from January 1% of the first year. If
“Months” is chosen, it will start from the first day of the earliest month in the chosen time interval,

bttp:/ [ sci2.wiki.cns.in.edu/ 5.1.2+ Time+S licing+of+ Co-Authorship+Networks+ (1S [+Data)
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Slice Table by Time

larch & practice

hitp:/ [ cishell.wiki.cns.in.edu/ Slice+ Table+by+ Time

‘:’C | S]-]( .[| Slice Table by Time £ Tools -

Description

Siice Table By Time is an algonthm to chop a table up into new tables, based on a date/time column. It takes the column with the dateftime data, a string
describing the format of that column, the intervals that the data should be sliced into, whether or not the slices are cumulative, whether or not the sices should be
aligned with the calendar, and what day the week is considered to start on (which only matters f the slices are aligned with the calendar] as paramaters

The column to use for date/time values should have a single value for each row of data. it is used by the algorithm to choose which shce{s) the row should end up
in. In order to what d: s by that row, you must prowide the algarithm with a descriptive format, in the second parameter. For instance,
a four digit year would be represented by yyyy (the default value). See hitp Viodat purceforge o DateTimeF grmat himi for
details of all the various formatting options.

The next dropdown has the available intenals to slice the table into. These include milliseconds, seconds, minutes, hours, days, weeks, fortnights. months,
quarters, years, decades. and centuries. A future version of the algorithm may include the ability to select how many of these intenals should be grouped together
&t once

The checkbox that follows determines i the slices will be cumulative. i the slices are not cumulative, every row in the onginal table is in one and only one resulting
slice. However, if the slices are cumulative, every row in the onginal table is in the slice it is for and every slice for a period after that

The checkbox that follows determines if the slices will be aligned with the calendar. For instance, if the first row is for June Tth, 2006 and yearly slices are chosen,
then the default bahavor will be to have the first slice be from June Tth, 2006 to June Gth, 2007 However, f the slices are abigned with the calendar, the first slice
will be from January 1st, 2006 to December 31st, 2006. Abgnment does not affect the output for intervals of fortnights, quarters, decades, or milliseconds

If the slices are aligned with the calendar and are weekly, then the day the week stans is used 1o determine how they are aligned

Pros & Cons

The output of the slice algonthm is in separate tables, so a longitudinal analysis will require working with each slice separately, which can be awkward. There will
likety be future versions of the time slice algonthm that annotate the ongnal table with the slice the rows belong to

Applications

When doing longitudinal analysis of data, it can be useful to consider it in chunks, such as to calculate how statistics have changed over time. Allematively, only a
particular time pariod might be of interest, and this algorithm can extract it from data for a larger time range

Implementation Details

This algonithm uses the Joda Time library extensively, which provides
times.

0 improved bl pared to the default Java algorithms for dates and
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o Visualize Each Network, Keep Node Positions

Sfarch & practice

To see the evolution of Vespignani's co-authorship network over time, check ‘cumulative’.

2. Extract co-authorship networks one at a time for each sliced time table using 'Data
Preparation > Extract Co-Author Network', making sure to select "ISI" from the pop-up
window during the extraction.

3. To view each of the Co-Authorship Networks over time using the same graph layout,
begin by clicking on longest slice network (the 'Extracted Co-Authorship Network' under slice
Sfrom beginning of 1990 to end of 2006 (101 records)’) in the data manager. Visualize it in
GUESS using 'Visualization > Networks > GUESS".

4. From here, run 'Layout > GEM followed by 'Layout > Bin Pack'. Run 'Script > Run Script
... and select ' yoursci2directory/ scripts/ GUESS / co-anthor-nw.py'.

5. In order to save the x, y coordinates of each node and to apply them to the other time
slices in GUESS, select 'File > Export Node Positions' and save the result as
"yoursci2directory/ NodePositions.csv'. Load the remaining three networks in GUESS using the
steps described above and for each network visualization, run "File > Import Node Positions'
and open "yoursci2directory/ NodePositions.csv'.

0. To match the resulting networks stylistically with the original visualization, run "Serips >
Run Secript ..." and select "yoursci2directory/ scripts/ GUESS / co-author-nw.py', followed by 'Layout >
Bin Pack', for each.

bttp:/ [ sci2.wiki.cns.in.edu/ 5.1.2+ Time+S licing+of+ Co-Authorship+Networks+ (1S [+Data)
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1990-2001 1950-2006

bttp:/ [ sci2.wiki.cns.in.edn/ 5.1.2+ Time+ Slicing+of+ Co-Authorship+Networks+(1S1+Data)
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
> Sci? Tool Basics

> Sci? Tool — Advanced Topics
» Walkthrough: Visualizing temporal data for NSF projects
» Walkthrough: Locating data on a geographic map
» Walkthrough: Examining an evolving network

» Interacting with the statistical toolkit R and the network visualization
package Gephi
» Sci? tool visualizations
» Bipartite networks
» Map of Science

» Outlook and Q&A
> Adjourn
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- - - - -

% Sci2 Tool

| File DataPreparation Preprocessing Anahysis Modeling Visualization (R Help

. nsole Create an R Instance -]
R-Brldge B Consol :

.......... Send tableto R
(GUESS was selected.

Author{s): Eytan Adar

Implementer(s): Eytan Adar (GUESS), Russell Duhon (resizelinear, colorize fio)
Integrator(sk: Russell Duhon

» Run ‘R > Create an R Instance’ . You must set the ‘R Executable
Directory’ parameter to be the path to the directory on your
computer that contains Rgui.exe. Results in an ‘R Instance’
object in the Data Manager.

» To send a table from the data manager to an R Instance object,
select the table and the R Instance object together then run R >
Send Table to R’. Select ‘R > Run Roui’ and the table is available in
the R environment using the variable name you specified as a
parameter to the Import algorithm.

> To pull back data from an R Instance object to the Data
Manager, select the R Instance object and run R > Get Table
From R’. Choose the name of the variable from the dropdown

list.
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& Aol tor

ool Seience. | Gephi Bridge

» Gephi must already be installed on the system for this bridge
plugin to work.

» Select any network file, then choose Visualization > Networks >
Gephi

» The selected network file will be opened in Gephi using the

Import report
t?;Sc'lZTool _' - _- ) ____ e - . - —— -
File DataPreparation Preprocessing Analysis Modeling ! Visualization | R Help
2 Console General v | ¥ Data Manager
Temporal » =z -
GUESS was selected. .
I
Author(s): Eytan Adar Gm.spatla i
Implementer(s): Eytan Adar (GUESS), Russell Duhen (resizelinea Topical r
Integrator(s): Russell Duhon Network . GUESS
Reference: Adar, Eytan, "GUESS: A Language and Interface for Gi ,_,._”__ -
(http://graphexploration.cond.org/) Gephi
Documentation: http://wiki.cns.iv.edu/display/CISHELL/GUESS
ECHO is off. Radial Tree/Graph (prefuse alpha)
Startina GUESS... Daclind Tran/Zemek suibh Ammetabine fronforn b
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
» Sci? Tool Basics

> Sci? Tool — Advanced Topics
» Walkthrough: Visualizing temporal data for NSF projects
» Walkthrough: Locating data on a geographic map
» Walkthrough: Examining an evolving network
> Interacting with the statistical toolkit R and the network visualization
package Gephi
» Sci? tool visualizations
> Bipartite networks
» Map of Science

» Outlook and Q&A
» Adjourn
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Map+of+Science+viatJournals

Topical Visualization
)k o 13 ol e, e e o 143 bty s 1] b

» 'The Map of Science is a visual ;
representation of 554 sub- ?
disciplines within 13 disciplines
of science and their
relationships to one another

» A set of journals can be overlaid o e
: : e et e\ i oLl et B
onto this base map, showing the =y ()

areas of science encompassed
» FEach circle size represents the .

Dt o 157 i e ] 1 st 11 S
13, T |63 A PRI

(weighted) proportion of the :
journal set mapped to that sub- il
discipline
» Detailed breakdown of each
discipline

mEarth Sclences.
N CuERENT SoEME
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Bipartite Network Graph
bitp:/ [ wiki.cns.in.edn/ display/ CISHEIL 1./ Bipartite+Network+Graph

» A bipartite network
graph can be visualized s

ke 11, 2012 | 1136 40 EDT

using this plugin. - s ooy

» Supports edge and node
weights

» Node ordering can be
sorted independently

Legend How To Read This Map

Sortezy Ean

o L)
W v, Pondort o maT Ty dew vorbehy Wt 40 vt .. by

e — -

O o e
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Tutorial Overview

» Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools
» Sci? Tool Basics

» Sci? Tool — Advanced Topics

» Outlook and Q&A

» Adjourn

96




Computational Scientometrics
Cyberinfrastructures

T Scholarly Database: 25 million scholarly records
% http://sdb.slis.indiana.edu

g’“ w%% VIVO Research Networking
& .
e http://vivoweb.org

+

: & Information Visualization Cyberinfrastructure
o d

wex- http:/ /iv.cns.iu.edu

A,

@1 Network Workbench Tool & Community Wiki
4 http://nwb.cns.iu.edu

. {r Science of Science (Sci?) Tool

¥ http:/ /sci2.cns.ju.edu

Epidemics Tool & Marketplace
*es* Forthcoming

g o ClShel!

Alliance
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SD& SCROIRIg IR Scholarly Database at Indiana University
bitp:/ [ sdb.wiki.cns.in.edn

Supports federated search of 25 million publication, patent, grant records.
Results can be downloaded as data dump and (evolving) co-author, paper-citation networks.

PR S 2 |SCHOLARLY DATABASE

Cytrenmirastsucsuse for Hetwurk Boence Conter, SU3 Induns Uraveimty, Bloceungiun
b far Center, SLIS, Indiana Univernity, Bloomington

y T A AAREES

Search | Edit Profile | Admin | About | Logout

U User Non-IU User
I ruiple tarrna are artared in s fald, they are
Eageepen Search automatically combinad using ‘OR’, G0, "breast
cancer’ matchas any record with ‘bresst’ or "cancer’ in
p— creators: | b
 Loon ] You can put AND Betrann combine vith
Title: CANDS Thiss “braait AMD ¢ auld enly match

Abstract: [ANA rocnds 2 ol b
Fullvewts [
First ear: [1898 =]
Last vear: [2000 =]

Couble quotstion can be ured to match compound
tarn rutrievas recoads with

cormasnd to matching the te

= Db T ,
|, SevooL oF Liasany @
- AN [HFORMATICN SCIEHCE b

Register for free access at http://sdb.cns.iu.edu




cholarly Database :: Results - Mozilla Firefox

Fle [Edt View Higtory Bookmarks Tools Help

W‘ C' 30 o) | L] | htpisssdb.sis.indiana.edufsearchiresuksrq=("artiicial inteligence”) 17 = '|marknv:kbmid1

F

2] Most Visted @ Getting Started . Latest Headines | | Hotel Kenigshof - Bod...

ﬂe'
|

R

A &

SCHOLARLY DATABASE]

Cyberinfrastructure for Network Science Center, SLIS, Indi

ity, Bl

gton
( |
Search ‘ Edit Profile ‘ Admin | About ‘ Logout |
Browse Results
Your search returned 13,231 results in 0.295 seconds. [/ i. '
Total results per database: NIH: 2,103, Medline: 10,235, USPTO: 279, NSF: 614,
Results 1 through 20,
Next>>
-, Authors/Creators Year Title Score (out of
5.71)
Medline LaCombe 1987 Artificial intelligence. L. e §
Medline 1989 Artificial i i @: expert sysh 5.71
Medline Schritt 1990 [Artificial intelligence in dentistry ] 5.71
Medline ::::::::: and 2002 Artificial-intelligence- ted sy 5.60
Medline Touretzky 1980 Artificial intelligence. 4.86
Medline Goldenberg 1980 Artificial intelligence. 4.86
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arly Database = Download - Mozilla Firefox

e Edt Wew Hatory Tock Heb

2l

inckana. s

artiicial AN U7 E,]-|mmm )

O - c x . [OTwres

L&) Most visted P Gettng Started .

SCHO

Download Results

T selast all downloads,

Medline Database: =

7 madiine MasH hasding table
T Madline MasH qualifier table
™ madiine auther table L2

™ Madiine co-auther ¢
7 Mediine master table L2

o]
o (rwb format) B

LA

Cyberinfrastructure for Network Science Center, SLIS, Indiana University, Bloomingion

r T T
Search | EditProfie | Admin | About | Logout

Download |2Ell301] records starting st record |1 from the folloving databases:

RLY DATABASE]

Download automatically
extracted networks:
Co-author
Co-investigator
Co-inventor
Patent-citation

‘Fle Edt Vew Favortes Took Hebp

Download tables suitable for
burst analysis

Qe - O - \F| [ soweh | s | (-

Addvess | 3 D:\sampledatalscentometricsisdb

2 ame
X [ e e o
'— HIH m"“r‘.bl.g e e
File and Folder Tasks 2 I suthor,toblecsy | 2958
NEE Databias - S Medine_co-suthor_table_(rwb_format).csv 627 KB
29 Make 8 new folder EJMedine_master_table.csv 13,986...
T KSF coninvastigatar tablaovb format) [T ) Publsh this folder tothe EMedine_MesH_headng table.csv 3,453 KB
T WeF master table Web SJMedine_MesH_qusiier_table.csv 8538
USPTO Database: | BN raster_tatle cov Sime
= - Other Places i BENsF _co-nvestigator_table_(mwb_format).csv 19KB
USPTO Patant Cooparation Trasty table [0 SNsF _master_table.csv 1,303 K8
T usPTO agent table 2 scientometrics Eusp1o_ co-nventor_table _(rwb_Format).csv 18KB
T useTo assignas table T &) My Documents EJUSPTO_sgent_table.csv 20k8
I useTo citation table tnw format) 1 & My Network Places H)UsPT0_sssignee_table.csv Z3KB
™ uspTo daims table B2 S useTO_chation_table_(rwb_format).csv 7248
T USPTO corinvantor table (nwb format) [T Euse1o_nventor_table.csv 63K
T UsPTO inventor table [ Details 2 gmo:m_r_buﬂm).:w 308 KB
T useTo mactar (burst format) 0 sdb E)UsPTo_master_table.csv kB
I usPTO master table (0 Fie Folder — EJuseto_patent_Cooperation_Treaty_table.csv 2KB
Date Modfied: Today, Apel
_Downioad | 08, 2009, 1:28PM ~14] | ey
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Enabling a National
Network of Scientists

VIVO: A Semantic Approach to Creating a National Network
of Researchers (http://vivoweb.orqg)

» Semantic web application and ontology
editor originally developed at Cornell U.

* Integrates research and scholarship info
from systems of record across
institution(s). e

« Facilitates research discovery and cross- e ——
disciplinary collaboration.

« Simplify reporting tasks, e.g., generate > T et
biosketch, department report. - - e

Pacumy ant et

Funded by $12 million NIH award.

Cornell University: Dean Krafft (Cornell PI), Manolo Bevia, Jim Blake, Nick Cappadona, Brian Caruso, Jon Corson-Rikert, Elly Cramer, Medha Devare,
John Fereira, Brian Lowe, Stella Mitchell, Holly Mistlebauer, Anup Sawant, Christopher Westling, Rebecca Younes. University of Florida: Mike Conlon
(VIVO and UF PI), Cecilia Botero, Kerry Britt, Erin Brooks, Amy Buhler, Ellie Bushhousen, Chris Case, Valrie Davis, Nita Ferree, Chris Haines, Rae Jesano,
Margeaux Johnson, Sara Kreinest, Yang Li, Paula Markes, Sara Russell Gonzalez, Alexander Rockwell, Nancy Schaefer, Michele R. Tennant, George Hack,
Chris Barnes, Narayan Raum, Brenda Stevens, Alicia Turner, Stephen Williams. Indiana University: Katy Borner (IU PI), William Barnett, Shanshan Chen,
Ying Ding, Russell Duhon, Jon Dunn, Micah Linnemeier, Nianli Ma, Robert McDonald, Barbara Ann O'Leary, Mark Price, Yuyin Sun, Alan Walsh, Brian
Wheeler, Angela Zoss. Ponce School of Medicine: Richard Noel (Ponce PI), Ricardo Espada, Damaris Torres. The Scripps Research Institute: Gerald
Joyce (Scripps P1), Greg Dunlap, Catherine Dunn, Brant Kelley, Paula King, Angela Murrell, Barbara Noble, Cary Thomas, Michaeleen

Trimarchi. Washington University, St. Louis: Rakesh Nagarajan (WUSTL PI), Kristi L. Holmes, Sunita B. Koul, Leslie D. McIntosh. Weill Cornell
Medical College: Curtis Cole (Weill PI), Paul Albert, Victor Brodsky, Adam Cheriff, Oscar Cruz, Dan Dickinson, Chris Huang, Itay Klaz, Peter Michelini,
Grace Migliorisi, John Ruffing, Jason Specland, Tru Tran, Jesse Turner, Vinay Varughese.
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University of Florida

mparing Grants of Organizations in Univer
) 5 g Enabling a National

Network of Scientists

t to compare?

Records 1-10 of 30

Entity Label Entity Type

UF Dapa
epartment

Florda Museum
of Natural Hists

1, UF College, College

Agent, Conter

nternational
C r Hon-Ac
Depariment

Florida Sea Grant 4 UF Cent

Log in

Research

Chemistry

1-1301554

Math and F

Sub-Disciplines #ol %
pubs. activity




Conlon, Mike

Associate Director and Chief Operating Officer

Co-Author Network (GraphML File

This may cnly be & smal

person's total work

Interact

Hover over a

Retresh

Sort alphabetica

Enabling a National
Network of Scientists

1Y FArT

point publication

Mike

—

Network Analysis (With Whom?) Who is co-authoring, co-investigating, co-inventing

with whom? What teams are most productive in what projects?
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National Researcher Networking
Visualization 1.0

Briis
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w
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idaho Wyoming a o |
lowa A,
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] o 0
Iinois Ohio
s Nevada A L] m'q‘l.‘m
; ta Colorado Y W - West
Kansas 1
k = MISSD‘-_;‘ Virginia
salifornia Hauhucky virg
o
Tennessee North
o o Oklahoma Arkansas Carolina
Arizona
o New
o Mexico Mississippl s }?mha
M - @ Alabama W
o . Q. Texas . peTi
- @
e an.
N v'h o Louisiana
L] o P —_
Gulf oI’ R
Caldomia e
o o Gultof,
gin O o8 0N Sr

o México o

Uap data €2011 Europa Technologies, Geocentre Consuling, NEGL MapLink, Tele Atias -

Québec

o

o F

X
Maryland

District of
Columbia

+|J
% New

I Maine

Rhode Island

Connecticut

New Jersey,
Delaware

& cyberinfrastructure for
Seey NETWORK SCIENCE CENTER
. cns.iu.edu

P Data Types
Check in the boxes next to the data
types you'd like to see displayed on the

map.

~
7>

2))

<
& ™ O People

M [ Publications
B < Patents

M /\ Funding

M O Courses

Brunsw_%
{ | Nova
| Scotia

Vermont
New Hampshird
Massachusetts

System Types
Elsevier SciVal Experts

Stanford CAP

Timeline

North
Atlantic
Ocean

Jun, 2011
Jun, 2011
>

Jun, 2011

I =
Play Pause Stop

Terms of U

Geospatial Analysis (Where) Where is what science performed by whom? Science is
global and needs to be studied globally.
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Borner, Katy
Download Data

General Statistics Enabling a National
e Network of Scientists

c«amn;nmt — | General Statistics
S * 30 publication(s) from 2001 to 2010

¢ 80 co-author(s) from 2001 to 2010

Co-Author Network

Save as Image (PNG file)

Tables
* Publications per year

Tables

Yom

Co-authors

36 publication(s) from 2001 to 2010 o
Enabling a National
Network of Scientists

80 co-author(s) from 2001 to 2010

Year Count Co-Author(s)

2001 1 Chen C

2002 3 Chen C.; McMahon T., Feng Y
2003 2/Chen C.; Boyack KW

2004 17 Sengupta A ; Penumarthy S.; Thakur S.; Sooriamurthi R.; Maru J.T.; Shiffrin R.M.; Mane I; Moor KA ;

-0 WNNN N

Co-author network

<xml version="1.0" encoding="UT ">
<graphml xmlns="http://graphml.graphdrawing.org/xmlns"

xmlns:xsi="http: //vwv.v3. org/2001 /ALSchema-instance”

%xsi:achemalocation="http: //graphml, graphdraving, org/xnlns

htep: //graphml . graphdrawving. org/xmlns/l.0/graphml . x3d">
<key id="label" for="node” attr.name="label” attr.type="string” />
<key id="number of authored works" for="node" attr.name="number of_ suthored works" attr.type="int" />
<key ids"num unknowm _publication” for="node” attr.name="num unknowm _publication” attr.types="int” />
<key id="num_latest publication” for="node"” attr.name="num latest publication” attr.types="int" />
<key id="latest_publication” for="node” attr.name="latest publication” attr.type="int" />
<key id="profile url"” for="node"” attr.name="profile url"” attr.type="string” />

'
2
3
4
5
6
7
8
vl
o
15

=

Save as Image (.PNG file)
Publications per year , see top file.

Co-authors Count
i 1

Ben-Miled Z
Blackwell A
Boyack K'W.
Bozicevic M
Brodbeck D.
Burkhard R.A
Chen C




w = B3] 1111 Data Manager =a

Welcol g visualization of epidemic processes. -~
Thebpi] &~ — T — e NIH RM-07-004 award. The
prima File | Compartmental g Simulation § o; jim Sh
Create a compartmental model
The Epi £ B hintan Tank, Joseph Biberstine,
Chin HAl [wel Edit compartmental model ng, a

| EpiC uses the Cybmfrastructure Shell (httpa"fdslwl.org) loped at the Cyberinfi ture for

Network Science Center (http ;
| Visualizati R
Please cite as follows: - = nee
| EpiC Team. (2009). EpiC Tool. Indiana Univ Single-Population
Exact on of
Network e i
| 2 Scheduler|

[Visualization | R Help

Line Graph

Remove From List | IR pleted ically 1" all cor

! Algorithm Name Date Time

Create an R Instance
Run Rgui

Import Table Into R

Export Table From R

@ RO centen @CISIN lleered
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Compu{—*Impact o Air Travel on Global Spread of Infectious DISGGSBS‘—

FOI‘CCElSt (hmo:m:f:gl::::m
development of modern
trarspartalion syibems.
Epideniic
Binlooie, 33
Reaction-d. .".,:"
A Vespigne
\lodel *Forecasts or THe Next Pandemic Influenza
ot f’-{.n’-'-'fc:f;'.a’-" Seasonale Feremts s bt mxmdmhh a ! ﬂ?f.'f’.f',ﬂ':'.am"a&":u The b ey e -+ Reproductive
: f—.‘::zghﬂmn 3 m:&hxmmmmuum b b . Mumber{Ro}

Case and C for e ol of ¥

Hanai (Vieinam) in the Spring

PloS-Medic W

Geographical «

4

mis B mie §1 | meas £
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e W . Pes e e W3, et s il g
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TEXTREND

rch and Techno Jedlik gramme

TEXTREND: Development of a business and governmental decision support analyss
toolbox using trend- and text-analysis tools S dowriond dec
The two interconnected objectives of the TEXTrend project are (1) the creation of leader .« network phd
an integrated TEXTrend toolkit and service basis, and (2) the elaboration of research sclence
demonstrative applications in varied fields of business and govermnmental i Ilegm m”tf‘_"_e“_d
) <ermplif _ toolkit trend . ur ervonwet |
University Press Ltd. decisions, exemplified by use cases P .
Team leader: George Kampis, PhD, DSc - = http:fkagcmwd.wrn
Gydirgy Fabri, PhD, CSc
;<216 Gulyas, Ph
Sandor Sods, PhD & s
Zalan Szakolezi, BSc e, s n
Zoltan Szaszi, BSc T i Ta E s
g AP0 = R ¢
| s B
HCCI Research Institute of Economics npdpet. B
and Enterprises iy AR
Team leader: [stvdn Jdnos Toth, PhD —
lbanes Czibik, MSc Created by

lagnes Makd, MSc www.wordle.net
Tamas Uhnn, M

Zoltan Varhalmi, MS¢

Glia Computer Consulting Ltd.
Team leader: Attila Bencsik, MSc
Rita Adam, MSc

Henr 1

Istvan Graf, MSc

TEXTrend adds WEKA, Wordij, CFinder, and more.

See the latest versions of TEXTrend Toolkit modules at
bttp:/ [ textrend.org/ index.php2option=com _content>view=articled>id=47 & ltenid=53
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A Tool for Science of Science Research & Practice
Home Download Documentation Ask AnExpert Testimonials Developers

Ask An Expert

(if you need to report a bug for the Sci” tool instead, click here )

Project Title | Pick any name to help us to refer to this
projectiguestion in the future.
Types of Analyses oy o . 4
g E! Temporal (When) © View sample questions
™ Geospatial (Where) @ HERE.
™ Topical (what) @ . o
™' Modeling (Why) © (Will open in new tab.)
™ Networks (With Whom?) ©
Levels of Analy T i (1-100 records) @

™ MesoiLocal (101-10,000 records) @
™ Macro/Global (> 10,000 records) ©

Intended Users Whe is the intended audience?

Who is interested in the resull?

understand?

Insight Needed | What would youluser like fo

https://sci2.cns.iu.edu/user/ask.php
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Tutorial Overview

Plug-and-Play Macroscopes, OSGi/CIShell Powered Tools

Sci? Tool Basics
» Download and run the Sci? Tool
» Walkthrough: Load, analyze, and visualize a network
» Walkthrough: Analyzing the publications of four prominent network science researchers
» Load and clean a dataset; extract networks from raw data
» Calculate basic statistics and analyses of the network
» Visualize the results
Sci? Tool — Advanced Topics
Walkthrough: Visualizing temporal data for NSF projects
Walkthrough: Locating data on a geographic map
Walkthrough: Examining an evolving network
Interacting with the statistical toolkit R and the network visualization package Gephi

VVVYVYV

Sci? tool visualizations
» Bipartite networks
» Map of Science

Outlook and Q&A
Adjourn
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Thank youl

istructure for

cyberinfrastructure :
NETWORK SCIENCE CENTER

Please complete the Post-Tutorial Questionnaire
so that we can further improve these tutorials.

% %k ¥k

Bug reports and all comments are welcome.




cyberinfrastructure for
ETWORK SCIENCE CENTER

XX

All papers, maps, tools, talks, press are linked from http://cns.iu.edu

CNS Facebook: http://www.facebook.com/cnscenter

Mapping Science Exhibit Facebook: http://www.facebook.com/mappingscience




