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» 'These slides
http://sci2.cns.iu.edu/docs/2011-borner-1SSI-Tutorial.pdf

» Sci2 Tool Manual v0.5.1 Alpha
http://sci2.wiki.cns.iu.edu

» Sci2 Tool v0.5.1 Alpha (May 4, 2011)

http://sci2.cns.iu.edu
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» Additional Datasets
http://sci2.wiki.cns.iu.edu/2.5+Sample+Datasets
» Additional Plugins

NWE Tool 1.0
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Or copy them from the DVD or memory stick.




O Workshop Overview

1:30 Macroscope Design and Usage & CIShell Powered Tools: NWB &
Sci2

1:45 Sci2 Tool Basics

» Download and run the tool.

2:00 Sci2 Sample Workflow: Padgett's Florentine Families - Prepare, load,
analyze, and visualize family and business networks from 15th century
Florence.

2:30 Sci2 Sample Workflow: Studying Four Major NetSci Researchers.

» Load and clean a dataset as text file; process raw data into networks.

» Find basic statistics and run various algorithms over the network.

»  Visualize as either a circular hierarchy or network

3:30 Break

4:00 Sci2 Demo I: Geospatial maps with congressional districts

4:30 Sci2 Demo II: Evolving collaboration networks

4:45 Outlook and Discussion

5:00 Adjourn
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Different datasets/formats.
Diverse algorithms/tools written in
many programming languages.

The Changing Scientific Landscape

Star Scientist -> Research Teams: In former times, science was driven by key scientists.
Today, science is driven by effectively collaborating co-author teams often comprising
expertise from multiple disciplines and several geospatial locations (Borner, Dall'Asta,
Ke, & Vespignani, 2005; Shneiderman, 2008).

Users -> Contributors: Web 2.0 technologies empower anybody to contribute to
Wikipedia or to exchange images and videos via Fickr and YouTube. WikiSpecies,
WikiProfessionals, or WikiProteins combine wiki and semantic technology in support
of real time community annotation of scientific datasets (Mons et al., 2008).

Cross-disciplinary: The best tools frequently borrow and synergistically combine
methods and techniques from different disciplines of science and empower
interdisciplinary and/or international teams of researchers, practitioners, or educators
to fine-tune and interpret results collectively.

One Specimen -> Data Streams: Microscopes and telescopes were originally used to
study one specimen at a time. Today, many researchers must make sense of massive
streams of multiple types of data with different formats, dynamics, and origin.

Static Instrument -> Evolving Cyberinfrastructure (CI): The importance of hardware
instruments that are rather static and expensive decreases relative to software
infrastructures that are highly flexible and continuously evolving according to the
needs of different sciences. Some of the most successtul services and tools are
decentralized increasing scalability and fault tolerance.
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Macroscope Design

Custom Tools for Different Scientific Communities
Information Visualization Cyberinfrastructure
http://iv.cns.iu.edu

Network Workbench Tool + Community Wiki

http://nwb.cns.iu.edu
Science of Science (Sci?) Tool and Portal
http://sci2.cns.iu.edu
Epidemics Cyberinfrastructure
Coming soon

180+ Algorithm Plugins and Branded GUIs
+

Core Architecture

Open Services Gateway Initiative (OSGi) Framework.
http://orgi.org
Cyberinfrastructure Shell (CIShell)
http://cishell.org
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CIShell Powered Tools:
Network Workbench (NWB)




Downloads for NWB Tool Releases

Network Workbench Tool

The Network Workbench (NWB) tool
supports tesearchers, educators, and
practitioners interested in the study of
biomedical, social and behavioral science,
physics, and other networks.

In February 2009, the tool provides more 169
plugins that support the preprocessing,
analysis, modeling, and visualization of

networks.

More than 50 of these plugins can be
applied or were specifically designed for

S&T studies.

It has been downloaded more than 65,000
times since December 20006.

LELTS People Research Publications

Summary
Network Workbenc
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evaluate, and o) unigue distributed,
scale network analysis, modeling, and visual
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* 32300100 beta 5 Released

« 1.23.09 Ann Mcranie's fulorial abstract for 5
008

2008 Mapping the F
h & Croative Activly, 3
M08

4
http://nwb.slis.indiana.edu il
Cumulative Total of Downloads [~
o 89,559

+ 11.4.08 Two NWE Pis featured in “Conneclod—TTe
Poyer of Six Degrees.” 2008. Anna Maria Talas,
Director. Australian Broadcasting Cofporation, Lid
[¥ouTube] Full Video (30088

Getting Stared

See more gocumentation

Getinvolved

Herr 11, Bruce W., Huang, Weixia (Bonnie), Penumarthy, Shashikant & Borner, Katy. (2007). Designing Highly Flexible and Usable
Cyberinfrastructures for Convergence. In Bainbridge, William S. & Roco, Mihail C. (Eds.), Progress in Convergence - Technologies for Human

Wellbeing (Vol. 1093, pp. 161-179), Annals of the New York Academy of Sciences, Boston, M.A.

Investigators:

Software Team:

Goal:

Amount:
Duration:
Website:

Katy Bérner, Albert-Laszlo Barabasi, Santiago Schnell,
Alessandro Vespignani & Stanley Wasserman, Eric Wernert

Lead: Micah Linnemeier
Members: Patrick Phillips, Russell Duhon, Tim Kelley & Ann McCranie

Previous Developers: Weixia (Bonnie) Huang, Bruce Herr, Heng Zhang,
Duygu Balcan, Bryan Hook, Ben Markines, Santo Fortunato, Felix
@rkhrn, Ramya Sabbineni, Vivek S. Thakre & Cesar Hidalg

Develop a large-scale network analysis, modeling and visualization toolkit
for physics, biomedical, and social science research.

$1,120,926, NSF 115-0513650 award
Sept. 2005 - Aug. 2009

http://nwb.slis.indiana.edu
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m Project Details (cont.)

NWB Advisory Board:

James Hendler (Semantic Web) http://www.cs.umd.edu/~hendler

Jason Leigh (CI) http://www.evl.uic.edu/spiff,

Neo Martinez (Biology) http://online.sfsu.edu/~webhead

Michael Macy, Cornell University (Sociology) http://www.soc.cornell.edu/facultv/macy.shtml

Ultik Brandes (Graph Theoty) http://www.inf.uni-konstanz.de/~brandes

Mark Gerstein, Yale University (Bioinformatics) http://bioinfo.mbb.vale.edu
Stephen North (AT&T) http:

Tom Snijders, University of Groningen http://stat.camma.rug.nl/snijders

Noshir Contractor, Northwestern University http://www.spcomm.uiuc.edu/nosh
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Computational Proteomics
What relationships exist between protein targets of all drugs and all
disease-gene products in the human protein—protein interaction network?
o
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Figure 2 Drug-target network (DT network). The DT network is generated by using the known associations between FDA-approved drugs and their target
proteins. Circles and rectangles correspond to drugs and target proteins, respectively. A link is placed between a drug node and a target node if the protein
s a known target of that drug. The area of the drug (protein) node is proportional to the number of targets that the drug has (the number of drugs targeting
the protein). Color codes ame given in the legend. Drug nodes (circles) are colored according to their ical Th Chemical Classification, and the
target proteins (rectangular boxes) are colored according to their cellular component obtained from the Gene Ontology database,
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Fig. 1. The product space. (A} Hierarchically clustered proodmity (4) matrix  with their prodmity value. The sizs of the nodes are proportional to world
representing the 775 SITC-4 product classes exported in the 19982000  trade, and their colors are chosen fing to the classifs introduced by
period. (B) Network representation of the product space. Links are color coded  Leamer. 13
Second sight
Computational Social Science e
Studying large scale social Power struggle
networks such as Wikipedia How doyoukeep ok o thebubtng
marss of information that s Wikipedia?
This chaotic-looking masaic i one

attempt to show which lopics ae

Second Sight: An Emergent Mosaic of
Wikipedian Activity,
The NewScientist, May 19, 2007

network dynamics, coinciding with this
week's Inteinational Workshop and

| Conbesence on Network Science

{ In Bloomington.




Computational Epidemics
Forecasting (and preventing the effects of) the next pandemic.

Epidemic Modeling in Complex: realities, V. Colizza, A. Barrat, M. Barthelemy, A.V espignani, Conptes Rendus
Biologie, 330, 364-374 (2007).

Reaction-diffusion processes and metapopulation models in heterogeneous networks, V.Colizza, R. Pastor-Satorras,
A.Vespignani, Nature Physics 3, 276-282 (2007).

Modeling the Worldwide Spread —elmpact or Air Travel on Global Spread or Infectious Diseasese—

of Pandenzic Influenza: Baseline

Case and Containment Interventions,

V. Colizza, A. Barrat, M. Bartheleny,
A.-. Valleron, A.V espignani,
PloS-Medicine 4, €13, 95-110 (2007).
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NWB Tool 1.0.0 T |

Can be freely downloaded for all reone | B i &ttt )
major operating systems from LT T o LR 2L BRI

http://nwb.cns.iu.edu

Select your operating system from
the pull down menu and download.

Unpack into a /awb directory.

Run /nwb/nwb.exe ek B o e

NWB —datis Tt

Tool 1.0.0 Official Release
September 15m, 2000

Release Notes

Session log files are stored in _
*yournwbdirectory*/ logs’ directory. [ESICEAEN oo\ 000 |

326 Lux [ e |
Bd-bt Limax

intel Mac OSX
GIG4/GS5 Mac 05X

Cite as i

Demo
Oct 1310, 2000

NWB Team. (2006). Network P—
Workbench Tool. Indiana University,

Northeastern University, and University of
Michigan, bitp:/ [ nwb.cns.in.edn. ‘

Windows (P & Vista) ¥
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M NWB Tool Interface Components

% Network Work

bench Tool

File Preprocessing

of small, n

115-0513650 award.

Please cite as follows

'ECusnla —
Welcome to the Netwa
visualization

I The Network Workben

sy %
L'} y WisL S

Console displays data operations
(save, load, view, etc.) and
algorithm input parometers,
selection, & ocknowledgements as
well as error reporfing.

Help

=0

| 149 Data Manager

preprocessing, modeling, analysis, and

ks supported in part by the NSF
, Dr. Albert-Laszld Barabasi, Dr. Santiago

Schnell, Dr. Alessandro Vespignani, Dr. Staﬂeywassermm,ardnt Eric A, Wernert.

The NWE tool was developed by Weixia Huang, Russell Duhon, Micah Linnemeier, ‘rl'nothy Kelley, wa
|Balcan, Mariano Beird, Bruce Herr, Santo Fortunato, Ben l-'Barknes Felix Terkhorn, Heng Zhang

-Runm César Hidalgo, Ramya Sabbineni, Vivek Thdwos, Soma Sanyal, Ann McCranie, Alessmd

Vesp i, and Katy Borner, It uses the Cyberinfrastructure Shell (http://cishell.org) develuped at the
Cytmt\fraﬂructue For Network Science Center (http://cns.slis.indiana.edu) at Indiana University.

'thB Team. (2006). Netmk ‘wiorkbench Tool. Indiana University and Northeastern University,
http / fnwb.slis.indiana.edu

-

Data Manager keeps track of
all datasets that are available
for algorithmic visvalization
or manipulation.

Els:hmu-—

used and displays algorithm
rogress
3Rt

Scheduler lists what algorithms you've

Time % Complete

% Network-

Console shows references to seminal works.
Workflows are recorded into a log file, and soon can be re-run for easy replication.
All algorithms are documented online; workflows are given in tutorials.

m File, Preprocessing, Modeling, and Visualization Menus

Load... Extract Top Nodes Random Graph GUESS
Load and Clean 151 File Extract Nodes Above or Below Yalue Watts-Strogatz Small World SR
Read Drsctory Hearchy Remove Node Attributes Barabssi-Albert Scale-Free Elizh
Datasets Delete High Degree Nodes = DrL (VxOrd)
Delete Random Nodes Speciied (prefuse beta)
Save... Delete Isolat Chord
e Hyperarid Circular (JUNG)
Extract Top Ei PRU
View with... ExtrﬁEopl l*JH“ e ] Radial Tree/Graph (prefuse alpha)
TARL RacIdT W\
Merge Node and Edge Files Remove Edge Attributes ree/Graph mmum(pmhnua;
Split Graph to Node and Edge Files|  Remove Self Loops Discreta Netw
Tests bl Q (Weig Balloon Graph (prefuse alpha)
Preferences Node Samgls o Force Directed with Annotation (prefuse beta)
Sampling Kamada-Kawai {JUNG)
Bk e Fruchterman-Reingold (JUNG)
Fruchterman-Reingold with Annotation (prefuse beta)
Spring (JUNG)
Small World (prefuse alpha)
Parall ordiniates (demo)
LaNet
Circular Hierarchy

Borner, Katy, Sanyal, Soma and Vespignani, Alessandro (2007). Network Science. In Blaise Cronin (Ed.),

ARIST, Information Today, Inc./American Society for Information Science and Technology, Medford, NJ,
Volume 41, Chapter 12,

ivl.slis.indiana.edu/km

pp. 537-607.

ub/2007-borner-arist.pdf
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A8 aikhanghy Analysis Menu and Submenus

Unweighted and Directed

Indegree Distribution
Outdegree Distribution

- -

K-Mearest Neighbor
Single Node In-Out Degree Correlations

Adjacency Transitivity

Weak Component Clustering

Strong Component Clustering

Blondel Community Detection

Analysis Unweighted and Undirected ~ » |
MNode Degree
Network Analysis Toolkit (NAT)
Unweighted and Undrected Degree Distribution
\Weighted and Undirected Watts-Strogatz Clustering Coefficient
Unweighted and Directed Watts Strogatz Clustering Coefficient over K
‘Weighted and Directed
Diameter
Search Average Shortest Path
Discrete Network Dynamics Shortest Path Distribution
Textual hode Betweenness Centraltty
Global Connected Components
Weighted and Undirected | s
Clustering Coefficient Weak Component Clustering
Nearest Neighbor Degree Blondel Community Detection
Strength vs Degree
Dwee &Strm MST-Pathfinder Netmks:alng
Average Weight vs End-point Degree Extract K-Core
K-Mearest Neighbor (Java) Annotate K-Coreness
Strength Distribution
\Weight Distribution Weighted and Directed a
Randomize Weights HITS Search pl
MST-Pathfinder Network Scaling Wesohied Pagerank Can
Fast Pathfinder Network Scaling Fast Pathfinder Network Scaling Chord
Blondel Community Detection Blondel Community Detection

Annotate K-Coreness

T >
Burst Detection

K Random-Walk
Random Breadth First

Discrete Network Dynamics

Extract and &nnotate Attractors

2

Bérner, Katy, Sanyal, Soma and Vespignani, Alessandro (2007). Network Science. In Blaise Cronin (Ed.),
ARIST, Information Today, Inc./Ametican Society for Information Science and Technology, Medford, NJ,

Volume 41, Chapter 12, pp. 537-607. http:

ivl.slis.indiana.edu/km

ub/2007-borner-arist.pdf
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§2CIShell

CIShell — Customize Menu

> 'The file Yyourtooldirectory/ configuration/ defanlt_menn.xml’ encodes the structure of

the menu system.

» In NWB Tool, the Modeling menu (left) is encoded by the following piece of

xml code:

@mmm?m
File P ing | Modeling | Anabysis

B Consale Random Graph

irnvestigators are Dr, K
Wasserman, and Dr. |

The MWBtoolwasdg ="

Tank, Jazeph Bibersti Cherd

Terkhom,Heng Zhan .

Vespignani, and Katy: Hypergrid
PRU

MNetwork Warkbench
Seience Center (hitps TARL

Please cite a3 follows
NWE Teamn, (2006). K

T FEDAGIE WOrKDe Wiatts-Strogetz Small Waorld
Barabisi-Albert Scale-Free

| <top_menu name="Modeling">

i . <menu pid="edu.iu.nwb.modeling. smallworld"
— e <menu pid="edu. iu. nwh.modeling. barabasialbert”/>

<menu t¥pe- ‘break” />
<menu p

<menu ¥pe- ‘break” />
<menu p
<menu type- ‘break"/>
<menu ¥pe- ‘break”/
<menu p
</top_menu>

<menu pid="edu.iu.nwb.modeling. erdosrandom

3raph“/‘>

d="edu. iu. iv.modeling. p2p. can.CanAlgorithm" />
<menu pid="edu.iu.iv.modeling.p2p. chord.chordalgorithm”/>
<menu pid="edu.id. iv.modeling. p2p. hypergrid. Hypergrid"/>
<menu pid="edu. iu. jv.modeling. p2p. pru. Prualgorithm”/>

d="edu. iu, iv.modeling.tarl.Tar1Algorithm" />

d="edu. u. nwb modeling. weighted. evolvingnetwork” />

<menu pid="edu. iu. nw’b modeling. discretenetworkdynamics. onpalgorithm” />
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Gnuplot

portable command-line driven
interactive data and function plotting

utility http://www.gnuplot.info/.

GUESS

exploratory data analysis and visualization tool
for graphs and networks.

https://nwb.slis.indiana.edu/community/?Pn=Vi
sualizeData. GUESS.
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Supported Data Formats

The NWB tool supports loading the following input file formats:

GraphML (*.xml or *.graphml)

XGMML (*.xml)

Pajek .NET (*.net) & Pajek .Matrix (*.mat)
NWB (*.nwb)
TreeML (*.xml)
Edge list (*.edge)
CSV (*.csv) @
IST (*.isi) O comecrtom
Scopus (*.scopus)

NSF (*.nsf)

Bibtex (*.bib)

Endnote (*.enw)

YVVVVVVVYYVYYY

and the following network file output formats:
GraphML (*.xml or *.graphml)
Pajek .MAT (*.mat)

Pajek NET (*.net)

NWB (*.nwb)

XGMML (*.xml)

CSV (*.csv)

Formats are documented at https:

Y VVVVYY

@ edu berkeley.guirprefus e graphTr

zedata Treef

8] prefuse.data Graph

file:textfegmmi «xmil

. edu.berke ley.guir.prefuse.graph Graph
J

. eduuciicsjunggraphGraph .
. file-test/bibtex

refusedataTable

. . filetext/referbib
filetest e

. File:text/graphmd +xml

. file:test/ps
. 2tk

/ Qs TR —
.XMe.apph(amn.-'p ajeknet \

@ filetext/jpg

. file:application/pajekmat

nwb.slis.indiana.edu/community /Pn=DataFormats.HomePage.

. fletext/icopus
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CIShell Powered Tools:

Science of Science (Sci2) Tool

Science of Science (Sci2) Tool
http://sci2.cns.iu.edu

> Explicitly designed for SoS research and practice, well documented, easy to use.

» Empowers many to run common studies while making it easy for exports to
perform novel research.

Y

Advanced algorithms, effective visualizations, and many (standard) workflows.

A\

Supports micro-level documentation and replication of studies.

\4

Is open source—anybody can review and extend the code, or use it for
commercial purposes.

SUMMARY
e Existing metrics have known flaws
| ® A reliable, open, joined-up data
infrastructure is needed

e Data should be collected on the full
O P | N | O N range of scientists’ work

e Social scientists and economists

should be involved

nature Vol 464|25 March 2010

Let's make science metrics more scientific

To capture the essence of good science, stakeholders must combine forces to create an open, sound and
consistent system for measuring all the activities that make up academic productivity, says Julia Lane.
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Epce of Seicnce

OSGi/CIShell powered tool with NWB plugins and
many new scientometrics and visualizations plugins.

o Baslogy

B Becerchnodogy
© 13 Bewin Research

10 Chemical. Mechanical. & Civil Enginwering

Horizontal Time Graph

S

00 Dot Py A Db Fucey o bassy

Jaint Co-Authorship Network
p

Sci?2 Tool — “Open Code for S&T Assessment”

Nodke Sl & Cilor

1
5

]
T )
] T i 1]

Edge Sine ¢ Color

]
]
1

GUESS Network Vis
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Bérner, Katy, Huang, Weixia (Bonnie), Linnemeier, Micah, Dubon, Russell Jackson, Phillips, Patrick, Ma, Nianli, Zoss,

Abngela, Guo, Hanning & Price, Mark. (2009). Rete-Netzwerk-Red: Analyzing and 1 isualizing Scholarly Networks

Using the Scholarly Database and the Network Workbench Tool. Proceedings of ISST 2009: 121h International Conference
on Scientometrics and Informetrics, Rio de Janeiro, Brazil, July 14-17 . V'ol. 2, pp. 619-630.
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Atool for
.

W% Scif Tool

File Preprocessing Modeli A

s (Vomizon) Scentometrcs

Help

‘Welcome to the Science of Science Tool (Sci
The development of this tool is supported in
|Network Science center and the School of Li
Indiana University, the National Science Fou{
and 05-0715303, and the James 5. McDonnel
Cyberinfrastructure portal (http:fiscislis.ind

The primary investigators are Katy Bomer, In
SciTech Strategies Inc. The Sci’ tool was dew
J. Duhon, Patrick A. Phillips, Chintan Tank, a|
Cyberinfrastructure Shell (httpsficishell.org)
for Network Science Center (http:ffens.slis.in
Many algorithm plugins were derived from t
(http:/inwb.slis.indiana.edu).

Please cite as follows:
Sci® Team. (2009). Science of Science Tool. Ir
| Strategies Inc., http:fiscislis.indiana.edu.

E Schedultl-..

Remove From List | [ Remove completed

GUESS

GnuPlot

Radial Tree/Graph (prefuse alpha)
Radial Tree/Graph with Annotation (prefuse beta)
Tree View (prefuse beta)

Tree Map (prefuse beta)

Force Directed with Annotation (prefuse beta)

Fruck Rei tat

gold with A (prefuse beta)

Drl (VxOrd)
Specified (prefuse beta)

Horizontal Line Graph

Circular Hierarchy

Geo Map (circle an

tions)
Geo Map (region colonng annotations)

Irnage Viewer

RefMapper
. ! Algorithm Narme Date Time % Con|
& Extract Co-Author Netw...  09/03/2000 00:15:20 AM  —
& Load and Clean ISIFile 09/03/2008 00:15:05 AM |

Circular Hierarchy

E]




Workshop Overview

1:30 Macroscope Design and Usage & CIShell Powered Tools: NWB & Sci2
1:45 Sci2 Tool Basics
» Download and run the tool.

2:00 Sci2 Sample Workflow: Padgett's Florentine Families - Prepare, load,
analyze, and visualize family and business networks from 15th century
Florence.

2:30 Sci2 Sample Workflow: Studying Four Major NetSci Researchers.

» Load and clean a dataset as text file; process raw data into networks.
»  Find basic statistics and run various algorithms over the network.

> Visualize as either a circular hierarchy or network

3:30 Break

4:00 Sci2 Demo I: Geospatial maps with congressional districts

4:30 Sci2 Demo 1I: Evolving collaboration networks

4:45 Outlook and Discussion

5:00 Adjonrn
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Sci2 Tool v0.5 Alpha (April 4, 2011)

Can be freely downloaded for all major
operating systems from

http://sci2.cns.iv.edu S

S lmh-ﬂi—.éﬁ-m-lm-

Select your operating system from the bt —
ot

pull down menu and download.
Unpack into a /sci2 directory.

Run /sci2/sci2.exe

Tutneials

Sci2 Manual is at é';f‘.._"'”"‘“’“’““"""‘?’“‘“c‘ e o e oot i ey e

0101 Flag and Firs Masrssinges Tatseial Isterasesiesl Coeformaee ow Secml Computmg. Bebavionl Misdekng ied

http://sci2.wiki.cns.iu.edu

Aibnard for palizymakery dwring Capital Hill 1162 (xpbuior scmand

Phewse vire 13

Cite as N DA B o A it e, ol Mt
Sei? Team. (2009). Science of Science (Sci) Tool. ‘:mﬂ;ﬂ:;k:“mm;:\f;““ﬂ;"mmhﬂhmm
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i Sci’ Tool: Download, Install, and Run

Sci2 Tool v0.5 Alpha (April 4, 2011)
Supports ASCII UTF-8 characters
Web-based Yahoo! and desktop Geocoders
U.S. and World geomapper

Customizable stop word lists _ :

. 1) 5¢i2-N-1.0.0.201008130505NGT-macosx.carbon.ppc.zip
Merging of networks 1) 5¢i2-N-1.0.0.201008130505NGT-macosx.carbon.x86.zip
New home page, wiki-based tutorial 1 sci2-N-10.0.201008130505NGT-macosx.cocosx86_64.zip
1) 5¢i2-N-1.0.0.201008130505SNGT-win32.win32.x86.zip

YV VVYYVYY

Bug fixes, streamlined workflows

Sci2 Tool runs on Windows, Mac, and Linux.

UﬂZiP- bscanL | _ 91,374KB
. . sci2 | Browse with Corel Paint Shop Pro Photo X2
Run /SC12/SC12.CXC J Open Command Prompt Here
Extract All...
Scan for Viruses... :
1-Zip » Open archive
Open With... Extract files...
& Magiclso v Extract Here
29
Sci2 Tool Interface Components
& practice . o .
See also bttp:/ [ sci2.wiki.cns.iu.edu/ 2.2+ User+Interface
" stool eloEs
Use | File DataPrepanation Prep ing Analysis Modeling  Visuali Help
> M dd E'lﬂonmk = O it Dsta Manager| = O
enu to rea ata) run | 'Welcome to the Science of Science Tool (Sei’). - ."?”Direcu;ry;l‘nt - Pref
. | [The pment of this tool is supparted in part by the Cyberinfrastn for |
algorlthms . | [Network Science center and the School of Library and Information Science atIndisna |E
{University, the National Science Foundation under Grant No. SBE-0738111 and
O5-0715303, and the James S McDonnell Foundation, See Science of Science
> Console to see Work log, | [Cyberinfrastructure portal (hitpeffscislisindiana.edu) for more information.
. || {Primary investigators are Katy Bomes, Indiana University and Kevin W. Bayack, SeiTech
re ferences tO S emlnal Works . | Strategies Inc. The Sci’ tool was developed by Micah W. Linnemeier, Russell J. Duhon,
L2tk A b s Chiotan Tank, ded Jestph Saption, R wbyosni inichuet B
» Data Manager to select, view, | @ s =1
save loaded, simulated, or \BamevaEropn i) B3 Remove comp b (Remove s completd]
. || m]
derived datasets. it I
! Algorithm Name Date Time % Compl
> SChedUICf to see status Of i Read Directory Hierarchy  08/15/2010  OT0217PM s
algorithm execution. | L [ ]

All workflows are recorded into a log file (see /sci2/logs/...), and soon can be re-
run for easy replication. If errors occur, they are saved in a error log to ease bug
reporting,

All algorithms are documented online; workflows are given in tutorials, see Sci2
Manual at http://sci2.wiki.cns.iu.edu
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Sci2 Tool — Read+Visualize Sci2 Tool Directory Tree

Use ‘File > Read Directory Hierarchy’ with parameters
i

Root directory I C:\Documents and Settingsikaty\Desktopinwb 3/
Levels to recurse | 1 )

[V Recurse the entire tree
™ Read directories only (skips files)

\-.I"/

3
(Lo ] Concel|

Visualize resulting Directory Tree - Prefuse (Beta) Graph’ using
o Visnalization > Tree VView (prefuse beta)’

o Visualization > Tree Map (prefuse beta)’

o Visnalization > Balloon Graph (prefuse alpha)’

o Visualization > Radial Tree/ Graph (prefuse alpha)’

31

. =10l x|
Different views of the
/nwb directory
hierarchy.

e
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Note the size of the
/plugin directory.
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i Sci2 Tool — Visualize Workshop Attendees

Use File > Read’ to load Se/T'S Conf SNA Registrants report 4.10.11-clean.csv

A | 8 |
1 |LastName Org Organization-Cleaned
2 |Agoulnik edu Bngham and Womnen's Hospital, Harvard Medical Schoal
3 |Amaral eduy Northwestern University e
_4 |Bates edu University of lllinois at Chicago W% Sci2 Tool
5 |Bennett g0 NIH File [Data Preparation | Preprocessing Analysis |
6 |Bietz edu University of California, Inine ]
7 |Bishop edu University of Tennessee Ej Remove ISI Duplicate Records
B . == - e -
"9 |Lotrecchiann orgedu  George Washington University Wel R Raws with M Fields
10 |Lusina ca,edu Centre for Hip Health & Mability The E
Seiel Extract Directed Network
ga:!. Extract Bipartite Network
. . . Bxtract P Citation Network
Run ‘Data Preparation > Extract Bipartite Network’ ford Sl
Wlth parameter Values * Extract » bipartite netwark from two calurmng in the table, B the
colurmn values may list multiple entries, enter the special text
which delimits them.

First column (Last Name B @
Optional: Calculate Node Degree Scondcohmn [0rg 3]0

Teet Delimniter ] i§|

Aggregate Function File  C/Users/User/Desktop/NWB-Seidjsci20.5-siphs | Browae| (@]
Visualize resulting ‘Bipartite network (Gorel

from Last Name and Org’ using ‘Visunalization > Network > GUESS’ and
TLayout > GEM’, T.ayout > Bin Pack’

33

Sci2 Tool — Visualize Workshop Attendees

ofs

N,
_ ¥ e Rovira @ 1.5t Name
° \ . .
Van Den Besselaar I| » Sima Gould ‘\. - . Email Org
/ oy |
5{" N s '.I .
N\ Size coded by degree.
oCa
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‘i Sci2 Tool — Visualize Workshop Attendees

Use File > Read’ to load Se/T'S Conf SNA Registrants report 4.10.11-clean.csv

A B |

1 Last Name Org Organization-Cleaned
2 |Agoulnik edu Bngham and YWomen’s Hospital, Harvard Medical School
3 |Amaral eduy Northwestem University
4 |Bates edu University of lllinois at Chicago

5 |Bennett g0 NIH

6 |Bietz edu University of California, Inine

Bishop edu University of Tennessee

‘L;otre:chuann orgedy  George Washington University
10 |Lusina ca edu Centre for Hip Health & Mability

Run ‘Data Preparation > Extract Bipartite Network’

With parameter values:

Optional: Calculate Node Degree

Visualize resulting ‘Bipartite network

'-Eahmmum @_

Agaregate Function Fle CofUsersUser/Desktop/NWE-Scizisciz-5-alpha | Browse| [

¥ Sci2 Tool

File [m Preprocessing  Analysis |
: Remove IS Duplicate Records
Remove Rows with Multitudinous Fields

Extract Directed Network
Extract Bipartite Network
Extract Paper Citation Network

Extract » bipartite network from two columng in the table. If the
colurnn values miry st multiple entries, enter the special tet
which delimits them.

) =
|Last Narne - 3!
[organization-Cleaned - [@]
T 4 -_|

L4

Jfrom Last Name and Org’ using ‘Visualization > Network > GUESS” and

Layout > GEM’, Layout > Bin Pack’
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Sci2 Tool — Visualize Workshop Attendees
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Sci2 Tool — Visualize SciTS Co-Author Network
Based on Holly’s EndNote File

Open Holly’s ¢ TS-Library-03-04-2011.enl’ in EndNote and save as S¢/TS-Library-03-
04-2011.enw’ following instructions on
http://cishell.wiki.cns.iu.edu/Endnote+Export+Format

Use File > Read’ to load SciTS-Library-03-04-2011.enw’
Run Data Preparation > Extract Co-Occurrence Network’

With parameter values: [73] g vetwork from Table .
Extracts a network from a delimited table
Column Name F\uﬁmn v] &]
Text Delimiter | &]

Optional: Calculate Node Degree

Visualize resulting ‘Bipartite network
Jfrom Last Name and Org’ using ‘Visualization > Network > GUESS” and
Layout > GEM’, Layout > Bin Pack’
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Sci2 Tool — Visualize SciTS Co-Author Network
Based on Holly’s EndNote File

Network Analysis Toolkit (NAT) was selected. ST,

Implementer(s): Timothy Kelley . ol . B oo s 706 Authors
Integrator(s): Timothy Kelley 5 i

Reference: Robert Sedgewick. Algorithms in Java, Third Edition, Part 5 - Graph

Algorithms. Addison-Wesley, 2002. ISBN 0-201-31663-3. Section 19.8, pp.205

Documentation: .

http:/ /wiki.cns.iu.edu/display/ CISHELL/Network+Analysis+Toolkit+%28NAT%29

This graph claims to be undirected. - ;

Nodes: 706
Isolated nodes: 100 - 0 LA " - - -
Node attributes present: label L %% w

Edges: 1687 U s v -
No self loops were discovered. : s
No parallel edges were discovered.

Edge attributes: . I
Did not detect any nonnumeric attributes. : S e s it
Numeric attributes: . . - .. : i
minmaxmean ES 2 R =T *
weight ~ 151.15412 Vi i P

This network seems to be valued. "
Average degree: 4.779

This graph is not weakly connected.

Thete are 223 weakly connected components. (100 isolates)

The largest connected component consists of 73 nodes.

Did not calculate strong connectedness because this graph was not directed.

Density (distegarding weights): 0.0068
Additional Densities by Numeric Attribute
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si 1 Sci2 Tool — Visualize SciTS Co-Author Network
Based on Holly’s EndNote File

I eS8 rch & practice

4 %%, Weak Component Cluster of 73 nodes
LN k with degree attrik added to node list.4

%7, Weak Component Cluster of 50 nodes
%3, Weak Component Cluster of 33 nodes
%%, Weak Component Cluster of 25 nodes
%7, Weak Component Cluster of 17 nodes

Weak Component Clustering W - #: \feak Component Cluster of 14 nodes

Implementer(s): Russell Duhor) - #: oy Component Cluster of 12 nodes

g;iiit:;g)‘;i‘?sseu Dubon :.'. Weak Component Cluster of 12 nodes.2

hitp:/ /wiki.cns.iu.cdu/display :, Weak Component Cluster of 11 nodes

o s Weak Component Cluster of & nodes

Input Parameters:
Number of top clusters: 10
223 clusters found, generating graphs for the top 10 clusters.
Node Degree was selected.
Implementer(s): Timothy Kelley
Integrator(s): Timothy Kelley
Documentation: http://wiki.cns.iu.edu/display/ CISHELL/Node+Degree
GUESS was selected.
& Author(s): Eytan Adar
o Implementer(s): Eytan Adar (GUESS), Russell Duhon (resizeLinear, colorize fix)
Integrator(s): Russell Duhon
Reference: Adar, Eytan, "GUESS: A Language and Interface for Graph Exploration,"
CHI 2006 (http://graphexploration.cond.org/)
Documentation: http://wiki.cns.iu.edu/display/CISHELL/GUESS
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T Sci2 Tool — Visualize SciTS Co-Author Network
. Basedon Holly’s EndNote File

4 %7, Weak Component Cluster of 73 nodes
%, Network with degree attribute added to node list.4

%, Weak Component Cluster of 50 nodes
%, Weak Component Cluster of 33 nodes
%%, Weak Component Cluster of 25 nodes
%%, Weak Component Cluster of 17 nodes
%5, Weak Component Cluster of 14 nodes
%, Weak Component Cluster of 12 nodes
%, Weak Component Cluster of 12 nodes.2
%%, Weak Component Cluster of 11 nodes
2, Weak Component Cluster of § nodes

B02| Stipelman, B. 589 *
603 Stokols, D. 200~
604 |Stokols, Daniel 75"
B05 | Stone, Anthony R. 606 *
606 | Stringer, M. j. 608 *
607 | Subramanian, S. 558
608 | Sundstrom, Eric 219
609 Sung, N. 611"
610/ Sung, NS 628 *
611|Syme, 638|Tress, G. B61 *
639 Trochim, W, 506 *
640 | Trochim, W, M. 408 *
641 | Trochim, W. M. K 48 "
642 | Trochim, W.m. 444 "
643 Trochim, William 76"
644 | Trochim, William M. K [
645 Unger, J. 508 *
646 |Uzzi, B. 346 *
647 |Uzzi, Brian B8 *
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Sci2 Tool — Visualize SciTS Co-Author Network
Based on Holly’s EndNote File — Last Names

Network Analysis Toolkit (NAT) was selected. . ’ . - B 706 Authors
Implementer(s): Timothy Kelley ) ’

Integrator(s): Timothy Kelley - g ¥

Reference: Robert Sedgewick. Algorithms in Java, Third Edition, Part 5 - : h -

Graph Algorithms. Addison-Wesley, 2002. ISBN 0-201-31663-3. Section - * LR 584 Authors
19.8, pp.205 C ’
Documentation: . % @ o
http://wiki.cns.iu.edu/display/ CISHELL/ Network+Analysis-FT00‘Lkisj—

%28NATY29 -
This graph claims to be undirected.

i =
Nodes: 584
Isolated nodes: 79
Node attributes present: label, totalDegree

Edges: 1472
No self loops were discovered. B -
No parallel edges were discovered. . ks b B

Average degree: 5.0411 s * ® & ]
This graph is not weakly connected. . i
There are 162 weakly connected components. (79 isolates)

The largest connected component consists of 183 nodes.

Did not calculate strong connectedness because this graph was not
directed.

Density (disregarding weights): 0.0086

Additional Densities by Numeric Attribute

41

Last Names — Giant Component

Lazer, Pentland, Adamic, Aral, Barabasi, Brewer,
Christakis, Contractor, Fowler, Gutmann, Jebara,
King, Macy, Roy, Van Alstyne (2009) Computational
Social Science. Science.

EEREERRPE 00

%, Weak Component Cluster of 183 nodes
%7, Weak Component Cluster of 48 nodes
%%, Weak Component Cluster of 14 nodes
%, Weak Component Cluster of 13 nodes
%, Weak Component Cluster of & nodes
%%, Weak Component Cluster of 8 nodes.2
00 %, Weak Component Cluster of 7 nodes
y i %, Weak Component Cluster of 6 nodes
a '_ / /| %, Weak Component Cluster of 5 nodes
v / [ %7, Weak Component Cluster of 5 nodes.2
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Workshop Overview

1:30 Macroscope Design and Usage & CIShell Powered Tools: NWB & Sci2
1:45 Sci2 Tool Basics
» Download and run the tool.

2:00 Sci2 Sample Workflow: Padgett's Florentine Families - Prepare, load,
analyze, and visualize family and business networks from 15th century
Florence.

2:30 Sci2 Sample Workflow: Studying Four Major NetSci Researchers.

» Load and clean a dataset as text file; process raw data into networks.
»  Find basic statistics and run various algorithms over the network.

> Visualize as either a circular hierarchy or network

3:30 Break

4:00 Sci2 Demo I: Geospatial maps with congressional districts

4:30 Sci2 Demo 1I: Evolving collaboration networks

4:45 Outlook and Discussion

5:00 Adjonrn

43

Padgett's Florentine Families - Compute Basic
Network Properties & View in GUESS

Florentine families related through business ties (specifically, recorded financial
ties such as loans, credits and joint partnerships) and marriage alliances.
Node attributes
Wealth: Each family's net wealth in 1427 (in thousands of lira)
Priorates: The number of priorates (seats on the civic council) held between
1282- 1344
Totalties: The total number of business or marriage ties in the total dataset of

116 families.

“Substantively, the data include families who were locked in a struggle for political
control of the city of Florence around 1430. Two factions were dominant in this
struggle: one revolved around the infamous Medicis, the other around the
powerful Strozzis.”

http://svitsrv25.epfl.ch/R-doc/library/ergm/html/florentine.html
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Padgett's Florentine Families - Compute Basic
Network Properties & View in GUESS

> Load *yoursci2directory*/ sampledata/ socialscience/ florentine.nwb
» Run Analysis > Network Analysis Toolkit (NAT)’ to get basic properties.

This graph claims to be undirected.

Nodes: 16

Isolated nodes: 1

Node attributes present: label, wealth, totalities, priorates
Edges: 27

No self loops were discovered.

No parallel edges were discovered.

Edge attributes:

Nonnumeric attributes:

Example value

marriag...T

busines...F

Average degree: 3.375

There are 2 weakly connected components. (1 isolates)
The largest connected component consists of 15 nodes.
Did not calculate strong connectedness because this graph was not directed.
Density (distegarding weights): 0.225

» Select network and run Visualization > GUESS’ to
> Apply ‘Layout > GEM’.

open GUESS with file loaded.

45
wor =18l
2 console 50| =n
......... | ' NWB File: C:\Documents and Settingsijaty\C
:-Erif F;sisetm:g;, T Dustribution of degree for network at st
uthor(s): Eytan L.
hmplementen(s): Eytan Adar (GLESS), Russell Duhon (resizetinear, colrizs fix) o List of edges of network created through the
nbegrator(s): Russel Dubon /" Distribution of degree for network at st
Feference: Adar, Eytan, "GUESS: A Language and Interface For Graph Exploration,” CHI 2006 (http:/ /graphexploration.cond.org/) Ml Distribution of degres for network at st
Eﬁ:;-:r;?tm- https://nwh.slis.indiana.edu/community, 7n =VisualizeDat 2. GUESS B2 W fie: C:\Documents and Settingslkatyc
Etarting GLESS. . = Graph and Network Anatysis Log
ECHO is off. = Sequence of site betwesnnesses for o
El‘:f;\ilddl?ymt For your visuskzation is random., For a clearer visuakzation, please run & Layout from the Layout menu. (We recommend GEM, ) A Distribution of sibs batwesnness for nat
e . A
5LESS log file for this session can be found in = Dctribution of ke betweennass for naty
C:\DOCUME 1 Jraty|\LOCALS~1\Temp|C1Shel- S5O9Z1StaticE xecut SSR04ALGORT guession tat '+ NWE file with site betweennass attribute
- - sakactad Visualization - GUESS =10] x|
puthor(s) Extan Adee | Fle Edt Layot Sopt Vew Heb
{s): Eytan Ad
Inbegraton(s): Russell Dubs k- |
B e araas A, Evtan - Medici-Acciaiuoli
Pocumentation: https: i Field Vahe |
ECHO i off. __edgesd o
Starting GUESS. .. Business F
ECHO is off. coior darvdoion
[The: indtial lavout For your +
ECHO is off, 5 (drected False
SUESS log File For this sess| .5 label
KA DOCUME~1 Yty \LOCA labelcolor 0,0,0,255
Labelsize 12
B scheduler Isbelvisble False
narriage T
Remove FromList [ [ | odel e
node2 nl
m visible true
weight 1o
2
[ltr| ™20
GUESS
GLESS
| Node Betw
| Metwork Az
¥ Load...
. GraPlot
GraPlot
J 2 Obrect: | Property: = | Operator: Ve
¥ Degree Dis -
J il Eurabiie Colour Show Hde Size Show Label Hide Label Change Label
v GraPlot ] |
b Desgres Dis Node Shape Center | Change History
| GUESS
| Load...
Interpreter | Graph Modifier
| K | 46




Lg% Pan:

Fie Edt Layout Script View Help | “orab” the background
Medici : by holding left-click
Field || Value ' and moving your

g ;::1 ;.:;:Iu... g O mouse. i
height  10.0
image

‘g lsbel  Medii N O Zoom:
m ?'20'0"” b A Using scroll wheel,
oo, e ﬁ U press the “+” and “-”
origingl... Medici O buttons in the upper-
priorates 53 /’) left hand corner, or
f:: ;"”’b @] < right-click and move
totalties 54 the mouse left or right.
o e m Center graph by
width  10.0 selecting “View ->
X 90.625... Centet’.
y 44.312... m m

S
i " Select /g to
select/move single

Object: [ ‘_'J Property: [Ia-tels-:: "'] Operator: [E} Value: EI nodes. Hold down
| coour || show |[ Hde || see || showiabel || Hidersbel || changelabel | ‘Shift’ to select
| Format Node Labels | | Format Edge Labels | multiple.
| Modeshape || center || changetistory | ' . .
| ] Right click to modify
Color, etc.
[Nodes | [labetsize =] From: | | To: | || Do Resize Linear
Interpreter , Graph Modfier |
47
Graph Modifier:
Visualization - GUESS ‘Jm—IK
| Select “all nodes” in the Object
T drop-down menu and click ‘Show
rod | vae || G Label’ button.
color  255,25... -
ed  False 3
height 5.0 a (x_.-’ ani;) . -~ . .
gmw . W e Select ‘Resize Linear > Nodes >
kel pucd l'h'} ' Baradort] h lities” d d th
Isbelcolor ?,zo,o,.. o Lamb b ponzzt) = @) — totalities rop-down menu, then
labebv... true E W altizzi) type “5” and “20” into the From”
name  nl2 - rezzi Y 2
. P O e Strazz b - ;. and To Valtle box sleparz?tely. ’
srcha... cadeb.. @ W ouior) Medtl) Then select ‘Do Resize Linear’.
2 - -
’::m 1 (O romataony 2 Actiaiuok)
=HE m Select ‘Colotize>
pah_ 52 Nodes>totalities’, then select
P10 m O Pueci) white and enter (204,0,51) in the
pop-up color boxes on in the
Ay “From” and “To” buttons.
Object: | [«] Property: [heie =) Operator: [~ ~| vahue: [ =
: Select “Format Node Labels”,
| coor || show || mde |[ see || showisbel || mdetsbel || chenotabel | lace defaul oinallabel
P | ] replace default text {orlglna abel}
with your own label in the pop-up
| Nodeshzpe || cCenter || chengetstory | box Fnter a f tine strino f
= = : 1
st OX ner? ormatting string for
node labels.
Interpreter | Graph Modfier |

48




Visualization - GUESS AJQI!]

a " Castellani:)_
’ ' Barbadorr) Ginoric)
Lamiy ) Peruzzi) ) L saliath)
‘f‘ . Albizzi))
“‘1 Streezi) O )
" Bischeri) ) Ridolfi) -’ Pazzi)
] Medicl:)
L . Guadagnt)
) tomabuany U Acciaiuoli)
ﬁ J Pucci) Interpreter:
Uses Jython a combination of Java
Ay and Python.
-
>>> resizelinear(totalities,5,20)
>33 colorize(wealth,white,red) Try
55>
colorize(wealth, white, red)
" / Graph Modiier |
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Workshop Overview

1:30 Macroscope Design and Usage & CIShell Powered Tools: NWB & Sci2
1:45 Sci2 Tool Basics
» Download and run the tool.

2:00 Sci2 Sample Workflow: Padgett's Florentine Families - Prepare, load,
analyze, and visualize family and business networks from 15th century
Florence.

2:30 Sci2 Sample Workflow: Studying Four Major NetSci Researchers.
> Load and clean a dataset; process raw data into networks.

»  Find basic statistics and run various algorithms over the network.
» Visualize as either a circular hierarchy or network.

3:30 Break

4:00 Sci2 Demo I: Geospatial maps with congressional districts

4:30 Sci2 Demo 1I: Evolving collaboration networks

4:45 Outlook and Discussion

5:00 Adjonrn
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Studying Four Major NetSci Researchers (ISI Data)
using Database (section 5.1.4)

FourNetSciResearchers.isi

Time frame: 1955-2007

Region(s): Miscellaneous

Topical Area(s): | Network Science

Analysis Type(s): Paper Citation Network, Co-Author Network, Bibliographic

Coupling Network, Document Co-Citation Network, Word Co-
Occurrence Network

Thomson Reuter’s Web of Knowledge (WoS) is a leading citation database. Access it
via the “Web of Science” tab at http://www.isiknowledge.com (note: access to this
database requires a paid subscription). Along with Scopus, WoS provides some of
the most comprehensive datasets for scientometric analysis.

To find all publications by an author, search for the last name and the first initial
followed by an asterisk in the author field.

bttp:/ [ sci2. wiki.cns.in.edn/ 5. 1.4+ S tudying+Four+Major+ NetS ci+Researchers+(IS1+Data)
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Data Acquisition from Web of Science

.-.I.Iil!.l'
In Dec 2007, we downloaded e N5 R N e — “e@'

all papers by
» Eugene Garfield
» Stanley Wasserman

o] o s | % 151 s of Knaeiga [ VL)
1S Web of Knowledge™
Web of Science®
o] | ) ) [
Ganeral Search

Select dotabase{s) and timospan: | s i a

(miacom
L o o |

Citation Databases: : Latest [ veen =] {upcated Dacember 09, 2007)

P U Science Citation Index Expanded (TC1-EXPANDED )~ 1955-present voar [Fe07

F 1 Social Sciences Citation Index (S5C1)--1056-prasent & From [Teas 5] to [3567 = (defsult is al years)
To remesber these settings, first 3ign in or regrter

» Alessandro Vespignani
»  Albert-Laszl6 Barabasi

F i Arts i Humanities Ctatscn Indes (ABHCT)--1975-present

Enter tirms or pheases sepacated by the opraton AND, OF, WOT, o SAME, 4nd than press SEARCH,
Lz Iwitory/Combene jutsl

Ve our G 1 bt
The search will be added 1o the ssarch history. Yot e Gatteal_Seein naonil

ch b

swancn] cuna |

from

» Science Citation Index
Expanded (SCI-EXPANDED)
--1955-present

» Social Sciences Citation Index

(SSCI)--1956-present

»  Arts & Humanities Citation
Index (A&HCI)--1975-present

SEAw0l

TOPIC: jj Enter one or morw tarms. Seaeches within artichy tites, kayworeds, and abstracts,

& : ol spll® ANO *North Sea® (How 1o search for phrases)
I Tt anly

AUTHOR: ) Entad ond of mors uthor rans (see usher iodas K.
:CVBAIAN C* DR DBRIAN C*
Author Fincder: Weed help finding papers by an suthor? Use Author Finder

GROUP AUTHOR: (i Enter ona or mors Group names (see group author indes 5.
Ex CERN

SOURCE TITLE: {j Enter full joumal titles {cew fisl source tities hst
Example: Cancer® OR Journal of Cancer Research and Chnical r_\ncnlwv

nnucum:w YEAR: U Enter & publication year or range.
: 3001 or 1997-1990

ADDRESS: ) Enter abbrevisted terms from an suthor's affitation (use sbbreviatons heip)
Example: Yale Univ SAME hosp

Restnct search by languages and documant types

ngarh =
i s ahatence o8 Publshad Dam
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Comparison of Counts
No books and other non-WoS publications are covered.

Age Total # Cites Total # Papers H-Index

Eugene Garfield 82 1,525 672 31

Stanley Wasserman 122 35 17

Alessandro Vespignani 42 451 101 33

Albert-Laszl6 Barabasi 40 2,218 126 47 (Dec 2007)
41 16,920 159 52 (Dec 2008)
44 30,102 201 68  (April 11)
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Extract Co-Author Network

Load*yoursci2directory*/ sampledata/ scientometrics/ isi/ FourNetS ciResearchers.isi’

using "File > Load ...*
And file with 361 records appears in the Data Manager.

Duplicates were removed, author names normalized. Log file exists.

% 2 Tool (E==fon ==
File Data Preparation Preprocessing  Analysis  Modeling  Visualzation Help
LConsole = O || it Data Manager =0
|8 Console, g
{Lnaded 361 records. Al m 151 Data: C:\Users\User\Desktop\10-NEH-A&H-Workshop
| Removed 0 duplicate records. [T 361 Unique IS Records

Author names have been normalized.
:|351 records with unique IS 1Ds are available via Data Manager.

'Wrote log to

|C:\Users\User\AppData\Local Temphisiduplicateremoverlog2534733993422022 — |
3RS =
L 3
B Scheduler =
Remove From List | || Remove completed automatically ..R:mm all complete
!t Algorithm Name Date Time %

¥ Load and Clean I3 File 08/15/2010 07:29:43PM
~ Load and Clean ISI File 08/15/2010 07:12:49PM
‘ m
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Extract Co-Author Network

(see section 5.1.4.2 on correcting duplicate/ misspelled anthor names)

To extract the co-author network, select the 367 Unigue IST Records’ table and run
‘Data Preparation > Extract Co-Author Network’ using isi file format:

x|
Extracts a co-authorship network From one of several supported file
types.
File Format |isi i &

[

The result is an undirected but weighted network of co-authors in the Data Manager.
Run ‘Analysis > Network > Network Analysis Toolkit (NAT)’ to calculate basic
properties: the network has 247 nodes and 891 edges.

Use ‘Analysis > Network > Unweighted and Undirected > Node Degree’ to calcnlate the number
of neighbors for each node independent of co-anthorship weight.

To view the complete network, select the ‘Extracted Co-Authorship Network’ and run
Visualization > Networks > GUESS".

Network is loaded with random layout. In GUESS, run T.ayout > GEM’ and ‘Layout

> Bin Pack’ to improve layout. Run "Seripr > Run Seript ..." and select '
yoursci2directory/ scripts/ GUESS / co-author-nw.py'.
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Co-Author Network of all Four NetsSci Researchers

agerin, A ',‘ Node Size EI\ Colar E,dgr Size &I(_'nlm'

~=g Co-Authored
=] 7
. Eugene Garfield 2 33

(4 1

| — |
1 127 1 3
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Co-Author Network of all Four NetsSci Researchers

Use the GUESS Graph Modifier to change
color and size coding.

_E:'m-.:!:_v Wasserman

Calculate node degrees in Sci2 Tool. \ d
. S

Use a graphic program to add legend.

agerin 32 X\ [ 4 Node Sire & Color Eiige Size & Color
L ol Fape \NuiP 1 i

' Eugene Garficld L :—‘

a5
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Individual Co-Author Networks
(Read/map 4 files separately)

Alessandro Vespignani Albert-1.4sz16 Barabasi
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Atool for

o Dl'xiﬂn:t:

Network Visualization:
Node Layout

Load and Clean ISI File was selected.
TLoaded 361 recotrds.

Removed 0 duplicate records.
Author names have been normalized.

Extract Co-Author Network was selected.
Input Parameters:

File Format: isi

Network Analysis Toolkit INAT) was selected.
Nodes: 247

Edges: 891

GUESS was selected.

59
Network Visualization:
Color/Size Coding by Data Attribute Values
-
®
' &% Visualization - GUESS
Ele [Edt Layout Script View Help
Vespignani, A ¢
Field vaeo ||| o

color 125,12,17,255
Fixed false

g height 10.0 °
image .
label Vespignani, A .

— labelcolor 0,0,0,255 J
labelsi 12 LA . -
labelvisible false T @ Node Size & Color Edge Size & Color
name nlél | ® Number of .‘.li Crs Number of Times
rumberofworks 101 .., Co-Authored
originallabel Vespignand, A » =
strokecolor  black g ., ——| 127 33
e 2 o 35 b4
timescited 3811 4 1
visible true 5
o — M s o
X 586.75
g el B 1 127 1 33




Network Visualization:
Giant Component

Weak Component Clustering was selected.
Implementer(s): Russell Duhon
Integrator(s): Russell Duhon

Input Parameters:
Number of top clusters: 10
3 clusters found, generating graphs for the top 3 clusters.
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Network Visualization:

Color/Size Coding by Degree

Node Degree was selected.
Documentation:

https:/ /nwb.slis.indiana.edu/community/?n=AnalyzeData.No
deDegree

.......... - * . .
. . » .
.
o .
. " - . L] .
.- | 7 . )
—~@ ’ %
Garield E ®
. 4 —y mman, §
. L ]
[ ] .. L ] ® \ .
o \
-] °® * e
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Network Visualization:
Color/Size Coding by Betweeness Centrality

Node Betweenness Centrality was selected. i
Author(s): L. C. Freeman

Implementer(s): Santo Fortunato

Integrator(s): Santo Fortunato, Weixia Huang

Reference: Freeman, L. C. (1977). A set of measuring centrality

based on betweenness. Sociometry. 40:35-41. *

Input Parameters: s e . ;
Number of bins: 10 . L _feageran s

umber of bins: 10
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Network Visualization:
Reduced Network After Pathfinder Network Scaling

/ '
LSt eMakeev, MA o i 'c ’ " . G";m'&
Ovicgek T 5 Aﬁ HE ., 1 0
o 5 ®hong H *
"’""'I‘s : J efevan
2 RN
. . _.ﬁ'ihu.u §
°r Y .?EEI'{
B A S R OPasoesabmasRe alorsto,V
. N Tt =
®0tva, 2N N e
- - pignani, A .
° I\"Ei!.!, A v N
SRR @Phoneo, L
- V4 _sBameemy, M
. » eBamat A
MST-Pathfinder Network Scaling was selected. . - .
Input Parameters: T vm——
Weight Attribute measures: SIMILARITY [ )

Edge Weight Attribute: weight
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Network Visualization:
Circular Hierarchy Visualization

Select Co-Author Network and run Blondel Community detection:

File DataPreparation Preprocessing | Analysis | Modeling  Visualizati Help
B Console ! Temporal L =0

= 1 :
Geospatial ’ = NEH- Worksh - |
Lo e Clisis ISt Filé waas sebeicted, 2 . Users\User\Desktop\10-NEH-A&H-Workshop\DVDAsci2\sample
Author(s): Micah Linnemeier P — o - ique IS Records
Implementer(s): Micah Linnemeier | Nebworks | Network Analysis Toolkit (NAT) on
Integ {s): Micah Li i ' | MetSciResearchers.isi
Documentation: | Unweighted & Undirected * e meraed
:..;arde;.l' bshis.indi d itylin=LoadData.ISILoadAr Weighted & Undirected » Clustering Coefficient
Ci\Users\User\Desktop\10-NEH-A&H-Workshop\DVD\sciZ\sample Unweighted & Directed ¥ Nearest Neighbor Degree
ometrics\isi\FourNetSciResearchers.isi | Weighted & Directed » Strength vs Degree
Loaded 361 recards‘ . D 151 Data: CAUsers\Use Degree & Strength
Removed 0 duplicate records. 4 [T7] 361 Unique ISI Rec Ayerage Weight vs End-point Degree
Author names have been normalized. - 2y e

'« Bxtracted Co-£ Strength Distribution

361 records with unique IS1IDs are available via Data Manager, £7] Author inform Weight Distribution
Wrote log to Randomize Weights
CA\U L DatalL Tempisidupli flogd773522398971021
37\3.;::"\ PR S e i = Blondel Community Detection

With parameter values | glondel Community Detection

This algorithm impl ts Blondel's ¢ ity detection
algorithm.
Weight | numberofcoauthoredworks v]
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Network Visualization:
Circular Hierarchy Visualization

I‘.iﬂﬂn:i.'
Sdarch & practice

Visualize resulting file using ‘VZsualization > Networks > Circular Hierarchy’
with parameter values

5| Circular Hierarchy

Provides Circular Hierarchy Visualization on the network.

Degree of Edge Bundling 0.75

Node Strength Column  |timescited - [@)
Level 0 |blondel_community level 0 |
Level 1 [blondcl_community_lml_l ']
Level 2 (blondel_community level 2 |
Level 3 (No Level - [ @)
Edge Weight Column [ numberofcoauthoredworks  ~| (@]

MNode Color Column ’numbem!‘works v]

Node Color Range IGmen to red v]
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Network Visualization:
Circular Hierarchy Visualization

Nodes that are interlinked/clustered e SSN
are spatially close to minimize the IR WRTE R e
number of edge crossings. T

Node labels, e.g.,

author names. //

Network structute f = >
using edge bundling.

Color coded clustet ———»

hierarchy according to 75 &N 7

Blondel community s '

detection algorithm. \\ 7 B Node Coloz

Note: — = “ w

Header/footer info, legend, and more meaningful color coding are under development.
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Paper-Citation Network Layout

To extract the paper-citation network, select the 367 Unigue 151 Records’ table and run
‘Data Preparation > Extract Paper Citation Network. *

The result is a unweighted, directed network of papers linked by citations, named
Extracted paper-citation network in the Data Manager.

Run NAT to calculate that the network has 5,342 nodes and 9,612 edges. There are
15 weakly connected components. (0 isolates)

Run ‘Awnalysis > Networks > Unweighted and Directed > Weak Component Clustering’ with
parameters

f ¥ Weak Component Cluster of 5151 nodes

:'3 Weak Component Clusterin -" &
& = . %, Weak Component Cluster of 38 nodes
Creates new graphs containing the top connected components. % Weak Component Cluster of 35 nodes
o
= - ‘Weak Component Cluster of 27 nodes
o
Nurmber of top clusters 10| A %%, Weak Component Cluster of 27 nodes.2
%, Weak Component Cluster of 15 nodes
[ Cancel

to identify top-10 largest components. The largest (giant) component has 5,151 nodes.

To view the complete network, select the network and run ‘VZsualization > GUESS”.
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314 joumnal references matched out of 361 found.

These 314 references are

associated with 13 of 13 disciplines of science and 233 of 554 research specialties in the UCSD Map of Science.

Data:

WoS and Scopus for 2001-2005, 7.2 million
papers, more than 16,000 separate journals,
proceedings, and series

Similarity Metric:
Combination of bibliographic coupling and
keyword vectors

Number of Disciplines:

554 journal clusters further aggregated into 13 main
scientific disciplines that are labeled and color
coded in a metaphorical way, e.g., Medicine is
blood red and Earth Sciences are brown as soil.

& -
-W& -
(C.,/ :
&
o ., 0 Anfectious Disease
o
& g
@ &
Earth Scaence:
.
" | Science Map =
Locate the journals from a table on the UCSD Map of Science
Journal colurmn Joumal Name {(Abbreviated) v || &
Dataset display name  FourNetSciResearchers.isi £
oK Cancel
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How to Read the UCSD Map

UCSD Science Map
with data overlay. —

Map legend of ——
circle area size
coding

Listing of all data —
records organized int
UCSD science areas.

Circle of non-located,
e.g., ‘Unclassified’
records.

Header and footer with
information when this
map was created, by
whom and using what
data set.

Listing and circle of
non-located, e.g.,
‘Unclassified’ records.
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Workshop Overview

1:30 Macroscope Design and Usage & CIShell Powered Tools: NWB & Sci2
1:45 Sci2 Tool Basics
» Download and run the tool.

2:00 Sci2 Sample Workflow: Padgett's Florentine Families - Prepare, load,
analyze, and visualize family and business networks from 15th century
Florence.

2:30 Sci2 Sample Workflow: Studying Four Major NetSci Researchers.

» Load and clean a dataset as text file; process raw data into networks.
»  Find basic statistics and run various algorithms over the network.

> Visualize as either a circular hierarchy or network

3:30 Break

4:00 Sci2 Demo I: Geospatial maps with congressional districts
4:30 Sci2 Demo 1I: Evolving collaboration networks

4:45 Outlook and Discussion

5:00 Adjonrn
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Sci2 Demo I:
Geospatial maps with congressional districts

A ) Identify Congressional District, Latitude, Longitude

1 Zipcode
2 90095 A B & D
3 2672 1 Zipcode Congressional District Latitude Longitude
2| 232930568 2 90035 CA-30 34.0735035 -118.6645815
5 10032 3 4672 ME-02 45.818717 -69.0290345
6 10039242 4 | 232980568 VA-03 37.270472  -77.0699835
7 46091500
8 191112434
9 27705 . . . .
L T Aggregate/Count identical Congressional Districts
e . | A [ I BV |
12 10065 1 |Congressional District Latitude Longitude Count
2 |CA-30 34.0735035 -118.6645815 4
3 |ME-02 45818717 -69.0290345 2
4 |VAO3 37.270472  -77.0699835 1
_5 |NY-15 40.8341475 -73.9342095 4

o7—Y

O

o . @9

O ‘

@
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e Aol for o

o e orbeience Relevant Sci2 Manual entry

B i furch & practice

£iome @ £ Tools -
1 Introduction 5.3.2 Congressional District Geocoder
& 2 Gefting Started &714 Added by Scolt Weingart Ias! edited by Ted Polley on Mar 28, 2011 (view change
@ 3 Algorithms, Tools,
and Plugins 2ip code.csv
& 4 Workflow Design
¢ Region(s) United States
= 5 Sample Workflows
@ 5.1 Indvidual Lavel Analysis Type(s) Geospatial Analaysis
Studies - Micro
# 5.2 Institution Level To visualize Congressional Districts you must first extract that data from a dataset containing either ZIF codes or
Studies - Meso You can the Cong i District G plugin here. You can load any file that contains
S 53 Global Leval 9.digit U.S. ZIP codes to be geocoded. A sample file can be loaded by using ‘File > Load and following this path
Studies - Macro ‘yoursic. Y @ P csv'. Load the file in Standard csv format. Then select the file in the data
5.3.1 Geo USPTD manager and use 'Analysis > Geospatial > Congressional Distnict Geocoder with the following parameters:
(SDB Data) p -
532¢C % Congressicnal District Geocod =&
District Geocoder
& & Sample Sdence Converts US, ZIP codes to congressional districts
Studies & Online
Sendces o
& 7 Extending the Sci2 Pisce Name Column [Zin.cade. i~ |H|
Tool B |!-—‘
# 8 Relevant Datasets
and Tools —
9 Referances E Carcel
Appendix 1 Glossary
Appendix 2 CIShell 5-digits ZIP codes with multiple congressional districts, empty entries and imvalid ZIP codes that failed to be geocoded
Algorithms will list in waming messages on the console. The output table contains all columns of the input table with three
Appendix 3 Sc2 columns app Cong district, latitude, and lengitude. To view the output table save the file
Release Notes 0.5 using ‘File > Save..." and selecting the desired save location (to view the file in Excel save it as a csv file). Once the
apha file has been saved it can be viewed with your choice of program. Below the file has been opened as a csv file
__- = = = = |
1 ;le code Congressional District Latitude Longitude
2 90035 CA-30 34.0735035 -118.6645815

bhitp:/ [ sci2.wiki.cns.iu.edn/ 5.3.2+ Congressional+ District+ Geocoder
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2| Relevant CIShell plugin

Sreifarch & practice

gggc | Sh Ql | Congressional District Geocoder £ Tools ~

&1 Added by Ted Polley, last edited by Chin Hua Kong on Mar 29, 2011 (view change)

Description
This algorithm converts the given 9-digits U.S. ZIP codes (ZIP+4 codes) into its congressiga g and geographical coordinates
(latitude and longitude). The Benchmark is 50,000 ZIP codes per second. Download the pl m@

Pros & Cons

1. The algorithm is using a local database mapping with 25MB file size. It will increase the application size dramatically. So it is build
as an external plugin

2. For first execution in the same application window, the plugin required 5 seconds to load the database. The consequent execution
will not required the pre-loading phase.

3. Since some 5-digits ZIP codes contain muttiple districts, the 9-digits ZIP codes is required for the conversion. Warning message will
be printed to notice user if the given 5-digits ZIP codes contain multiple districts

4. Congressional district might be varied by each election. The database would need to be maintained and updated relatively.

Applications

This plugin only support U.S. ZIP codes. It convert 9-digits ZIP codes to their belonging congressional district. It is an external plugin since
the data size is so large. The dataset is based on the year 2008 election.

bitp:/ [ cishell.wiki.cns.in.edn/ CongressionaltDistrict+ Geocoder
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Console Messages

A

Load... was selected.

Documentation: http://wiki.cns.iu.edu/display/ CISHELL/Data+Formats

Loaded: C:\Users\katy\Desktop \NWB-SCI2\sci2-2011.04.04-v0.5a\sampledata\geo\ zip code.csv
Congressional District Geocoder was selected.

Implementer(s): Chin Hua Kong

Integrator(s): Chin Hua Kong

Documentation: https://nwb.cns.iu.edu/community/?n=SampleData.CongressionalDistrictGeocoder

Input Parameters:

Place Name Column: Zip code

District values added to Congressional District, Latitude and Longitude respectively.

There are 2 rows with "33612" ZIP code, which could not been given a congressional district.
There are 1 rows with "2472" ZIP code, which could not been given a congressional district.
There are 3 rows with "10016" ZIP code, which could not been given a congressional district.
There are 1 rows with "11203" ZIP code, which could not been given a congressional district.
There are 1 rows with "60637" ZIP code, which could not been given a congressional district.
There are 1 rows with "70118" ZIP code, which could not been given a congressional district.
There are 1 rows with "60612" ZIP code, which could not been given a congressional district.
There are 3 rows with "21205" ZIP code, which could not been given a congressional district.
There are 1 rows with "2467" ZIP code, which could not been given a congtessional district.
5-digit ZIP codes may often be insufficient, as many zip codes contain multiple congressional districts. 9-digit zip codes may be required. If a
zip code was recently created, it may also not be contained in our database.

Successfully converted 86 out of 100 ZIP codes to congressional districts.
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Sci2 Demo I:
il Geospatial maps with congressional districts

Run Preprocessing > General > Aggregate Data’
using parameter values

 Aggegue v & |
Aggregate data in the table based on a column,
prpamcinn  (sinmea] ©)
| Zip code _NoM > L‘?J
Latitude [Average - [@]
— 1
Dielimiter for Congressional District | 'i]

(C0K ] [Coneel]

Note: Need lat/long for geomap.

Input Parameters:

Aggregate on column: Congressional District

Longitude: AVERAGE

Latitude: AVERAGE

Delimiter for Congressional District: |

Zip code: NONE

Aggregated by ": All rows of Latitude column were skipped due to no non-null, non-empty values.
Aggtegated by ": All rows of Longitude column were skipped due to no non-null, non-empty values.
Frequency of unique "Congressional District" values added to "Count" column.

"Zip code" column has been deleted from the output. Since No aggregation was mentioned for it.
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farch & practice

Create Geo Map (Circle Annotation)

Geo Map (Circle Annotations) was selected.
Author(s): Joseph R. Biberstine
Implementer(s): Joseph R. Biberstine
Integrator(s): Joseph R. Biberstine

Documentation: http:/ /wiki.cns.iu.edu/display/ CISHELL/Geo+Map

Input Parameters:

Longitude: Longitude

Size Circles By: CircleSize

Color Circle Exteriors By: None (no outer color)
Color Circle Interiors By: CircleSize
Exterior Color Scaling: Linear
Exterior Color Range: Yellow to Blue
Interior Color Range: Blue to Red
Size Scaling: Linear

Map: US States

Author Name:

Interior Color Scaling: Linear
Latitude: Latitude

14 rows in the table did not specify all values needed to make a circle; those rows were skipped.

Printing PostScript..
Done.

Saved: C:\Users\katy\Desktop\geoMaps2903082942930990749.ps

Save ps file, convert to pdf, view.

5| Geo Maps (circles) =
Creates a map with circle Circles are p d,
sized, and colored (inside and outside) according to columns in
the input table, Either or both kinds of coloring can also be
disabled. The table data for each dimension can be log-scaled
before processing.

Map i_ussmes > §| .
Author Name K. Borner §|
Latitude [Latitude ¢
Longtude [Longrude

Size Circles By i‘f.uunl

Size Scaling :_!-lﬂell

Color Circle Exteriors By | None (no outer colar)

Exterior Color Scaling

Esterior Color Range i_\"ell:mbo élue
Color Circle Interiors By |Count

Interior Color Scaling E\I.incll
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How to Read the Geo Map

L e e L

U.S. Map with

_—
data ovetlay.

Listing of map
type, author, and
parameters used.
E— G40 Map (Circle Annotation Style)
ABser Equil-Azes Cogic Projecsios

Age 10,2011 | 09:22:16 AM
K Bomes

Header and footer
with information

when this map
was created, by
whom and using
what data set.

Map legend with
color coding,

Ases Lisess «—

%, |
/ N
/|




Workshop Overview

1:30 Macroscope Design and Usage & CIShell Powered Tools: NWB & Sci2
1:45 Sci2 Tool Basics
»  Download and run the tool.

2:00 Sci2 Sample Workflow: Padgett's Florentine Families - Prepare, load,
analyze, and visualize family and business networks from 15th century
Florence.

2:30 Sci2 Sample Workflow: Studying Four Major NetSci Researchers.

» Load and clean a dataset as text file; process raw data into networks.
»  Find basic statistics and run various algorithms over the network.

> Visualize as either a circular hierarchy or network

3:30 Break

4:00 Sci2 Demo I: Geospatial maps with congressional districts

4:30 Sci2 Demo II: Evolving collaboration networks

4:45 Outlook and Discussion

5:00 Adjonrn
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Sci2 Demo II:
Evolving collaboration networks

ch & practice

Tandor Su Stonebraker Dantzich Thiel Dalal oyt
S Alkan e Larson Labow Fox
Paxson Wisnovsky Landay obibins o
Spelding oy, Munzner Weke FARIReh
Helerstem Crerwinski Hix
Konstan Woodft Exagovic Guimbretiers Feance
Baldonado
Beny Olston i Deline Brueni il
Kuchinsky
G Chi Gossweiler Fobertson Giager Nowell
Riedl - Hearst
Mackinkey Dishl o o Tanasse
Shoop Schank "
Ratzel Hahorsen Hatzler
Pedersen Tanev ‘Whitney
Lewis Chang Palli T
Badro sai : " Pitkow Fso
Fd arding garashi 2
Zhang Zelweger — Fusshail .
- amping
Price Stasko Kraamar o 0{-!upkms Senn
Callshan
; Burks
JAukhenea
Jones’ L Lucas
“Brown  Harrold \‘"?'““"l 5 B Kolojechick
shnson =
N Card Dunmine
& Botsfogo — Gomberg
sk j Gershon oldsten
* ‘Weiland
Rndin Shneiderman ek Chush Mafs Sofioling
o Bederson  'vaRenberg Jain . Hao G
" Herrmann Jevyal -
Fumnas Fiose Villemazn 2 Kerpedjiev
Hsu
North "
Zhang Plaisant Wil \:‘Mdm Seidl Kaim Derthick
= e Ahlberg - Schneidewind Hamison
Kriegel
. Doan
Zacks Tanin Noth  pange
Carr Beigel Wistrand Berchiolkd Moore
Ankerst
Legend Node Color Code Edge Color Code
0.9 g . -
Nodes ~ Authors toia &% — Mapping the Evolution of
Mo o S b o crbong ™ Pubksnied 2529 ppedt Co-Authorship Networks
e 0-3% I - Weimao Ke. Lalitha Visvanath & Katy Bomer
Edges ~ Co-authorship relations 40-40 InfoVis Lab @ Indiana University
Edge color ~ Year of first co-authorship s0. mmmmmmmm Uisplayed Year: 1988 2004
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Ria e Sci2 Demo II:

of

)

Science

Sl Evolving collaboration networks

b oisi v |44

Name Date modified Type Size

[I_;"m droVespig Fre ].3_;[3 wHisld.isi
|| FourNetSciResearchers.isi 4 LaszloBarabasi.isi
] StanleyWasserman.isi 4| TestSPapers.isi

As csv, file looks like:

A | B | c | b | E | F__ |[EEEs
_1 |Abstract Authors Authors (Full Names) 'Beginning Book Seri¢ Book Serie Cited Pate (
_2 |The systematic study of Colizza, V]Barrat, AlBarthelemy, M[Vespignani, A | 2015
3 |Uncovering the hidden r¢Colizza, VIFlammini, AlSerrano, MA[Vespignani, A 110
_4 |Computer viruses can s|Vespignani, A 135
_5 |Mapping the Intemet geiDall'’Asta, L|Alvarez-Hamelin, l[Barrat, AlVazquez, AlVespignani, A | 140 LECTURE NOTES IN

Visualize each time slide separately:

[ -

M sl

19901991
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RAtoal for

orlcience Relevant Sci2 Manual entry

= reidarch & practice

Hjoma £* Tools -
I aocichon 5.1.2 Time Slicing of Co-Authorship Networks (ISI Data)
# 2 Gefting Staried 76 Added by Ted Polley, last edited by Scolt Welngart on Mar 15, 2011 (vew change
¥ 3 Algonthms, Toals,
and Plugins AlessandroVespignan isi
& 4 Workflow Design
5 Sample Wondiows Time frame. 1990-2006
S 5.1 Indvidual Level Region(s) Indiana University, University of Rome, Yale University, Leiden Unharsity, Inemational Center for Thearstical Physics,
Studies - Micro University of Paris-Sud
2;"‘;:‘:&2!‘: Topical Areals) Informatics, Complex Network Science and System Research, Physics, Statistics, Epidemics
Putlication, and Analysis Type(s Co-Authorship Netwark
Funding Profiles hysie Typels) i
ofOne 5
Researcher The Sci* Tool supports the analysis of evohang networks. For this study. load Alessandro Vespignani's publication history from ES1. which can be
(Endiote and downloaded from Thomson's Wb of Science or loaded using ‘File > Load” and following thes path- ° i
NSF Data} AsitAlessandroVespignani isiusing ' Slice the data into five year intervals from 1390-2006 using Preprocessing > Temporal > Slice Table by Time' and the
5.1.2 Time Skcing following parameters:
ol Co
Wotworks 0151 =1 [ Sice Table by Time T o) e |
Data)
5.1.3 Funding Shce a table into groups of rows by bme.
Profiles of Three -
Researchers at = 1
Pfeipizin| Date/Time Column | Publication Year ||!
(NSF Data) —
514 Studying Cote/ilene foamt. § yryy &)
Four Major Net3d —
Researchers (151 Shice Into [veas - L-J
Data) —
 52instution Level How Many? 5 |!
Studies - Meso ==
& 5.3 Global Livel From Tine 19%0 |&)
Studies - Madie [ i
& 5 Sample Scence e 2008 |l
Studies & Onlne = el
< latrve 1
Serdces 4 Cloms S 'u
# 7 Edending the Sa2 1
7= | Align With Calendar |4
® § Relevant Datasets 1
and Toals i WeekStartsOn [Sundwy =] |!
9 References [ | |

bttp:/ [ sci2.wiki.cns.in.edu/ 5.1.2+ Time+S licing+of+ Co-Authorship+Networks+ (1S [+Data)
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ch & practice

Slice Table by Time

= A
W% Slice Table by Time @M
Slice a table into groups of rows by time.
Date/Time Column |Publkau'on Year > |
Date/Time Format  yyyy | ﬂ‘
Slice Into | Years el
"Slice Into” allows the user to slice the table by days, weeks, months, quarters, years, decades, and
How Many? 5 centuries. There are two additional parameters for time slicing: cumulative and align with calendar. The
former produces tables containing all data from the beginning to the end of each table's time interval, which
From Time 1290 can be seen in the Data Manager and below.
= D 101 Unique 151 Records
ToTime 2006 slice from beginning of 1990 to end of 2006 (101 records)
@] Cumulative? sbce&unbemoﬂmmendofm: (65 records)
| slice from beginning of 1990 to end of 1996 (26 records)
] Align With Calendar {71 shice from beginning of 1990 to end of 1991 (4 records)
Week Starts On Lsﬂ'i The latter option aligns the output tables according to calendar intervals
[EREH] 101 Unique ISI Records
- | slice from beginning of 2002 to end of 2006 (36 records)

™! slice from beginning of 1997 ta end of 2001 (39 records)
1 shice from beginning of 1992 to end of 1996 (22 records)
+1 slice from beginning of 1990 to end of 1991 (4 records)

Choosing "Years™ under "Slice Into” creates multiple tables beginning from January 1% of the first year. If
“Months® is chosen, it will start from the first day of the earliest month in the chosen time interval

bttp:/ [ sci2. wiki.cns.in.edu/ 5. 1.2+ Time+Shicing+of+Co-Authorship+Networks+ (1S1+Data)
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Visualize Each Network, Keep Node Positions

To see the evolution of Vespignani's co-authorship network over time, check ‘cumulative’.

Extract co-authorship networks one at a time for each sliced time table using 'Data

Preparation > Extract Co-Author Network', making sure to select "ISI" from the pop-up
window during the extraction.

To view each of the Co-Authorship Networks over time using the same graph layout,

begin by clicking on longest slice network (the 'Extracted Co-Authorship Network' under 'slice
Sfrom beginning of 1990 to end of 2006 (101 records)’) in the data manager. Visualize it in
GUESS using 'Visualization > Networks > GUESS'.

From here, run Layout > GEM' followed by "Layout > Bin Pack'. Run 'Script > Run Script

..."and select ' yoursci2directory/ scripts/ GUESS [ co-author-nw.py'.

In order to save the x, y coordinates of each node and to apply them to the other time

slices in GUESS, select 'File > Export Node Positions' and save the result as

"yoursci2directory/ NodePositions.csv'. Load the remaining three networks in GUESS using the
steps described above and for each network visualization, run 'File > Import Node Positions'
and open "yoursci2directory/ NodePositions.csv'.

To match the resulting networks stylistically with the original visualization, run 'Seripz >
Run Seript ..." and select "yoursci2directory/ seripts/ GUESS / co-author-nw.py', followed by 'Layout >
Bin Pack', for each.

bttp:/ [ sci2.wiki.cns.in.edu/ 5.1.2+ Time+S licing+of+ Co-Authorship+Networks+ (1S [+Data)
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““::‘.r'-s._..

1580-2001 1990-2006

bttp:/ [ sci2.wiki.cns.in.edn/ 5.1.2+ Time+ Slicing+of+ Co-Authorship+Networks+(1S1+Data)
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Relevant CIShell plugin
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Slice Table by Time £ Tools ~

&ClIShel
3

var L IDNE

Added by Argtha Alencar. last edited by Ted Polley on Jan 12, 2011 (yiew changa)

Description

Shice Table By Time is an algonthm to chop a table up into new tables, based on a dateftime column. |t takes the column with the date/time data, a string
describing the format of that column. the intervals that the data should be sliced into. whether or not the slices are cumalative, whether or not the slices should be
aligned with the calendar, and what day the week is considered to start on (which only matters if the slices are aligned with the calendar) as parameters

The column to use for dateftime values should have a langlc value for each row of data. It is used by the algosithm to choose which slice(s) the row should end up
in_ In order to d what d s reps d by that row, you must provide the al-gmhm with a descnptive format, in lha second pammm For instance,
a four digit year would be represented by yyyy (the default value) See hitp oda-t nel al/DateTimeFormat himl for
details of all the vanous formatting options.

The next dropdown has the available intenals to shce the table into. These include millisecends, seconds, minutes. hours, days, weeks, fortnights, manths,
quarters, years, decades, and centunes. A future version of the algorithm may include the ability to select how many of these intenals should be grouped together
at once

The checkbox that follows determines if the shces will be cumulative. I the slices are not cumulative, every row in the onginal table is in one and only one resulting
shce. However, if the shces are cumulative, evary row in the onginal table is in the slice it is for and every slice for a period after that

The checkbox that follows determines if the shces will be aligned with the calendar. For instance. if the first row is for June Tth, 2006 and yearly slices are chosen,
then the default behaior will be to have the first slice be from June Tth, 2006 to June 6th, 2007. However, if the slices are aligned with the calendar. the first slice
wall be from January 1st, 2006 to December 31st, 2006. Alignment does not affect the output for intervals of fortnights, quarters, decades, or milliseconds

I the slices are aligned with the calendar and are weekly, then the day the week stars is used to determing how they are aligned

Pros & Cons

The output of the slice algorithm is in separate tables, so a longitudinal analysis will require working with each slice separately, which can be awkward. There will
likely be future versions of the time slice algonthm that annctate the onginal table with the slice the rows belong to

Applications

When doing longitudinal analysis of data, it can be useful to consider it in chunks, such as to calculate how statistics have changed over time. Altematively. only a
particular time pericd might be of interest, and this algorithm can extract it from data for a karger time range

Implementation Details

This algonthm uses the Joda Time kbrary ively, which provides signil improved capabili P to the default Java algonthms for dates and
times

bttp:/ [ cishell.wiki.cns.iu.edn/ Slice+ Table+by+ Time
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Workshop Overview

1:30 Marcoscope Design and Usage & CIShell Powered Tools: NWB & Sci2
1:45 Sci2 Tool Basics
»  Download and run the tool.

2:00 Sci2 Sample Workflow: Padgett's Florentine Families - Prepare, load,
analyze, and visualize family and business networks from 15th century
Florence.

2:30 Sci2 Sample Workflow: Studying Four Major NetSci Researchers.

» Load and clean a dataset as text file; process raw data into networks.
»  Find basic statistics and run various algorithms over the network.

> Visualize as either a circular hierarchy or network

3:30 Break

4:00 Sci2 Demo I: Geospatial maps with congressional districts

4:30 Sci2 Demo 1I: Evolving collaboration networks

4:45 Marcoscopes: Outlook and Discussion

5:00 Adjonrn
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Spﬁ ST, Scholarly Database at Indiana University
bttp:/ [ sdb.wiki.cns.in.edu

w2~ 000N

Supports federated search of 25 million publication, patent, grant records.
Results can be downloaded as data dump and (evolving) co-author, paper-citation networks.

@ [SSEOLRLY DAIABASE & [SCHOLARLY DATABASE

=
Cptrenstrastsuctan fon Natmrk frsencs Covser, 518, {sbiana Urvermty, Blocengtun ‘i'q
= L.

Cyb far Center, SLIS, Indiana Univernity, Bloomington

T A R LML RNEES NN S A S Sy

. | Search | EditProfile | Admin | About | Logout
i Non-IU User
| Somomreeen, | e
by Search :_:;:.“F' h-ﬁ-o-mabu artarad in & fald, |r|:f.::!
o Creators:

Tithe:
Abstract: [FNA
Full Text:
First Year: | 1538 'I
Last ¥Year: | 2008 *l

ke s ' tieiline (1098 - 2008) ol

. Ly i (1981 - 2002 companed ts matching the te

F e (1ens - 2004)
F usero geze - zeery

B ,
|, SevooL oF Liasany @:
- AN [HFORMATICN SCIEHCE b

Register for free access at http://sdb.cns.iu.edu
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cholarly Database :: Results - Mozilla Firefox

Fle [Edt View Higtory Bookmarks Tools Help

W‘ C' 30 o) | L] | htpisssdb.sis.indiana.edufsearchiresuksrq=("artiicial inteligence”) 17 = '|marknv:kbmid1 P

2] Most Visted @ Getting Started . Latest Headines | | Hotel Kenigshof - Bod...

ﬂe'
|

R

A &

SCHOLARLY DATABASE]

Cyberinfrastructure for Network Science Center, SLIS, Indi Uni ity, Bl ington

-

Search ‘ Edit Profile ‘ Admin

Browse Results

[
About ‘ Logout |

Results 1 through 2

MNext>>

E Authors /

‘Your search returned 13,231 results in 0.295 seconds. | W/

0.

© ;

vi.- .

Total results per database: NIH: 2,103, Medline: 10,235, USPTO: 279, NSF: 614,

Year Tite

Medline LaCombe
Medline
Medline Schritt

Adlassnig

Medline Adlassnig

Medline Goldenbe

and

Medline Touretzky

g

1987 Artificial intelligence.

1989 Artificial i i @: expert sysh

1990 [Artificial intelligence in dentistry ]

2002 Artificial-i i e ted

Score (outof
5.71)

5.71
5.71
5.71

5.60

1980 Artificial intelligence.

1980 Artificial intelligence.

4.86
4.86 91

arly Database = Download - Mozilla Firefox

e Edt Wew Hatory Tock Heb

2l

artiicial AN U7 E,]-|mmm )

Q- ¢ X L [l

L) Most Visted e Getting Started . e

SCHO

Download Results

T selast all downloads,

Medline Database: =

I Madiine MasH hasding table
T Madline MasH qualifier table
I Madiine suthor table £

sl
I Madiing co-auther table (nvb farmat) L5
T Madline master tabla Lo

NIH Databas:

o
T wiH master tabla L0

NSF Databas:

T WSF cosinvestigator table(avb format) IE
-
T wsF mattar table

USPTO Database: -

™ usBTO Patent Cooparation Tresty table 0
T usPTO agent table
I usero aigignas table I"

I UseTo citation table (v format) 11

[T uspTO daims table L5

T USPTO corinvantor tabla (nwb Format) 2
T UsPTO inventer table Lol

7 UseTO mastar (burst format) (2

™ usPTO master table -

[ Downiosd |

LA

Cyberinfrastructure for Network Science Center, SLIS, Indiana University, Bloomingion

r T T
Search | EditProfie | Admin | About | Logout

Download |2Ell301] records starting st record |1 from the folloving databases:

RLY DATABASE]

Since March 2009:
Users can download networks:
Co-author

Co-investigator
Co-inventor

Patent citation

and tables for

burst analysis in NWB.

Fle Edt Vew Fovortes Took Heb | &
Qesd - () - T | Isesch || Folders |-
Address [ ) Di\sampledatalscientometricsisdd I Es
2| tame |
[ covrtog sk v ST
E : 1 uthor_table.csv | 0K
Resdiodeieyng E)Medine_co-author_table_(nwh_format),csv 627KB
29 Make 8 new folder EJMedine_master_table.csv 13,986...
) Publish this folder to the Emedine_MesH_headng_table.csv 3,453KB
Web S Medine_MeSH_qualfier_table.csv £53KB
E)NIH_master_table.csv 5,189 KB
Other Ploces i BENsF _co-nvestigator_table_(mwb_format).csv 19KB
SNsF _master_table.csv 1,303 KB
I scientometrice EJuseTO_ co-nventor_table_{rwh_format).csv 18KB
() My Documents EJUSPTO_sgent_table.cov 20k
& My Network Places H)UsPT0_sssignee_table.csv 23KB
S useTO_chation_table_(rwb_format).csv 7248
S UsPTO_invertor_table.csv 69KB
Details 2 HUSPTO_master_(burst_format).csv 08 K8
sdb E)UsPTo_master_table.csv ITKE
Fie Folder — EJuseto_patent_Cooperation_Treaty_table.csv 2KB
Date Modfied: Today, Apel
08, 2009, 1:28PM =14l | i

| Done

A
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Borner, Katy
Download Data

General Statistics Enabling a National
e Network of Scientists

c«amn;nmt — | General Statistics
S * 30 publication(s) from 2001 to 2010

¢ 80 co-author(s) from 2001 to 2010

Co-Author Network

Save as Image (PNG file)

Tables
* Publications per year

=1 =1 .

Tables

Co-authors

Yom

36 publication(s) from 2001 to 2010 : 3
: Enabling a National
Network of Scientists

80 co-author(s) from 2001 to 2010

Year Count Co-Author(s)

2001 1 Chen C

2002 3 Chen C.; McMahon T., Feng Y
2003 2/Chen C.; Boyack KW

2004 17 Sengupta A ; Penumarthy S.; Thakur S.; Sooriamurthi R.; Maru J.T.; Shiffrin R.M.; Mane I; Moor KA ;

-0 WNNN N

Co-author network

<xml version="1.0" encoding="UT ">
<graphml xmlns="http://graphml.graphdrawing.org/xmlns"

xmlns:xsi="http: //vwv.v3. org/2001 /ALSchema-instance”

%xsi:achemalocation="http: //graphml, graphdraving, org/xnlns

htep: //graphml . graphdrawving. org/xmlns/l.0/graphml . x3d">
<key id="label" for="node” attr.name="label” attr.type="string” />
<key id="number of authored works" for="node" attr.name="number of_ suthored works" attr.type="int" />
<key ids"num unknowm _publication” for="node” attr.name="num unknowm _publication” attr.types="int” />
<key id="num_latest publication” for="node"” attr.name="num latest publication” attr.types="int" />
<key id="latest_publication” for="node” attr.name="latest publication” attr.type="int" />
<key id="profile url"” for="node"” attr.name="profile url"” attr.type="string” />

'
2
3
4
5
6
7
8
vl
o
15

=

Save as Image (PNG file)
Publications per year , see top file.

Co-authors Count
i 1

Ben-Miled Z
Blackwell A
Boyack K'W.
Bozicevic M
Brodbeck D.
Burkhard R.A
Chen C
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'| || CIShell — Integrate New Algorithms

About the Cyberinfrastructure Shell Learn More...

The Cyberinfrastructure Shell (CIShell) is an open source, community-driven platform for the + CiShell Papers
integration and utilization of datasets, algorithms, tools, and computing resources. Algorithm = Ci h_” Powered Tools
integration support is built in for Java and most other programming languages. Being Java based, + Algorithms

it will run on almost all platforms. The software and specification is released under an Apache 2.0 * Plugins {comin il

= Misc, Tool Documentation
+ CIShell Web Services (coming soon)

CIShell is the basis of Metwork Waorkbench, TexTrend, Sci® and the upcoming EpiC tool « Screenshots

CIShell supports remote execution of algorithms. A standard web senvice definition is in
development that will allow pools of algorithms to transparently be used in a peer-to-peer, client- Getting Started
server, or web front-end fashion.

License.

« Documentation & Developer Resources
= Download

CIShell Features
Getting Involved...

A framework for easy integration of new and existing algorithms written
in any programming language » Contact Us

Using CIShell, an algorithm writer can fully concentrate on creating their own algonithm in whatever
language they are comfortable with. Simple tools are provided to then take their algorithm and

CIShell Developer Guide is at )itip:/ / cishell.wiki.cns.in.edu

Additional Sci2 Plugins are 4/}1‘{1): sci2.wikt.cns.in.edn/ 3.2+ Additional+ Plugins
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Cytoscape

@ —~1 .
%:’C I She ' " CIShell — Add new Plugins, e.g., Cytoscape

Adding more alyout algorithms and network visualization interactivity

via Cytoscape http://www.cytoscape.org.

Simply add org.textrend.visnalization.cytoscape_0.0.3.jar into your /plugin directory.
Restart Sci2 Tool.

Cytoscape now shows in the Visualization Menu.

Cytoscape was selected, Geospatial » | -
Integrator(s): TexTrend Consortium (http://www.textrend  Networks » hpis (TexTrend, i1l 361 Unique ISI Records

Universitas Press) COREE I %", Extracted Co-Authorship Network
Reference: Cytoscape Consortium (http://www.cytoscapel M' = E—| Author informati

C:\DOCUME~1\bornerk|L OCALS~1Temp|CIShel-Session-6885247 785800266799 StaticExecut able
Runner-20687 18271488870377\algorithm >echo of f

cytoscape. Cytoscapelnit[INFO]: Cytoscapelnt static initialization

cytoscape. Cytoscapelnit[INFO]: Parent_Dir: C:\Documents and Settings\bornerk),.cytoscape
created.

Select a network in Data Manager, run Cytoscape and the tool will start with this
network loaded.

97

& Cytoscape Desktop (New Session)
File Edt View Select Layout Pluginse Help

BE ARG B BE [ |- 8]

| Control Panel = B Network
T Network VizMapper™ | Editor | Fiters

Data Panel =
HOW Ol
o

. ———

Node Attribute Browser | Edge Attribute Browser | Network Attribute Browser |
‘Welcome to Cytoscape 2.6.2 Right-click + drag to ZOOM Middie-click + drag to PAN




& Cytoscape Desktop (New Session)
File E[ﬂ View Seh(t Layout

T —c

_| Control Panel Align and Distribute | I - FXPEIAT ==
4 Network mw ‘ EIE'@
Settings... |
Network |

| Edge-weighted Force directed (BioLayout) »

Data Panel

HOW =
o |

Mo

. Node Attribute Browser | Edge Attribute Browser = Network Attribute Browser

Welcomne to Cytoscape 2.6.2 Right-click + drag to ZOOM Middle-chick + drag to PAN
o2a C Lo . .
Re? (|She | 0sGi/Cishell Adoption

A number of other projects recently adopted OSGi and/or CIShell:

Cytoscape (bitp:/ [ cytoscape.org) Led by Trey Ideker at the University of California, San Diegois an
open source bioinformatics software platform for visualizing molecular interaction networks
and integrating these interactions with gene expression profiles and other state data (Shannon
et al., 2002).

> Taverna Workbench (bttp:/ / taverna.ors.nk) Developed by the myGtid team
(http://mygrid.org.uk) led by Carol Goble at the University of Manchester, UK. is a free
software tool for designing and executing workflows (Hull et al., 2006). Taverna allows users
to integrate many different software tools, including over 30, 000 web services.

» MAEuviz (bttps:/ [ wiki.ncsa.ninc.edu/ display/ MAE / Hopse) Managed by Jong Lee at NCSA is an
open-source, extensible software platform which supports seismic risk assessment based on
the Mid-America Earthquake (MAE) Center research.

> TEXTrend (bitp:/ [ texctrend.org) Led by George Kampis at E6tvos Lorand University, Budapest,
Hungary supports natural language processing (NLP), classification/mining, and graph
algorithms for the analysis of business and governmental text corpuses with an inherently
temporal component.

> DynaNets (http:/ [ wwmw.dynanets.org) Coordinated by Peter M.A. Sloot at the University of
Amsterdam, The Netherlands develops algorithms to study evolving networks.

As the functionality of OSGi-based software frameworks improves and the number and

diversity of dataset and algorithm plugins increases, the capabilities of custom tools will expand.
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National Office for

Home Publicat

Project leader
IGeorge Kampis, PhD, DSc

University Press Ltd.

TEXTREND: Development of a business and governmental decision support
toolbox using trend- and text-analysis tools

The two interconnected objectives of the TEXTrend project are (1) the creation of
an integrated TEXTrend toolkit and service basis, and (2) the elaboration of
demonstrative applications in varied fields of business and governmental
decisions, exemplified by use cases.

Team leader: Gegrae Kampis, PhD, DSc
Gydray Fabri, PhD, CSc
;<716 Gulyas, Phe
Sandor Sods, PhD
Zalan Szakolezi, BSc
Zoltan Szaszi, BSc

HCCI Research Institute of Economics

Istvan Graf, MSc

and Enterprises e Rorrvay t
Team leader: Istvdn Jdngs Téth, PhD """'““ al: “n“‘“ 2 Yecarmes
lignes Czibik, MSc P e o e
lagnes Makd, MSc e A - N b
Tamas Uhrin, MSc o] iy
= = e ? Samacn opte e Solwice
Zoltan Varhalmi, MS¢ ' e
T s
Glia Computer Consulting Ltd. ety pisy A g awtectoa sopey
Team leader: Attila Bencsik, MSc Auctiraiony Fonwe Depar
Rita Adam, MSc Retvmmnti =
Henriett Baai, BSc o R ety
Yewnice

- stk exseenanes. »

toolkit trend

analysis

download o
leader .« network phd
research science
team ... textrend
UNiVersity ver
Created at

http:fftagcrowd.com

Created by
www.wordle.net

TEXTrend adds R bridge, WEKA, Wordij, CFinder, and more.

See the latest versions of TEXTrend Toolkit modules at
bhitp:/ [ textrend.org/ index.phpZoption=com _content>view=articled>id=47 < ltemid=53

101

R Help
=0

i Data Manager-:

visualization of epidemic processes. -~

The Epif he NIH RM-07-004 d. Th
man] File [Compartmental Modeling] Networ "% S 97 0% fmed The
Create a compartmental model
The Epi : hintan Tank, Joseph Biberstine,
Chin Hd| | Weld Edit compartmental model ng, a

MNetwork Science Center (httpy//cns.slis.indi

I e

| EpiC uses the Cyberinfrastructure Shell (http://cishell.org) developed at the Cyberinfrastructure for

Help

Please cite as follows: i
| EpiC Team. (2009). EpiC Tool. Indiana Univer§|

Exact
Network

Single-Population

‘ ! Algorithm Name

& Scheduler |
[Remve From st | Remve compleed automatclly | Remove ll o (Veustestion] R _Help
i Line Graph

Date Time

% Complet
TPEYR] Help

Create an R Instance
| Run Rgui
.! Import Table Into R
| Export Table From R
S
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cyberinfrastructure for
ETWORK SCIENCE CENTER

All papers, maps, tools, talks, press are linked from http://cns.iu.edu

CNS Facebook: http://www.facebook.com/cnscenter
Mapping Science Exhibit Facebook: http://www.facebook.com/mappingscience




