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The Changing Scientific Landscape

Star Scientist -> Research Teams: In former times, science was driven by key scientists. Today, science is driven 
by effectively collaborating co-author teams often comprising expertise from multiple disciplines and several y y g p g p p p
geospatial locations (Börner, Dall'Asta, Ke, & Vespignani, 2005; Shneiderman, 2008).

Users -> Contributors: Web 2.0 technologies empower anybody to contribute to Wikipedia and to exchange 
images and videos via Fickr and YouTube. WikiSpecies, WikiProfessionals, or WikiProteins combine wiki and 
semantic technology in support of real time community annotation of scientific datasets (Mons et al., 2008). 

Cross-disciplinary: The best tools frequently borrow and synergistically combine methods and techniques from 
d d d d d/different disciplines of science and empower interdisciplinary and/or international teams of researchers, 
practitioners, or educators to fine-tune and interpret results collectively. 

One Specimen -> Data Streams: Microscopes and telescopes were originally used to study one specimen at a 
time. Today, many researchers must make sense of massive streams of multiple types of data with different 
formats, dynamics, and origin.  

St ti In tr m nt > E l in C b rinfr tr t r (CI) Th i p t f h d i t t th tStatic Instrument -> Evolving Cyberinfrastructure (CI): The importance of hardware instruments that are 
rather static and expensive decreases relative to software infrastructures that are highly flexible and 
continuously evolving according to the needs of different sciences. Some of the most successful services and 
tools are decentralized increasing scalability and fault tolerance.

Modularity: The design of software modules with well defined functionality that can be flexibly combined helps 
reduce costs, makes it possible to have many contribute, and increases flexibility in tool development, , p y , y p ,
augmentation, and customization.

Standardization: Adoption of standards speeds up development as existing code can be leveraged. It helps pool 
resources, supports interoperability, but also eases the migration from research code to production code and 
hence the transfer of research results into industry applications and products.

Open data and open code: Lets anybody check, improve, or repurpose code and eases the replication of scientific 
studies.



Desirable Features of Plug-and-Play Macroscopes

Division of Labor: Ideally, labor is divided in a way that the expertise and skills of computer 
scientists are utilized for the design of standardized modular easy to maintain and extend “corescientists are utilized for the design of standardized, modular, easy to maintain and extend core 
architecture”. Dataset and algorithm plugins, i.e., the “filling”, are initially provided by those that 
care and know most about the data and developed the algorithms: the domain experts. 

Ease of Use: As most plugin contributions and usage will come from non-computer scientists it must 
be possible to contribute, share, and use new plugins without writing one line of code. Wizard-
driven integration of new algorithms and data sets by domain experts sharing via email or onlinedriven integration of new algorithms and data sets by domain experts, sharing via email or online 
sites, deploying plugins by adding them to the ‘plugin’ directory, and running them via a Menu 
driven user interfaces (as used in Word processing systems or Web browsers) seems to work well.  

Plugin Content and Interfaces: Should a plugin represent one algorithm or an entire tool? What 
about data converters needed to make the output of one algorithm compatible with the input of 
h ? Sh ld h b f h l i h l i h ld h b k d l ?the next? Should those be part of the algorithm plugin or should they be packaged separately? 

Supported (Central) Data Models: Some tools use a central data model to which all algorithms 
conform, e.g., Cytoscape, see Related Work section. Other tools support many internal data 
models and provide an extensive set of data converters, e.g., Network Workbench, see below. 
The former often speeds up execution and visual rendering while the latter eases the integration p p g g
of new algorithms. In addition, most tools support an extensive set of input and output formats. 

Core vs. Plugins: As will be shown, the “core architecture” and the “plugin filling” can be 
implemented as sets of plugin bundles. Answers to questions such as: “Should the graphical user 
interface (GUI), interface menu, scheduler, or data manager be part of the core or its filling?” will 
depend on the type of tools and services to be delivered.depend on the type of tools and services to be delivered. 

Supported Platforms: If the software is to be used via Web interfaces then Web services need to be 
implemented. If a majority of domain experts prefers a stand-alone tool running on a specific 
operating system then a different deployment is necessary.

Project Details

Investigators: Katy Börner, Albert-Laszlo Barabasi, Santiago Schnell, 
Alessandro Vespignani & Stanley Wasserman, Eric Wernert 

Software Team: Lead: Micah Linnemeier
Members: Patrick Phillips, Russell Duhon, Tim Kelley & Ann McCranie
Previous Developers: Weixia (Bonnie) Huang, Bruce Herr, Heng Zhang, 
Duygu Balcan, Bryan Hook, Ben Markines, Santo Fortunato, Felix 
Terkhorn, Ramya Sabbineni, Vivek S. Thakre & Cesar Hidalgo

Goal: Develop a large-scale network analysis, modeling and visualization toolkitGoal: Develop a large scale network analysis, modeling and visualization toolkit 
for physics, biomedical, and social science research. 

Amount: $1,120,926, NSF IIS-0513650 award
Duration: Sept. 2005 - Aug. 2009  

Website: http://nwb slis indiana edu
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Project Details (cont.)

NWB Advisory Board:

James Hendler (Semantic Web) http://www.cs.umd.edu/~hendler/James Hendler (Semantic Web)  http://www.cs.umd.edu/ hendler/

Jason Leigh (CI)  http://www.evl.uic.edu/spiff/

Neo Martinez (Biology)  http://online.sfsu.edu/~webhead/

Michael Macy, Cornell University (Sociology)
http://www.soc.cornell.edu/faculty/macy.shtml

Ulrik Brandes (Graph Theory)  http://www.inf.uni-konstanz.de/~brandes/

Mark Gerstein, Yale University (Bioinformatics)  http://bioinfo.mbb.yale.edu/

Stephen North (AT&T) http://public research att com/viewPage cfm?PageID=81Stephen North (AT&T)  http://public.research.att.com/viewPage.cfm?PageID=81

Tom Snijders, University of Groningen  http://stat.gamma.rug.nl/snijders/

Noshir Contractor, Northwestern University http://www.spcomm.uiuc.edu/nosh/
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Resources

Publications
o http://nwb slis indiana edu/pub htmlo http://nwb.slis.indiana.edu/pub.html

Community Wiki, Tutorials, FAQ
o https://nwb.slis.indiana.edu/community
o http://nwb slis indiana edu/doc htmlo http://nwb.slis.indiana.edu/doc.html
o GUESS Manual http://guess.wikispot.org/manual

Software
htt // i h llo http://cishell.org

o http://nwb.slis.indiana.edu/download.html

Developer ResourcesDeveloper Resources

o http://cns-trac.slis.indiana.edu/trac/nwb
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Outline

1. Exemplary Network Science Research by NWB PIs
• Computational Proteomics• Computational Proteomics
• Computational Economics
• Computational Social Science
• Computational ScientometricsComputational Scientometrics
• Computational Epidemics

2. NWB Tool Challenges and Opportunities

3. NWB Tool Overview

4 NWB Tool for Scientometrics Research4. NWB Tool for Scientometrics Research 

5. Discussion of Future Work 
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Computational Proteomics
What relationships exist between protein targets of all drugs and allWhat relationships exist between protein targets of all drugs and all 
disease-gene products in the human protein–protein interaction network?

Yildriim, Muhammed 

A., Kwan-II Goh, 

Michael E CusickMichael E. Cusick, 

Albert-László Barabási, 

and Marc Vidal. (2007). 

Drug-target Network. g g

Nature Biotechnology 

25 no. 10: 1119-1126.
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Computational Economics
Does the type of product that a yp p
country exports matter for 
subsequent economic performance? 

C A Hidalgo B KlingerC. A. Hidalgo, B. Klinger, 

A.-L. Barabási, R. Hausmann 

(2007) The Product Space 

Conditions the Development 

of Nations. Science 317, 

482 (2007).

Computational Social Science
Studying large scale socialStudying large scale social 
networks such as Wikipedia

Vizzards 2007 Entry

Second Sight: An Emergent 
Mosaic of Wikipedian Activity, 
The NewScientist, May 19, 2007



113 Years of

Computational Scientometrics
113 Years of 
Physical 
Review

Br ce W Herr IIBruce W. Herr II 
and Russell 
Duhon (Data 
Mining & 
Visualization)Visualization), 
Elisha F. Hardy 
(Graphic 
Design), 
ShashikantShashikant 
Penumarthy 
(Data 
Preparation) 
and Katy Börnerand Katy Börner 
(Concept)

Computational Epidemics
Forecasting (and preventing the effects of) the next pandemic.Forecasting (and preventing the effects of) the next pandemic.

Epidemic Modeling in Complex realities, V. Colizza, A. Barrat, M. Barthelemy, A.Vespignani, Comptes 
Rendus Biologie, 330, 364-374 (2007).

Reaction-diffusion processes and metapopulation models in heterogeneous networks, V.Colizza, R. 
Pastor-Satorras, A.Vespignani, Nature Physics 3, 276-282 (2007).

Modeling the Worldwide Spread 
of Pandemic Influenza: Baselineof Pandemic Influenza: Baseline 
Case and Containment 
Interventions, V. Colizza, A. 
Barrat, M. Barthelemy, A.-J. 
Valleron, A.Vespignani, 
PloS-Medicine 4, e13, 95-110 
(2007).
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2. NWB Challenges and Opportunities

o Data
• Different data formats

• Different data models

o Algorithmso Algorithms
• Different research purposes (preprocessing, modeling, analysis, 

visualization, clustering)

• Different implementations of the same algorithmp g

• Different programming languages

• Algorithm developers/users are not computer scientists

o Different tools (Pajek, UCINet, Guess, Cytoscape, R, …)o Different tools (Pajek, UCINet, Guess, Cytoscape, R, …)

o Different communities, practices, cultures
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NWB Deliverables

Network Workbench (NWB) Tool
o A network analysis, modeling, and visualization toolkit for physics, y g p y

biomedical, and social science research. 

o Install and run on multiple Operating Systems. 

o Supports many file formats.

o Easy integration of new algorithms thanks to CIShell/OSGi.

Cyberinfrastructure Shell (CIShell)
 An open source software framework for the integration and utilization of An open source, software framework for the integration and utilization of 

datasets, algorithms, tools, and computing resources.
 Extends OSGi industry standard. 
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CIShell – Serving Non-CS Algorithm 
Developers & UsersDevelopers & Users

Developers Users

CIShell
IVC InterfaceCIShell Wizards

NWB Interface
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CIShell – Builds on OSGi 
Industry StandardIndustry Standard

CIShell is built upon the Open Services Gateway Initiative (OSGi) Framework. 

OSGi (http://www.osgi.org) isOSGi (http://www.osgi.org) is 
o A standardized, component oriented, computing environment for networked 

services. 
o Successfully used in the industry from high-end servers to embedded 

mobile devices since 8 yearsmobile devices since 8 years.
o Alliance members include IBM (Eclipse), Sun, Intel, Oracle, Motorola, NEC 

and many others.
o Widely adopted in open source realm, especially since Eclipse 3.0 that uses 

OSGi R4 for its plugin modelOSGi R4 for its plugin model.

Advantages of Using OSGi
o Any CIShell algorithm is a service that can be used in any OSGi-framework 

based systembased system.
o Using OSGi, running CIShells/tools can connected via RPC/RMI supporting 

peer-to-peer sharing of data, algorithms, and computing power.

C S f OSG S f
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Ideally, CIShell becomes a standard for creating OSGi Services for algorithms. 



NWB Deliverables

Network Workbench (NWB) Tool
o A network analysis, modeling, and visualization toolkit for physics, y g p y

biomedical, and social science research. 

o Install and run on multiple Operating Systems. 

o Supports many file formats.

o Easy integration of new algorithms thanks to CIShell/OSGi.

Cyberinfrastructure Shell (CIShell)
 An open source software framework for the integration and utilization of

NWB Community Wiki

 An open source, software framework for the integration and utilization of 
datasets, algorithms, tools, and computing resources.

 Extends OSGi industry standard. 

NWB Community Wiki
 A place for users of the NWB Tool, the Cyberinfrastructure Shell (CIShell), 

or any other CIShell-based program to request, obtain, contribute, and 
share algorithms and datasets. 
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 All algorithms and datasets that are available via the NWB Tool have been 
well documented in the Community Wiki.

Network Workbench Tool
http://nwb.slis.indiana.edup

The Network Workbench (NWB) tool 

35,000 in Aug 09
( )

supports researchers, educators, and 
practitioners interested in the study of  
biomedical, social and behavioral science, 
physics, and other networks. 

In Aug. 2009, the tool provides more 160 
plugins that support the preprocessing, 
analysis, modeling, and visualization of  
networks. 

More than 40 of  these plugins can be 
applied or were specifically designed for 
S&T studies. 

It h b d l d d r th 35 000It has been downloaded more than 35,000 
times since Dec. 2006.

18

Herr II, Bruce W., Huang, Weixia (Bonnie), Penumarthy, Shashikant & Börner, Katy. (2007). Designing Highly Flexible and Usable 
Cyberinfrastructures for Convergence. In Bainbridge, William S. & Roco, Mihail C. (Eds.), Progress in Convergence - Technologies for Human 
Wellbeing (Vol. 1093, pp. 161-179), Annals of  the New York Academy of  Sciences, Boston, MA. 
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https://nwb.slis.indiana.edu/community/

NWB Tool: Supported Data Formats

Personal Bibliographies
 Bibtex (.bib) 

Network Formats
 NWB (.nwb) 

 Endnote Export Format (.enw) 

Data Providers
 Web of  Science by Thomson Scientific/Reuters (.isi)
 Scopus by Elsevier ( scopus)

 Pajek (.net) 
 GraphML (.xml or 

.graphml) 
 XGMML (.xml) 

 Scopus by Elsevier (.scopus)
 Google Scholar (access via Publish or Perish save as CSV, Bibtex, 

EndNote)
 Awards Search by National Science Foundation (.nsf)

Burst Analysis Format
 Burst (.burst)

O h FScholarly Database (all text files are saved as .csv)
 Medline publications by National Library of  Medicine 
 NIH funding awards by the National Institutes of  Health 

(NIH)
 NSF f di d b h N i l S i F d i (NSF)

Other Formats 
 CSV (.csv) 
 Edgelist (.edge) 
 Pajek (.mat) 
 T ML ( l) NSF funding awards by the National Science Foundation (NSF)

 U.S. patents by the United States Patent and Trademark Office 
(USPTO)

 Medline papers – NIH Funding

 TreeML (.xml)

20



NWB Tool: Algorithms (July 1st, 2008)
See https://nwb.slis.indiana.edu/community and handout for details.

21

NWB Tool: Output Formats

 NWB tool can be used for data conversion. Supported output formats comprise:

 CSV (.csv) ( )

 NWB (.nwb) 

 Pajek (.net) 

 Pajek ( mat) Pajek (.mat) 

 GraphML (.xml or .graphml) 

 XGMML (.xml) 

 GUESS

Supports export of images into pp p g

common image file formats.

 Horizontal Bar Graphs

22

 Horizontal Bar Graphs 

 saves out raster and ps files.



Demo

Network Workbench (http://nwb.slis.indiana.edu).                                                                                                                           23

NWB Tool Overview

1. Download, install, and run.

2. Load, view, convert, save data.

3. Read and visualize a directory hierarchy.

4. Load a network, compute its basic properties, and explore it in GUESS., p p p , p
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NWB Tool Overview

1. Download, install, and run.

2. Load, view, convert, save data.

3. Read and visualize a directory hierarchy.

4. Load a network, compute its basic properties, and explore it in GUESS., p p p , p
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Download, install, and run

Goto http://nwb.slis.indiana.edu

NWB Tool 1.0.0
Select your operating system 
from the pull down menu.

Save as *.jar file.

Install and run.

Session log files are stored in 
‘*yournwbdirectory*/logs’ 
directory.
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NWB Tool Interface Components
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File, Preprocessing, Modeling, and Visualization Menus
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Analysis Menu 
and Submenus
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Integrated Tools

Gnuplot GUESSGnuplot

portable command-line driven 
interactive data and function 
plotting utility 

exploratory data analysis and visualization 
tool for graphs and networks. 

https://nwb.slis.indiana.edu/community/?n
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http://www.gnuplot.info/. =VisualizeData.GUESS. 



Supported Data Formats

In November 2008, the NWB tool supports loading the following input file formats:
 GraphML (*.xml or *.graphml)
 XGMML (*.xml)
 Pajek .NET (*.net) & Pajek .Matrix (*.mat)
 NWB (*.nwb)
 TreeML (*.xml)
 Edge list (*.edge)
 CSV (*.csv) CSV ( .csv)
 ISI (*.isi)
 Scopus (*.scopus)
 NSF (*.nsf)
 Bibtex (*.bib)
 Endnote (* enw) Endnote (*.enw)

and the following network file output formats:
 GraphML (*.xml or *.graphml)
 Pajek .MAT (*.mat)
 Pajek .NET (*.net)
 NWB (*.nwb)
 XGMML (*.xml)
 CSV (*.csv)

Th f t d t d t
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These formats are documented at 
https://nwb.slis.indiana.edu/community/?n=DataFormats.HomePage. 

NWB Ecology of  Data Formats and Converters 

Not shown are 15 sample datasets, 45 data preprocessing, analysis, modeling and visualization 
algorithms 9 servicesalgorithms, 9 services.

13 613 6
Supported Output formats
data for diverse visualization 
formats algorithms

88
Intermediate 
data formats 

Supported by

35
d t tdata converters.





Sample Datasets

The ‘*yournwbdirectory*/sampledata’ directory provides sample datasets from the 
biology, network, scientometics, and social science research domains:

/biology
/network
/scientometrics
/scientometrics/bibtex
/scientometrics/csv
/scientometrics/endnote
/scientometrics/isi/scientometrics/isi
o FourNetSciResearchers.isi
/scientometrics/nsf
o Cornell.nsf

The blue ones areo Indiana.nsf
o Michigan.nsf
/scientometrics/scopus
/socialscience

The blue ones are 
used in this tutorial.
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/socialscience
o florentine.nwb

Property Files and Python Scripts

The ‘*yournwbdirectory*/” directory also contains

/sampledata/scientometrics/properties    // Used to extract networks and merge datap p p g
o bibtexCoAuthorship.properties
o endnoteCoAuthorship.properties
o isiCoAuthorship.properties
o isiCoCitation.properties
o isiPaperCitation.properties
o mergeBibtexAuthors.properties
o mergeEndnoteAuthors.properties
o mergeIsiAuthors.properties

fo mergeNsfPIs.properties
o mergeScopusAuthors.properties
o nsfCoPI.properties
o scopusCoAuthorship.properties

/sampledata/scripts/GUESS // Used to do color/size/shape code networks 
o co-author-nw.py
o co-PI-nw.py
o paper-citation-nw.py
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o paper citation nw.py
o reference-co-occurrence-nw.py



NWB Tool Overview

1. Download, install, and run.

2 L d i t d t2. Load, view, convert, save data.

3. Read and visualize a directory hierarchy.

4. Load a network, compute its basic properties, and explore it in GUESS.
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Load, View and Save (Convert) Data

Use 'File > Load File' to load florentine.nwb in sample datasets in

‘*yournwbdirectory*/sampledata/socialscience’.y y p

The loaded file will appear in

the Data Manager windowthe Data Manager window.

Right click loaded file to save, 

view, rename, or discard.

Network Workbench (http://nwb.slis.indiana.edu).                                                                                                                           38



Data Converter Graph

There is no central 
data format.data format.

Instead, data formats 
used in differentused in different 

communities and 
required by the 

different algorithmsdifferent algorithms 
are supported. 
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NWB Tool Overview

1. Download, install, and run.

2 L d i t d t2. Load, view, convert, save data.

3. Read and visualize a directory hierarchy.

4. Load a network, compute its basic properties, and explore it in GUESS.
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Reading and Visualizing a 
Directory HierarchyDirectory Hierarchy

Use ‘File > Read Directory Hierarchy’ with parameters

Visualize resulting ‘Directory Tree - Prefuse (Beta) Graph’ using 

• ‘Visualization > Tree View (prefuse beta)’(p )

• ‘Visualization > Tree Map (prefuse beta)’

• ‘Visualization > Balloon Graph (prefuse alpha)’

• ‘Visualization > Radial Tree/Graph (prefuse alpha)’

Network Workbench (http://nwb.slis.indiana.edu).                                                                                                                           41

• Visualization > Radial Tree/Graph (prefuse alpha)

Different views of 
the /nwb directory 
hierarchyhierarchy.

Note the size of the 
/plugin directory./plugin directory.
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NWB Tool Overview

1. Download, install, and run.

2. Load, view, convert, save data.

3. Read and visualize a directory hierarchy.

4. Load a network, compute its basic properties, and explore it in GUESS., p p p , p
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Compute Basic NW Properties 
& View in GUESS& View in GUESS

Select florentine.nwb in Data Manager.
o Run ‘Analysis > Network Analysis Toolkit (NAT)’ to get basic properties.

o Optional: Run ‘Analysis -> Unweighted & Undirected -> Node 
Betweenness Centrality’ with default parameters.

o Select network and run ‘Visualization > GUESS’ to open GUESS with file 
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p
loaded.

o Apply ‘Layout -> GEM’.



Pan:
“grab” the 
background by 
holding left-click and 
moving your mouse.

Zoom:
Using scroll wheel, g ,
press the “+” and “-” 
buttons in the upper-
left hand corner, or 
right-click and move 
th l ftthe mouse left or 
right. Center graph 
by selecting ‘View -> 
Center’.

Select        to 
select/move single 
nodes Hold downnodes. Hold down 
‘Shift’ to select 
multiple.

Right click to modify
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Right click to modify 
Color, etc.



Graph Modifier:
Select “all nodes” in 
the Object drop-down j p
menu and click ‘Show 
Label’ button. 

Select “nodes based 
on ->”, then select 
“wealth” from the 
Property drop-down 
menu, “>=” from the 
Operator drop downOperator drop-down 
menu, and finally type 
“50” into the Value box. 
Then a color/size/
shape code
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shape code.

Interpreter:Interpreter:
Uses Jython a 
combination of Java 
and Python.

Try
colorize(wealth, 
white, red)
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resizeLinear(sitebet
weenness, 5, 25) 



Workflow Design Primerg

Modularity at data preprocessing/analysis/modeling level.y p p g/ y / g

Modularity at visualization level:

 ‘Data Layers’ are used in GIS systems to support the visual 
layering and coordination of different datasets, e.g., water pipes, 
streets electricity lines etcstreets, electricity lines, etc.  

 ‘Design Layers’ supported by graphic design software such as 
Photoshop or Dreamweaver enable the separate design and 
modular composition of design elements.

 ‘Visualization Layers’ define distinct parts with very specific 
functionality that collectively define a visualizationfunctionality that collectively define a visualization. 

BREAK



Exemplary Analyses and Visualizationsp y y

Individual Level
A. Loading ISI files of major network science researchers, extracting, analyzing 

and visualizing paper-citation networks and co-author networks.
B. Loading NSF datasets with currently active NSF funding for 3 researchers at g g

Indiana U

Institution Level
C. Indiana U, Cornell U, and Michigan U, extracting, and comparing Co-PI 

networks.

Scientific Field Level
D. Extracting co-author networks, patent-citation networks, and detecting 

bursts in SDB data.

Exemplary Analyses and Visualizationsp y y
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bursts in SDB data.



Data Acquisition from Web of Science

Download all papers by

 Eugene Garfield

 Stanley Wasserman

 Alessandro Vespignani Alessandro Vespignani

 Albert-László Barabási

from

 S i Ci i I d Science Citation Index 

Expanded (SCI-EXPANDED)

--1955-present 

 Social Sciences Citation Index 
(SSCI)--1956-present 

 Arts & Humanities Citation 
Index (A&HCI)--1975-present 

Comparison of Counts
No books and other non-WoS publications are covered.

Age Total # Cites Total # Papers H-Index

Eugene Garfield 82 1,525 672 31

Stanley Wasserman 122 35 17Stanley Wasserman 122 35 17

Alessandro Vespignani 42 451 101 33

Albert-László Barabási 40 2,218 126 47    (Dec 2007)

41 16,920 159 52    (Dec 2008)



Network Extraction
Sample paper network (left) and p p p ( )
four different network types derived from it (right)

From ISI files, about 30 different networks can be extracted.

Extract Co-Author Network

Load*yournwbdirectory*/sampledata/scientometrics/isi/FourNetSciResearchers.isi’ 

using 'File > Load and Clean ISI File'.

To extract the co-author network, select the ‘361 Unique ISI Records’ table and run

'Scientometrics > Extract Co-Author Network’ using isi file format:g

The result is an undirected network of co-authors in the Data Manager. It has 247

nodes and 891 edges. 

To view the complete network, select the network and run ‘Visualization > 

GUESS > GEM’. Run Script > Run Script… . And select Script folder > GUESS >p p p f

co-author-nw.py.



Comparison of Co-Author Networks

Eugene Garfield Stanley Wasserman

Alessandro Vespignani Albert-László Barabási

Joint Co-Author Network of all Four NetsSci Researchers



Paper-Citation Network Layout

Load ‘*yournwbdirectory*/sampledata/scientometrics/isi/FourNetSciResearchers.isi’ using 
'File > Load and Clean ISI File'.File  Load and Clean ISI File .

To extract the paper-citation network, select the ‘361 Unique ISI Records’ table and run 
'Scientometrics > Extract Directed Network' using the parameters:

The result is a directed network of paper citations in the Data Manager. It has 5,335 
nodes and 9,595 edges. 

To view the complete network, select the network and run ‘Visualization > GUESS’.
Run ‘Script > Run Script …’ and select ‘yournwbdirectory*/script/GUESS/paper-citation-nw.py’.



Exemplary Analyses and Visualizationsp y y

Individual Level
A. Loading ISI files of major network science researchers, extracting, analyzing 

and visualizing paper-citation networks and co-author networks.
B. Loading NSF datasets with currently active NSF funding for 3 researchers at g g

Indiana U

Institution Level
C. Indiana U, Cornell U, and Michigan U, extracting, and comparing Co-PI 

networks.

Scientific Field Level
D. Extracting co-author networks, patent-citation networks, and detecting 

bursts in SDB data.

NSF Awards Search via http://www.nsf.gov/awardsearch

Save in CSV format as *name*.nsf



NSF Awards Search Results

Name # Awards First A. Starts Total Amount to Date

Geoffrey Fox 27 Aug 1978 12,196,260

Michael McRobbie 8 July 1997 19,611,178

Beth Plale 10 Aug 2005 7 224 522Beth Plale 10 Aug 2005 7,224,522

Di l iDisclaimer:
Only NSF funding, no funding in which they were senior personnel, only as good as NSF’s internal 
record keeping and unique person ID. If there are ‘collaborative’ awards then only their portion of the 

j ( d) ill b i l d dproject (award) will be included.

Using NWB to Extract Co-PI Networks

 Load into NWB, open file to count records, compute total award amount.

 Run ‘Scientometrics > Extract Co-Occurrence Network’ using parameters:

 S l “E d N k ” d ‘A l i N k A l i T lki Select “Extracted Network ..” and run ‘Analysis > Network Analysis Toolkit 
(NAT)’

 Remove unconnected nodes via ‘Preprocessing > Delete Isolates’.

 ‘Visualization > GUESS’ , layout with GEM

 Run ‘co-PI-nw.py’ GUESS script to color/size code.



Geoffrey Fox

Michael McRobbie

Beth Plale



Geoffrey Fox Last Expiration date

July 10

Michael McRobbieMichael McRobbie 

Feb 10

Beth Plale

Sept 09Sept 09

Exemplary Analyses and Visualizationsp y y

Individual Level
A. Loading ISI files of major network science researchers, extracting, analyzing 

and visualizing paper-citation networks and co-author networks.
B. Loading NSF datasets with currently active NSF funding for 3 researchers at g g

Indiana U

Institution Level
C. Indiana U, Cornell U, Michigan U, and Stanford U extracting, and 

comparing Co-PI networks.

Scientific Field Level
D. Extracting co-author networks, patent-citation networks, and detecting 

bursts in SDB data.



NSF Awards Search via http://www.nsf.gov/awardsearch

Save in CSV format as *institution*.nsf

Active NSF Awards on 11/07/2008:

 Indiana University 257 
(there is also Indiana University at South Bend Indiana University Foundation, Indiana University Northwest, Indiana 
University-Purdue University at Fort Wayne, Indiana University-Purdue University at Indianapolis, Indiana y y y , y y p ,
University-Purdue University School of Medicine)

 Cornell University 501 
(there is also Cornell University – State, Joan and Sanford I. Weill Medical College of Cornell University)

 University of Michigan Ann Arbor  619 
(there is also University of Michigan Central Office, University of Michigan Dearborn, University of Michigan Flint,  
University of Michigan Medical School)

Active NSF Awards on 09/10/2009:

 Stanford University  429 

Save files as csv but rename into .nsf.
O i l th fil d i ‘* bdi t */ pl d t / i t t i / f/’Or simply use the files saved in ‘*yournwbdirectory*/sampledata/scientometrics/nsf/’.



Extracting Co-PI Networks

Load NSF data, selecting the loaded dataset in the Data Manager window, run
‘Scientometrics > Extract Co-Occurrence Network’ using parameters:

Two derived files will appear in the Data Manager window: the co-PI network and a 
merge table. In the network, nodes represent investigators and edges denote their co-
PI relationships. The merge table can be used to further clean PI names. 

R i h ‘A l i > N t k A l i T lkit (NAT)’ l h h b fRunning the ‘Analysis > Network Analysis Toolkit (NAT)’ reveals that the number of 
nodes and edges but also of isolate nodes that can be removed running ‘Preprocessing > 
Delete Isolates’. 

Select ‘Visualization > GUESS’ to visualize. Run ‘co-PI-nw.py’ script.

Indiana U: 223 nodes, 312 edges, 52 components

U of Michigan: 497 nodes, 672 edges, 117 c

Cornell U: 375 nodes, 573 edges, 78 c



Extract Giant ComponentExtract Giant Component

Select network after removing isolates and run ‘Analysis > 
Unweighted and Undirected > Weak Component Clustering’  with parameter 

Indiana’s largest component has 19 nodes Cornell’s has 67 nodesIndiana s largest component has 19 nodes, Cornell s has 67 nodes, 
Michigan’s has 55 nodes.

Visualize Cornell network in GUESS using same .py script and save 
via ‘File > Export Image’ as jpg.

Largest component of 
Cornell U co-PI network

Node size/color ~ totalawardmoney
Top-50 totalawardmoney nodes are labeled.



Top-10 Investigators by Total Award MoneyTop 10 Investigators by Total Award Money

for i in range(0, 10):

print str(nodesbytotalawardmoney[i] label) + ": " +print str(nodesbytotalawardmoney[i].label) + :  + 
str(nodesbytotalawardmoney[i].totalawardmoney)

Indiana University
Curtis Lively: 7,436,828

Frank Lester: 6,402,330

M d Th 6 402 330

Cornell University
Maury Tigner: 107,216,976

Sandip Tiwari: 72,094,578

S l G 48 469 991

Michigan University
Khalil Najafi: 32,541,158

Kensall Wise: 32,164,404

J l E l 25 890 711Maynard Thompson: 6,402,330

Michael Lynch: 6,361,796

Craig Stewart: 6,216,352

William Snow: 5 434 796

Sol Gruner: 48,469,991

Donald Bilderback: 47,360,053

Ernest Fontes: 29,380,053

Hasan Padamsee: 18 292 000

Jacquelynne Eccles: 25,890,711

Georg Raithel: 23,832,421

Roseanne Sension: 23,812,921

Theodore Norris: 23 35 0921William Snow: 5,434,796

Douglas V. Houweling: 5,068,122

James Williams: 5,068,122

Miriam Zolan: 5,000,627

Hasan Padamsee: 18,292,000

Melissa Hines: 13,099,545

Daniel Huttenlocher: 7,614,326

Timothy Fahey: 7,223,112

Theodore Norris: 23,35,0921

Paul Berman: 23,350,921

Roberto Merlin: 23,350,921

Robert Schoeni: 21,991,140

Carla Caceres: 5,000,627 Jon Kleinberg: 7,165,507 Wei-Jun Jean Yeung:21,991,140

Stanford University
429 active NSF awards on 09/10/2009

2000                         2015



Largest component 
39 nodes39 nodes

Stanford U:
218 nodes, 285 edges, 49 components 
157 isolate nodes were deleted



Top-10 Investigators by Total Award MoneyTop 10 Investigators by Total Award Money

for i in range(0, 10):

print str(nodesbytotalawardmoney[i] label) + ": " +print str(nodesbytotalawardmoney[i].label) + :  + 
str(nodesbytotalawardmoney[i].totalawardmoney)

Stanford University
Dan Boneh: 11,837,800

Rajeev Motwani: 11,232,154

H G i M li 10 577 906Hector Garcia-Molina: 10,577,906

David Goldhaber-Gordon: 9,792,029

Kathryn Moler: 7,870,029

John C. Mitchell: 7 290 668John C. Mitchell: 7,290,668

Alfred Spormann: 6,803,000

Gordon Brown: 6,158,000

Jennifer Widom: 5,661,311

Search for all active NSF awards by Northwestern University on 9/2/2009 via

http://www.nsf.gov/awardsearch



Nodes: 323, Edges: 313, Average 
degree: 1.9, 149 weakly connected 

(107 i l )components. (107 isolates)

Giant component has 63 nodes, 
Color and size coding by total award 
money

3. Exemplary Analyses and Visualizationsp y y

Individual Level
A. Loading ISI files of major network science researchers, extracting, analyzing 

and visualizing paper-citation networks and co-author networks.
B. Loading NSF datasets with currently active NSF funding for 3 researchers at g g

Indiana U

Institution Level
C. Indiana U, Cornell U, and Michigan U, extracting, and comparing Co-PI 

networks.

Scientific Field Level
D. Extracting co-author networks, patent-citation networks, and detecting 

bursts in SDB data.



Goto: http://sdb.slis.indiana.edu
Email: nwb@indiana.edu

Password: nwb

http://sdb slis indiana edu

Network Workbench (http://nwb.slis.indiana.edu).                                                                                                                           84

http://sdb.slis.indiana.edu



Network Workbench (http://nwb.slis.indiana.edu).                                                                                                                           85

Open and Preprocess SDB zip file

Load medline_medline_master.csv to NWB.

Run ‘Preprocessing > Normalize Text’ with 

a space as New Separator.

Network Workbench (http://nwb.slis.indiana.edu).                                                                                                                           86



Burst Analysis

Run ‘Analysis > Textual > Burst Detection’ with parameters:

and space as a separator.

Sort result by burst weight

|| 

V

Word Length Weight Strength Start EndWord Length Weight Strength Start End

care 1 Infinity Infinity 1988 1988

water 1 29.8883 29.8883 2002 2002

countri 10 27.03612 27.03612 1990 1999

protect 1 26.88557 26.88557 2002 2002

farm 1 23.32114 23.32114 2005 2005

villag 2 23.273 40.65081 2008

crop 2 22.33649 30.42535 2008

Network Workbench (http://nwb.slis.indiana.edu).                                                                                                                           87

educ 2 22.14556 26.98588 1995 1996

blood 5 22.12166 22.12166 1996 2000

Medcline Co-





Bonus:  Sci2 Tool

Sci2 Tool



Blondel Community Detection
Ci l Hi hCircular Hierarchy



File > Load
“worldfactbook.csv”





http://sci.slis.indiana.edu

All papers, maps, cyberinfrastructures, talks, press are linked 
from http://cns.slis.indiana.edu


