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Outline

1. Exemplary Network Science Research by NWB PIs
 Computational Proteomics Computational Proteomics
 Computational Economics
 Computational Social Science
 Computational Scientometrics Computational Scientometrics
 Computational Epidemics

2. NWB Tool Challenges and Opportunities

3. NWB Tool Overview

4 NWB Tool for Scientometrics Research4. NWB Tool for Scientometrics Research 

5. Discussion of Future Work 
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Computational Proteomics
What relationships exist between protein targets of all drugs and allWhat relationships exist between protein targets of all drugs and all 
disease-gene products in the human protein–protein interaction network?

Yildriim, Muhammed 

A., Kwan-II Goh, 

Michael E CusickMichael E. Cusick, 

Albert-László Barabási, 

and Marc Vidal. (2007). 

Drug-target Network. g g

Nature Biotechnology 

25 no. 10: 1119-1126.
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Computational Economics
Does the type of product that a yp p
country exports matter for 
subsequent economic performance? 

C A Hidalgo B KlingerC. A. Hidalgo, B. Klinger, 

A.-L. Barabási, R. Hausmann 

(2007) The Product Space 

Conditions the Development 

of Nations. Science 317, 

482 (2007).



Computational Social Science
Studying large scale socialStudying large scale social 
networks such as Wikipedia

Vizzards 2007 Entry

Second Sight: An Emergent 
Mosaic of Wikipedian Activity, 
The NewScientist, May 19, 2007

113 Years of

Computational Scientometrics
113 Years of 
Physical 
Review

Br ce W Herr IIBruce W. Herr II 
and Russell 
Duhon (Data 
Mining & 
Visualization)Visualization), 
Elisha F. Hardy 
(Graphic 
Design), 
ShashikantShashikant 
Penumarthy 
(Data 
Preparation) 
and Katy Börnerand Katy Börner 
(Concept)



Computational Epidemics
Forecasting (and preventing the effects of) the next pandemic.Forecasting (and preventing the effects of) the next pandemic.

Epidemic Modeling in Complex realities, V. Colizza, A. Barrat, M. Barthelemy, A.Vespignani, Comptes 
Rendus Biologie, 330, 364-374 (2007).

Reaction-diffusion processes and metapopulation models in heterogeneous networks, V.Colizza, R. 
Pastor-Satorras, A.Vespignani, Nature Physics 3, 276-282 (2007).

Modeling the Worldwide Spread 
of Pandemic Influenza: Baselineof Pandemic Influenza: Baseline 
Case and Containment 
Interventions, V. Colizza, A. 
Barrat, M. Barthelemy, A.-J. 
Valleron, A.Vespignani, 
PloS-Medicine 4, e13, 95-110 
(2007).
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2. NWB Challenges and Opportunities

 Data
 Different data formats

 Different data models

 Algorithms Algorithms
 Different research purposes (preprocessing, modeling, analysis, 

visualization, clustering)

 Different implementations of the same algorithmp g

 Different programming languages

 Algorithm developers/users are not computer scientists

 Different tools (Pajek, UCINet, Guess, Cytoscape, R, …) Different tools (Pajek, UCINet, Guess, Cytoscape, R, …)

 Different communities, practices, cultures
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NWB Deliverables

Network Workbench (NWB) Tool
 A network analysis, modeling, and visualization toolkit for physics, y g p y

biomedical, and social science research. 

 Install and run on multiple Operating Systems. 

 Supports many file formats.

 Easy integration of new algorithms thanks to CIShell/OSGi.

Cyberinfrastructure Shell (CIShell)
 An open source software framework for the integration and utilization of An open source, software framework for the integration and utilization of 

datasets, algorithms, tools, and computing resources.
 Extends OSGi industry standard. 
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CIShell – Serving Non-CS Algorithm Developers & Users

Developers Users

CIShell
IVC InterfaceCIShell Wizards

NWB Interface
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CIShell – Builds on OSGi Industry Standard

CIShell is built upon the Open Services Gateway Initiative (OSGi) Framework. 

OSGi (http://www.osgi.org) isOSGi (http://www.osgi.org) is 
 A standardized, component oriented, computing environment for networked 

services. 
 Successfully used in the industry from high-end servers to embedded 

mobile devices since 8 yearsmobile devices since 8 years.
 Alliance members include IBM (Eclipse), Sun, Intel, Oracle, Motorola, NEC 

and many others.
 Widely adopted in open source realm, especially since Eclipse 3.0 that uses 

OSGi R4 for its plugin modelOSGi R4 for its plugin model.

Advantages of Using OSGi
 Any CIShell algorithm is a service that can be used in any OSGi-framework 

based systembased system.
 Using OSGi, running CIShells/tools can connected via RPC/RMI supporting 

peer-to-peer sharing of data, algorithms, and computing power.

C S f OSG S f
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Ideally, CIShell becomes a standard for creating OSGi Services for algorithms. 

NWB Deliverables

Network Workbench (NWB) Tool
 A network analysis, modeling, and visualization toolkit for physics, y g p y

biomedical, and social science research. 

 Install and run on multiple Operating Systems. 

 Supports many file formats.

 Easy integration of new algorithms thanks to CIShell/OSGi.

Cyberinfrastructure Shell (CIShell)
 An open source software framework for the integration and utilization of

NWB Community Wiki

 An open source, software framework for the integration and utilization of 
datasets, algorithms, tools, and computing resources.

 Extends OSGi industry standard. 

NWB Community Wiki
 A place for users of the NWB Tool, the Cyberinfrastructure Shell (CIShell), 

or any other CIShell-based program to request, obtain, contribute, and 
share algorithms and datasets. 
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 All algorithms and datasets that are available via the NWB Tool have been 
well documented in the Community Wiki.
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https://nwb.slis.indiana.edu/community/
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NWB Tool Release (Nov 2008) 

Major features in v1.0.0 beta 2 Release

 Installs and runs on Windows Linux and Mac OS X Installs and runs on Windows, Linux and Mac OS X.

 Provides over 80 modelling, analysis and visualization algorithms. Half of them 
are written in Fortran, others in Java.

 Supports large scale network modelling and analysis for certain workflows Supports large scale network modelling and analysis for certain workflows 
(over 100,000 nodes)

 Supports several visualization layouts with node/edge annotation.

 Provides several sample datasets with various formats Provides several sample datasets with various formats. 

 Supports multiple ways to introduce a network to the NWB tool.

 Supports automatic data conversion.

 Provides a Scheduler to monitor and control the progress of running Provides a Scheduler to monitor and control the progress of running 
algorithms.

 Integrates a 2D plotting tool – Gnuplot (requires pre-installation on Linux and 
Mac).
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)

 Integrates GUESS graph exploration/visualization tool.

Demo
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NWB Tool Overview

1. Download, install, and run.

2. Load, view, convert, save data.

3. Read and visualize a directory hierarchy.

4. Load a network, compute its basic properties, and explore it in GUESS., p p p , p
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Download, install, and run

Goto http://nwb.slis.indiana.edu

NWB Tool 1.0.0 beta 2
(development release)
November 19th, 2008

Select your operating system from 
the pull down menu.

Save as *.jar file.

Install and run.

Session log files are stored in 
‘*yournwbdirectory*/logs’ directory.
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yournwbdirectory /logs  directory.

NWB Tool Interface Components
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File, Preprocessing, Modeling, and Visualization Menus
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Analysis Menu and Submenus
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Integrated Tools

Gnuplot GUESSGnuplot

portable command-line driven 
interactive data and function 
plotting utility 

exploratory data analysis and visualization 
tool for graphs and networks. 

https://nwb.slis.indiana.edu/community/?n
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http://www.gnuplot.info/. =VisualizeData.GUESS. 

Supported Data Formats

In November 2008, the NWB tool supports loading the following input file formats:
 GraphML (*.xml or *.graphml)
 XGMML (*.xml)
 Pajek .NET (*.net) & Pajek .Matrix (*.mat)
 NWB (*.nwb)
 TreeML (*.xml)
 Edge list (*.edge)
 CSV (*.csv) CSV ( .csv)
 ISI (*.isi)
 Scopus (*.scopus)
 NSF (*.nsf)
 Bibtex (*.bib)
 Endnote (* enw) Endnote (*.enw)

and the following network file output formats:
 GraphML (*.xml or *.graphml)
 Pajek .MAT (*.mat)
 Pajek .NET (*.net)
 NWB (*.nwb)
 XGMML (*.xml)
 CSV (*.csv)

Th f t d t d t
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These formats are documented at 
https://nwb.slis.indiana.edu/community/?n=DataFormats.HomePage. 



NWB Ecology of  Data Formats and Converters 

Not shown are 15 sample datasets, 45 data preprocessing, analysis, modeling and visualization 
algorithms 9 servicesalgorithms, 9 services.

13 613 6
Supported Output formats
data for diverse visualization 
formats algorithms

88
Intermediate 
data formats 

Supported by

35
d t tdata converters.



Sample Datasets

The ‘*yournwbdirectory*/sampledata’ directory provides sample datasets from the 
biology, network, scientometics, and social science research domains:

/biology
/network
/scientometrics
/scientometrics/bibtex
/scientometrics/csv
/scientometrics/endnote
/scientometrics/isi/scientometrics/isi
 FourNetSciResearchers.isi
/scientometrics/nsf
 Cornell.nsf

The blue ones are Indiana.nsf
 Michigan.nsf
/scientometrics/scopus
/socialscience

The blue ones are 
used in this tutorial.
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/socialscience
 florentine.nwb



Property Files and Python Scripts

The ‘*yournwbdirectory*/” directory also contains

/sampledata/scientometrics/properties    // Used to extract networks and merge datap p p g
 bibtexCoAuthorship.properties
 endnoteCoAuthorship.properties
 isiCoAuthorship.properties
 isiCoCitation.properties
 isiPaperCitation.properties
 mergeBibtexAuthors.properties
 mergeEndnoteAuthors.properties
 mergeIsiAuthors.properties

f mergeNsfPIs.properties
 mergeScopusAuthors.properties
 nsfCoPI.properties
 scopusCoAuthorship.properties

/sampledata/scripts/GUESS // Used to do color/size/shape code networks 
 co-author-nw.py
 co-PI-nw.py
 paper-citation-nw.py
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 paper citation nw.py
 reference-co-occurrence-nw.py

NWB Tool Overview

1. Download, install, and run.

2 L d i t d t2. Load, view, convert, save data.

3. Read and visualize a directory hierarchy.

4. Load a network, compute its basic properties, and explore it in GUESS.
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Load, View and Save (Convert) Data

Use 'File > Load File' to load florentine.nwb in sample datasets in

‘*yournwbdirectory*/sampledata/socialscience’.y y p

The loaded file will appear in

the Data Manager windowthe Data Manager window.

Right click loaded file to save, 

view, rename, or discard.
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Data Converter Graph

There is no central 
data format.data format.

Instead, data formats 
used in differentused in different 

communities and 
required by the 

different algorithmsdifferent algorithms 
are supported. 
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NWB Tool Overview

1. Download, install, and run.

2 L d i t d t2. Load, view, convert, save data.

3. Read and visualize a directory hierarchy.

4. Load a network, compute its basic properties, and explore it in GUESS.
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Reading and Visualizing a Directory Hierarchy

Use ‘File > Read Directory Hierarchy’ with parameters

Visualize resulting ‘Directory Tree - Prefuse (Beta) Graph’ using 

• ‘Visualization > Tree View (prefuse beta)’(p )

• ‘Visualization > Tree Map (prefuse beta)’

• ‘Visualization > Balloon Graph (prefuse alpha)’

• ‘Visualization > Radial Tree/Graph (prefuse alpha)’
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• Visualization > Radial Tree/Graph (prefuse alpha)



Different views of 
the /nwb directory 
hierarchyhierarchy.

Note the size of the 
/plugin directory./plugin directory.
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NWB Tool Overview
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Compute Basic NW Properties & View in GUESS

Select florentine.nwb in Data Manager.
 Run ‘Analysis > Network Analysis Toolkit (NAT)’ to get basic properties.

 Optional: Run ‘Analysis > Unweighted & Undirected > Node Optional: Run Analysis -> Unweighted & Undirected -> Node 
Betweenness Centrality’ with default parameters.

 Select network and run ‘Visualization > GUESS’ to open GUESS with file 
loaded.
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 Apply ‘Layout -> GEM’.



Pan:
“grab” the 
background by 
holding left-click and 
moving your mouse.

Zoom:
Using scroll wheel, g ,
press the “+” and “-” 
buttons in the upper-
left hand corner, or 
right-click and move 
th l ftthe mouse left or 
right. Center graph 
by selecting ‘View -> 
Center’.

Select        to 
select/move single 
nodes Hold downnodes. Hold down 
‘Shift’ to select 
multiple.

Right click to modify
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Right click to modify 
Color, etc.

Graph Modifier:
Select “all nodes” in 
the Object drop-down j p
menu and click ‘Show 
Label’ button. 

Select “nodes based 
on ->”, then select 
“wealth” from the 
Property drop-down 
menu, “>=” from the 
Operator drop downOperator drop-down 
menu, and finally type 
“50” into the Value box. 
Then a color/size/
shape code
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shape code.



Interpreter:Interpreter:
Uses Jython a 
combination of Java 
and Python.

Try
colorize(wealth, 
white, red)
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resizeLinear(sitebet
weenness, 5, 25) 

NWB Tool for Scientometrics Research

1. Loading NSF datasets with currently active NSF funding for Indiana U, 
Cornell U, and Michigan U, extracting, and comparing Co-PI networks.

2 L di ISI fil f j t k i h t ti2. Loading ISI files of major network science researchers, extracting, 
analyzing and visualizing paper-citation networks and co-author 
networks.

3. Loading text files and detecting Bursts.

Network Workbench (http://nwb.slis.indiana.edu).                                                                                                                           44



NWB Tool for Scientometrics Research

1. Loading NSF datasets with currently active NSF funding for Indiana U, 
Cornell U, and Michigan U, extracting, and comparing Co-PI networks.

2 L di ISI fil f j t k i h t ti2. Loading ISI files of major network science researchers, extracting, 
analyzing and visualizing paper-citation networks and co-author 
networks.

3. Loading text files and detecting Bursts.
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Analyzing NSF Data

Download NSF awards data from http://www.nsf.gov/awardsearch/
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Analyzing NSF Data 

Active NSF Awards on 11/07/2008:

 Indiana University 257 
(there is also Indiana University at South Bend Indiana University Foundation, Indiana University 
Northwest, Indiana University-Purdue University at Fort Wayne, Indiana University-Purdue University at 
Indianapolis Indiana University Purdue University School of Medicine)Indianapolis, Indiana University-Purdue University School of Medicine)

 Cornell University 501 
(there is also Cornell University – State, Joan and Sanford I. Weill Medical College of Cornell University)

 University of Michigan Ann Arbor 619 University of Michigan Ann Arbor  619 
(there is also University of Michigan Central Office, University of Michigan Dearborn, University of 
Michigan Flint,  University of Michigan Medical School)

Save files as csv but rename into .nsf.

Or simply use the files saved in 
‘* o rn bdirector */sampledata/scientometrics/nsf/’
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‘*yournwbdirectory*/sampledata/scientometrics/nsf/’.

Analyzing NSF Data 

Extracting Co-PI Networks

Load NSF data, selecting the loaded dataset in the Data Manager window, run
‘Scientometrics > Extract Co-Occurrence Network’ using parameters:

Two derived files will appear in the Data Manager window: the co-PI network and a 
merge table. In the network, nodes represent investigators and edges denote their 
co-PI relationships. The merge table can be used to further clean PI names. 

Running the ‘Analysis > Network Analysis Toolkit (NAT)’ reveals that the number of 
nodes and edges but also of isolate nodes that can be removed running 
‘Preprocessing > Delete Isolates’. 
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Select ‘Visualization > GUESS’ to visualize. Run ‘co-PI-nw.py’ script.



Indiana U: 223 nodes, 312 edges, 52 components
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U of Michigan: 497 nodes, 672 edges, 117 c

Cornell U: 375 nodes, 573 edges, 78 c

Select network after removing isolates and run ‘Analysis > Unweighted and 

Undirected > Weak Component Clustering’  with parameter p g p

Indiana’s largest component has 19 nodes, Cornell’s has 67 nodes, 
Michigan’s has 55 nodes.

Visualize Cornell network in GUESS using same .py script and save via 
‘File > Export Image’ as jpg.
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Largest component of 
Cornell U co-PI network

Node size/color ~ totalawardmoney
Top-50 totalawardmoney nodes are labeled.

Top-10 investigators by total award money

for i in range(0, 10):

print str(nodesbytotalawardmoney[i].label) + ": " + str(nodesbytotalawardmoney[i].totalawardmoney)

Indiana University
Curtis Lively: 7,436,828

Frank Lester: 6,402,330

Maynard Thompson: 6,402,330

Cornell University
Maury Tigner: 107,216,976

Sandip Tiwari: 72,094,578

Sol Gruner: 48,469,991

Michigan University
Khalil Najafi: 32,541,158

Kensall Wise: 32,164,404

Jacquelynne Eccles: 25,890,711y p , ,

Michael Lynch: 6,361,796

Craig Stewart: 6,216,352

William Snow: 5,434,796

Douglas V Houweling: 5 068 122

, ,

Donald Bilderback: 47,360,053

Ernest Fontes: 29,380,053

Hasan Padamsee: 18,292,000

Melissa Hines: 13 099 545

q y , ,

Georg Raithel: 23,832,421

Roseanne Sension: 23,812,921

Theodore Norris: 23,35,0921

Paul Berman: 23 350 921Douglas V. Houweling: 5,068,122

James Williams: 5,068,122

Miriam Zolan: 5,000,627

Carla Caceres: 5,000,627

Melissa Hines: 13,099,545

Daniel Huttenlocher: 7,614,326

Timothy Fahey: 7,223,112

Jon Kleinberg: 7,165,507

Paul Berman: 23,350,921

Roberto Merlin: 23,350,921

Robert Schoeni: 21,991,140

Wei-Jun Jean Yeung:21,991,140
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NWB Tool for Scientometrics Research

1. Loading NSF datasets with currently active NSF funding for Indiana U, 
Cornell U, and Michigan U, extracting, and comparing Co-PI networks.

2 L di ISI fil f j t k i h t ti2. Loading ISI files of major network science researchers, extracting, 
analyzing and visualizing paper-citation networks and co-author 
networks.

3. Loading text files and detecting Bursts.
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Data Acquisition from Web of Science

Download all papers by

 Eugene Garfield

 Stanley Wasserman

 Alessandro Vespignani

 Albert-László Barabási

from

 Science Citation Index 
Expanded (SCI-
EXPANDED)--1955-
present 

 Social Sciences Citation 
Index (SSCI) 1956Index (SSCI)--1956-
present 

 Arts & Humanities 
Citation Index (A&HCI)--
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( )
1975-present 



Data Acquisition from Web of Science (cont.)q ( )

Eugene Garfield

1,525 papers

# papers/citations for 
last 20 years
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Data Acquisition from Web of Science (cont.)q ( )

Can download 500 records max.

Exclude Current Contents articles

Include only articles. Download 99 articles.
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Data Acquisition from Web of Science (cont.)q ( )
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Data Acquisition from Web of Science (cont.)

Stanley Wasserman

35 papers

# papers/citations for 
last 20 years
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Data Acquisition from Web of Science (cont.)

Alessandro Vespignani

101 papers

# papers/citations for 
last 20 years
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Data Acquisition from Web of Science (cont.)

Albert-László Barabási

126 papers

# papers/citations for 
last 20 years
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Comparison of Counts

Age Total # Cites Total # Papers H-Index

Eugene Garfield 82 1,525 672 31

Stanley Wasserman 122 35 17

Alessandro Vespignani 42 451 101 33

Albert-László Barabási 40 2,218 126 47    (Dec 2007)( )

41 16,920 159 52    (Nov 2008)
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Extract Co-Author Network

Load*yournwbdirectory*/sampledata/scientometrics/isi/FourNetSciResearchers.isi’ 

using 'File > Load and Clean ISI File'.

To extract the co-author network, select the ‘361 Unique ISI Records’ table and run

'Scientometrics > Extract Co-Author Network’ using isi file format:

The result is an undirected network of co-authors in the Data Manager. It has 248

nodes and 891 edges. g

To view the complete network, select the network and run ‘Visualization > 

GUESS > GEM’. Run Script > Run Script… . And select Script folder > GUESS >

co-author-nw.py .
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py



Network of Wasserman, Vespignani and Barabási
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Comparison of Ego-Centric Co-Author Networks

Eugene Garfield Stanley Wasserman

Alessandro Vespignani Albert-László Barabási
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Paper-Citation Network Layout

Load ‘*yournwbdirectory*/sampledata/scientometrics/isi/FourNetSciResearchers.isi’ 
using 'File > Load and Clean ISI File'.

To extract the paper-citation network, select the ‘361 Unique ISI Records’ table and 
run 'Scientometrics > Extract Directed Network' using the parameters:

The result is a directed network of paper citations in the Data Manager. It has 5,335 p p g ,
nodes and 9,595 edges. 

To view the complete network, select the network and run ‘Visualization > GUESS’.
Run ‘Script > Run Script …’ and select ‘yournwbdirectory*/script/GUESS/paper-
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p p y y p p p
citation-nw.py’.
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NWB Tool for Scientometrics Research

1. Loading NSF datasets with currently active NSF funding for Indiana U, 
Cornell U, and Michigan U, extracting, and comparing Co-PI networks.

2 L di ISI fil f j t k i h t ti2. Loading ISI files of major network science researchers, extracting, 
analyzing and visualizing paper-citation networks and co-author 
networks.

3. Loading text files and detecting Bursts.
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Goto: http://sdb.slis.indiana.edu
Email: nwb@indiana.edu

Password: nwb
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http://sdb.slis.indiana.edu
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Open and Preprocess SDB zip file

Load medline_medline_master.csv to NWB.

Run ‘Preprocessing > Normalize Text’ with 

a space as New Separator.
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Burst Analysis

Run ‘Analysis > Textual > Burst Detection’ with parameters:

and space as a separator.p p

Sort result by burst weightSort result by burst weight
|| 

V
Word Length Weight Strength Start EndWord Length Weight Strength Start End

care 1 Infinity Infinity 1988 1988

water 1 29.8883 29.8883 2002 2002

countri 10 27.03612 27.03612 1990 1999

protect 1 26.88557 26.88557 2002 2002

farm 1 23.32114 23.32114 2005 2005

villag 2 23.273 40.65081 2008

crop 2 22.33649 30.42535 2008
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educ 2 22.14556 26.98588 1995 1996

blood 5 22.12166 22.12166 1996 2000

5. Discussion of Future Work

 Improving GUESS usability.

 Creating wizard for integrating compiled algorithms.

 Algorithms can communicate with other algorithms at run-
time using streams.

 Develop components to connect and query SDB.

 Customize Menu – Users can re-organize the algorithms for 
their needstheir needs.
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EpiC will Build on and Extend NWB
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Resources

Publications
 http://nwb slis indiana edu/pub html http://nwb.slis.indiana.edu/pub.html

Community Wiki, Tutorials, FAQ
 https://nwb.slis.indiana.edu/community
 http://nwb slis indiana edu/doc html http://nwb.slis.indiana.edu/doc.html
 GUESS Manual http://guess.wikispot.org/manual

Software
 htt // i h ll http://cishell.org
 http://nwb.slis.indiana.edu/download.html

Developer ResourcesDeveloper Resources

 http://cns-trac.slis.indiana.edu/trac/nwb
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